Welcome to the Codemasters Forums! Be sure to check the FAQ and Forum Rules before you get started.

Dirt Rally and Dirt 4 both unplayable after minor wheel/pedals changes

For starters, this is what I had before the issues started: CSW v2.5 with P1 rim, CSP V3 pedals, both connected separately to PC with USB. Everything was working fine.
Then I was messing with my setup a little so while at it, I connected the pedals to the base and also changed the P1 rim for the new F1 rim to try how it feels in a rally game.

And since then, both games have issues which make them unplayable. Dirt Rally doesn't recognise the wheel, only works as a controller. In Dirt 4 wheel is recognised just fine, all the inputs working but when I go for a freeride, the car doesn't move despite all the inputs are there - the car revs properly, upshifts and downshifts, handbrake isn't pressed but works as well etc. - but nothing happens, the car doesn't respond at all, no movement, no FFB response, nothing.

I tried to delete the setting in My documents folder, nothing. Tried to check the integrity of the files in Steam, nothing. Completely reinstalled both games, nothing.
All the other sim games had no issue at all after the hardware changes, on the contrary actually - in the F1 2017 I can finally bind the pedals properly.

Any help would be highly appreciated, it sucks when both rally games are unplayable.
Sign In or Register to comment.