Welcome to the Codemasters Forums! Be sure to check the FAQ and Forum Rules before you get started.

Dxinput Dirt4

Hey Guys, I have a Siatek P2900 and the game crashes whenever its plugged in.
What's new in Dirt 4 is I think they supported dx input. 

In older games it just wasn't supported. So I emulated Xbox360 controller and it worked fine.
I just need to figure out how to make the game think I don't have any direct input devices when the game turns on. 

In the config file there is a <input device_type="auto"/>
Obviously Auto is no good. I don't know what the options are. I want to force Xbox 360 controller since I am trying to emulate it. 

Can anyone help me out. 


  • campdudecampdude Member New Car Smell
    I've been trying to disable my device through here:
     <!-- Not Supported -->
        Devices here are defined to invalid action maps so no action map is assigned by default.
      <device id="{C626046D-0000-0000-0000-504944564944}" name="space_navigator" priority="0" type="not_supported"  />
      <device id="{046DBEEF-0000-0000-0000-504944564944}" name="space_navigator_driver" priority="0" type="not_supported" /> 
      <device id="{5F0D06A3-0000-0000-0000-504944564944}" name="saitek_rumble_force_pad" priority="0" type="not_supported"  />
      <device id="{030906A3-0000-0000-0000-504944564944}" name="saitek_rumble_force_pad" priority="0" type="not_supported"  />
      <device id="{030906F3-0000-0000-0000-504944564944}" name="saitek_rumble_force_pad" priority="0" type="not_supported"  />

    I just don't want it to be initialized by the game! But I can't figure out what I am doing wrong. I tried multiple Device ID numbers but its not happening. 
Sign In or Register to comment.