Welcome to the Codemasters Forums! Be sure to check the FAQ and Forum Rules before you get started.

When will the famous "D3D has been removed" error finally be resolved?

Because F1 2016 constantly crashed with the "D3D has been removed..." error I recently decided to buy F1 2018 hoping that that bug would have been resolved in the meantime. However, that problem still exists in F1 2018 making the game unplayable on my PC.

My PC configuration is as follows:
* Asus ROG Strix Z370-F Gaming motherboard
* Intel Core i7 8086K 4Ghz Turbo 5Ghz
* 32 GB Corsair VENGEANCE RGB DDR4 3000 MHz (2 x 8 GB)
* Gigabyte GeForce GTX 1080 Ti Aorus Xtreme Edition (11GB)
* 1TB Samsung 970 EVO M.2 PCIe NVMe

The PC runs rock-solid with any other program and very heavy workload like flight simulators. All components run on standard manufacturer specs (no overclocking).

After searching the web I already tried the following suggestions:
* Lowering all Graphics settings and texture detail settings
* Adding the -dxlevel 81 parameter to the program
* Adding the -safemode parameter
* Removing and re-installing GPU drivers
* re-installing DX drivers
None of the above suggestions could prevent the error.

Are there any solutions to this nasty bug?

Comments

  • SEYE2000SEYE2000 Member New Car Smell
    After playing for 3-4 laps and entering the pit, the game continuosly crashes and a message "D3D Device has been removed" shows. I'm running the game using my graphics card in Windows 10, my specifications should safely satisfy the game requirements and no problems should occur related to the graphic card.

    Here are the specifications of my laptop:
    HP Omen 15
    Intel Core i7 7700HQ @2.80GHz
    8Gb RAM
    NVIDIA GeForce GTX 1050
    All drivers up to date
    The GPU usage is configured so that it can only be used by games so that no other program/process utilices the GPU when playing.

    I've tried uninstalling and reinstalling the game without success, double checking the state of my drivers also without success.

    At this point, the game is simply unplayable, as I cannot even finish a single 5-lap race, the game just crashes before that.
  • hansmwhansmw Member New Car Smell
    In the meantime I downloaded the Aorus Engine utility from the Gigabyte site. My Graphics card was in gaming Mode, which appears to be the default, After setting it to "Silent"Mode I did not yet see the D3D error.
  • HooHoo Member, Codemasters admin
    Merged two threads on the same topic.

    The error is usually seen when there is a failure in the hardware, e.g. a power fluctuation or overheating, which causes the system to momentarily lose connection to the gfx card. Lowering GFX settings is unlikely to have much effect as this will result in higher frame rates which will create a similar load on your system. The suggested solution above to lower the load on on the card sounds like a good approach to increase stability if switching out power supplies or GFX cards is not an option. If you don't have access to anything to lower the GPU power demand, then capping framerate (either in game or through an external programme) might help.


  • hansmwhansmw Member New Car Smell
    Thank you all for your kind suggestions. So far so good and fingers crossed!
  • ChironTheseusChironTheseus Member Pit Crew
    "Your device is too powerful" would be a more useful error message lol! Hope it sorts it, thats one very nice graphic card! You may need several high end fans for that one hardware!
  • XCalinXXCalinX Member New Car Smell
    Hello folks,  
    Yesterday I upgraded from 2 GTX 1080s (the game was only able to use one anyway) to a 2080 Ti and I'm getting the D3D Device has been removed issue that a lot of people seem to be getting aswell. However, I never had that issue with the old setup in any F1 game. So it has to be something related to the GPU.  
    I tried removing the drivers with DDU and reinstalling them. It seemed to fix the issue (before I was getting the crash after a few seconds out on track and I once got it in the menus). But after 30 laps at Canada the unthinkable happened again...  
    What am I supposed to do? The GPU is rock solid in other games and I haven't overclocked it yet.
  • FayaFaya Member admin

    I’ve merged a couple of threads together that were about the same issue.

    There are a few suggestions through the thread that might help you further, @XCalinX ;


  • XCalinXXCalinX Member New Car Smell
    @Faya I'll try those when I get home but I don't think there's a problem with my GPU as it runs fine in other games.
  • FRACTUREDFRACTURED Member, Drivers Champion
    RTX OFF!!!

                       
                        
    Nice card.
    VIOLENCE. SPEED. MOMENTUM.

    The two time, 2016/2018 F1 Beta testing Champion of the World.
  • XCalinXXCalinX Member New Car Smell
    @FRACTURED Thanks but who cares that it's a nice card if I can't play F1 on it? lol
  • FRACTUREDFRACTURED Member, Drivers Champion
    Hopefully they get it working for you, its new technology, you're an early adopter! I'm interested to see what they can do with Ray Tracing in racing in the next few years, whats the point etc. But the DLSS should be helpful
    VIOLENCE. SPEED. MOMENTUM.

    The two time, 2016/2018 F1 Beta testing Champion of the World.
  • Iron09Iron09 Member New Car Smell
    Hi,
    I have problems with f1 2018, after a few minutes the game crash with error "The D3D Device has been removed! Reason: 0x887A0006"

    I've already tried updating the video card and directx drivers, but the problem is not solved. It is also impossible to play by lowering the graphic settings. Many users have the same problem but still no solution.
    I have an ATI R9290X and I have never had problems with other games, only with F1 2018.

    I tried several times to install the video card drivers and install the new drivers, I checked the integrity of the files using steam, but the problem was not solved.

    Sorry for the bad english
  • Tarou11Tarou11 Member New Car Smell
    edited October 14
    As for the blackscreen issue and if you are on Steam, you can try to launch the game from Steam in safe mode with the command "-safemode".
    To do so, right click on F1 2018 in your Steam library, click Properties, and Set Launch Options... Then insert the "-safemode" (without the "").

  • Jackk819Jackk819 Member New Car Smell
    Have had the same issue since launch, I have a R9 290.
    Can't even play career or multiplayer without it happening every time.
  • FayaFaya Member admin

    Hi there,

    I’ve merged two threads about the same issue. For the new comers, you may find helpful information in the posts above. Thanks,


  • supersnelsupersnel Member New Car Smell
    I have had the issue occur tree or four times in the 88 that I've played F1 2018 now. Restarting the pc sometimes helps but in my case, the issue occurs very unregularly. 2 times it occured after loading from one seesion to another in online and it happened once or twice when in the garage or on the track.

    Version: 1.[release]-1.10
    GTX 1060 3gb zotac mini
    AMD Ryzen 3 1300x 
    1080p resolution
    8 gb ddr4 ram @2400 MHz single channel, 1 stick
Sign In or Register to comment.