Welcome to the Codemasters Forums! Be sure to check the FAQ and Forum Rules before you get started.

graphical Bug during race

I stumbled upon a graphical bug during an online race. Does anybody know anything about it? I don't want it to happen again during an online race because it's pretty much a race ender...
https://plays.tv/video/5bba648e15e0df5c61/a-bug-that-cost-me-a-good-race-

Comments

  • QrazzoQrazzo Member New Car Smell
    So this is a bug that I had in last years game. For me it worked to alt tab out of  the game and get back into it. I play singleplayer most of the time, so for me this was not really as problem, but for you his may be different

  • FayaFaya Member admin

    Hi @loafcorn,

     That’s an interesting one. Could you let me know a couple of things so that we can try to track it down?

    • Can you confirm what platform you are on please?
    • Has it happened just the once or more than once?
    • If it’s happened more than once, does it happen in the same place/track? Or after a certain amount of time?
    • Could you give me a quick run down of your session up to the point you were affected?
    Many thanks,

  • loafcornloafcorn Member New Car Smell
    Hi @Faya

    Yeah, unluckily it is an interesting one as it appears I'm almost the only one that has these occurances.
    • I play on PC
    • Happened a couple of times already, up until this time only in career mode and once in TT. 
    • It can happen in almost every track. Last time it happened in career mode was Singapore, 2 races before the current one. Originally I thought it may appear after i use flashback, as it appeared in the first couple of races. Then I stopped using those, and it still appeared every now and then, albeit less frequent. The time plays almost no role in it. I had it once twice within 15 minutes, other times not at all in a week. 
    • I restarted the game before the session, joined it, we did short quali and started the race. I had no lag spikes whats-o-ever or any graphic glitches. It seemed like a normal session.

    Let me know if you need anything else, and I'll try to provide the necessary information. 

    Thanks for the help
  • FayaFaya Member admin
    Thanks, @loafcorn

    As your on PC, I'm going to ask if you can try a couple of things to see if they'll help at all. If these things don't work and you're still getting the graphical blackout issue, please send me the items at the bottom of this message so that we can try to replicate the issue here. 

    First off (if you've not already done so), please try validating your game. How to validate your files are just below if you're not sure. Then can you try updating all of your graphics drivers as well.

    Validating F1 2018 downloaded correctly

    1. Open Steam and go to the Library tab.
    2. Right click on F1 2018 and select Properties.
    3. Go to the Local Files tab and click verify integrity of game files.

    If after that, you're still getting the graphical blackout issue, please send us your Hardware Settings and a DXDiag. Many thanks!

    How to send us your in-game hardware settings file

    • Browse to your hard drive where windows in installed
    • Browse to "...\Documents\My Games\<game_folder>\hardwaresettings\"
    • Locate the file "hardware_settings_config.xml" and send this to us at community(AT)codemasters.com (replacing the (AT) with an @)

    How to save a DXDiag

    In Windows 7:

    1. Click on the "Start" Button.
    2. In the Search Box type dxdiag and press <Enter>. The DirectX Diagnostic Tool pop-up window should appear.
    3. Click on “Save all Information.”
    4. Save the information to your Desktop, keep the file name as is.
    5. Send the file to us at community(AT)codemasters.com (replacing the (AT) with an @ )

    In Windows 8, Windows 10:

    1. Press the [Windows]+[R] keys on your keyboard to bring up the Run command.
    2. In the "Run" command box, type in dxdiag and press <Enter>. The DirectX Diagnostic Tool pop-up window should appear.
    3. Click on "Save all Information."
    4. Save the information to your Desktop, keep the file name as is.
    5. Send that file to us at community(AT)codemasters.com (replacing the (AT) with an @ )
  • loafcornloafcorn Member New Car Smell
    Hi @Faya

    Thanks for the tips. I'll do the validation and get back to you as soon as I have an update. As I'm away for the next 2-3 weeks it might take some time. 

    Best regards

  • ChironTheseusChironTheseus Member Co-Driver
    Holy cow! The abyss actually swallowed you whole! Actually looked pretty good if that was part of a new F1 space wars edition..
    Carystus PS4 Pro
    "The fact is I don't drive just to get from A to B. I enjoy feeling the car's reactions, becoming part of it." ~Enzo Ferrari
  • loafcornloafcorn Member New Car Smell
    @Faya

    It appears to be that the email I tried sending to community[at]codemasters.com is undeliverable. 

    Is there another way to deliver the data?

  • FayaFaya Member admin
    Hi @loafcorn, thanks for letting me know about the email being undeliverable. Did you get an error at all? 
     


  • Tarou11Tarou11 Member New Car Smell
    Just to be sure @loafcorn , you did replace the (at) by the proper "@" symbol, right? I just sent them 2 files and had no issue.
  • loafcornloafcorn Member New Car Smell
    Hi @Faya , @Tarou11

    Yes, I did replace the at with an @, thanks for asking. ;-) 

    Sent them again from a different address and so far no error about it being indeliverable - albeit no answer yet either.
  • Tarou11Tarou11 Member New Car Smell
    edited October 2018
    loafcorn said:
    Hi @Faya , @Tarou11

    Yes, I did replace the at with an @, thanks for asking. ;-) 

    Sent them again from a different address and so far no error about it being indeliverable - albeit no answer yet either.

    You won't get an answer from this email address, it is just to send them files over.

    However I wrote to their customer support when the Steam update broke the trigger rumble controller, and I have been really impressed because I got an answer from them a few minutes or hours later. I thought, great, a company that does care about its customers and replies to emails, quickly moreover.

    Sadly, I think I was wrong since my issue is still not fixed after 8 days, even when the cause is known (Steam update), the affected file is known (Windows.gaming.input.dll), and it all worked fine before... Why am I telling you this? Don't hope your issue will be fixed anytime soon, you would be very disappointed.

  • MazokkiMazokki Member New Car Smell
    edited October 2018
    So when im racing, suddenly my screen starts going black, but its not like a normal black screen. It usually starts at the top of my screen, and it gradually "flows" down and finally everything goes black. Its almost looks like some kind of black liquid that slowly devours my whole monitor. This is really strange, and kinda scary D: . When I tab out and then go back in the game, everything is back to normal. But if im racing online this pretty much ruins my whole race. I used to have this happen with F1 2017 as well, but no other games. PC specs: i7 4790k, GTX 1080, 16gb DDR3 ram. 1440p 144hz monitor with G sync.

    Edit: I may have found a fix for this. Turned off  G sync, and turned on V sync, limited fps to 100. No black screen after that. Will update if the problem returns.

    Post edited by Mazokki on
  • kraM1tkraM1t Member Co-Driver
    I had this, turns out my memory overclock on the GPU was slightly too high, no problems with other games or benchmarks but this engine didn't like it apparently
  • FayaFaya Member admin
    Hi all,

    Both of these issues appear to be the same, so I've merged the threads. 

    Hi @loafcorn, I can confirm that we got your email through and the information was passed back to the team. The players above may have found a couple of work arounds that might work for you to?  

  • loafcornloafcorn Member New Car Smell
    @Faya

    Unfortunately I was out of town for the last 2 weeks so I was unable to test it yet. 
    I will update as soon as I tried. However, tabbing out is a no-no, as that is no solution to the cause but to the result. I will investigate the overclocking and see if the problem persists or not.

  • loafcornloafcorn Member New Car Smell
    Dear gents

    After a delay I'm back with an update. The bug occurs still occassionally, and I'm lost. I don't know what to do. The GPU isn't overclocked or anything. Has there been any news from the team investigating the issue?
Sign In or Register to comment.