Welcome to the Codemasters Forums! Be sure to check the FAQ and Forum Rules before you get started.

[SOLVED][PC]Thrustmaster T500RS F1 2018 FFB

DiffusionalDiffusional Member New Car Smell
Hello all, I bought F1 2018 more than a month ago and I was playing with Logitech F710 gamepad until yesterday. I got a Thrustmaster T500RS set and TH8A shifter so far I played Beam.NG Drive, Assetto Corsa and F1 2018 with it and apart from F1 I didn't have any problems with it. The problem with F1 2018 is there's no Forcefeedback, at all.  I tried it in Time trial, Grand Prix and on Multiplayer modes, no difference whatsoever. Also  I tried restarting game, pc, unplugging and plugging back USB's, changing Registry and creating new profile so far none of them worked, I hope you guys can solve my problem.

Edit: It also occured to me to try it in F1 2017 as well and it doesn't work in F1 2017 also.
Edit2: My games, software&firmware for steering wheel and shifter are all up to date.
Post edited by Diffusional on

Comments

  • DiffusionalDiffusional Member New Car Smell
    Today I decided to try it on a different computer and it worked on the other computer. So problem must be with mine. I deleted the game and installed it again but it didn't work.
  • steviejay69steviejay69 Member Petrol Head
    Today I decided to try it on a different computer and it worked on the other computer. So problem must be with mine. I deleted the game and installed it again but it didn't work.
    When you use the Thrustmaster CP is everything looking as it should be? Try the wheel without the shifter first and then introduce it.

    Use a USB 2.0 port, no hubs. Try removing other USB HID devices like the joystick dongle or desktop combos.
    I'm not stupid, I just don't always have all the necessary information,...stupid.
  • DiffusionalDiffusional Member New Car Smell
    To start with, thanks for your answer. Yes, on Thrustmaster Control Panel everything is normal. I did it like you said it, word to word still doesn't work.
  • steviejay69steviejay69 Member Petrol Head
    edited November 2018
    What version of Windows are you running? 7, 8.1 or 10? 32 or 64-bit? IF Windows 10 what is your version?

    Are you running an add-on rim for the T500 or the stock rim?

    I add the following as the check for updates function in the Thrustmaster CP does not ALWAYS notify you of updates.
    Changes made in new driver version 2018_TH8RS_1:
    
    - Addded support for TSS HANDBRAKE Sparco® Mod
    - Firmware update for TH8A Shifter: v27
    
    Your wheel’s Firmware version appears in the top right in the Control 
    Panel’s tabs:
    
    - Thrustmaster T500 RS Racing Wheel: V47
    I'm not stupid, I just don't always have all the necessary information,...stupid.
  • DiffusionalDiffusional Member New Car Smell
    I'm running 64-bit Windows 10 Pro, build 17134 . I'm using stock T500RS rim that came with it, I did check versions of both Steering wheel and TH8A they're latest version, I even deleted drivers and installed them back in case Something went wrong the first time but no difference whatsoever. 
  • DiffusionalDiffusional Member New Car Smell
    I tried my Logitech G710, rumble on that works. I still have no solution to my problem and it's annoying because I was dreaming about playing F1 2018 with a wheel for a long time.
  • steviejay69steviejay69 Member Petrol Head
    Remove the Thrustmaster drivers with Geek Uninstaller. Uninstall any Logitech software for the G710 (LGS or driver etc.) with same.

    Delete (or rename) hardware_config_settings.xml in My Documents\My Games\F1 2018

    Verify game files with Steam. (Disabling Steam cloud sync may be helpful).

    Install 2018_TTRS_3 drivers and restart.

    Check Thrustmaster CP for correct operation. Relaunch game and configure controller. Try ALT-TAB out and back into game if FFB is not working once you start to play.

    Good luck!
    I'm not stupid, I just don't always have all the necessary information,...stupid.
  • DiffusionalDiffusional Member New Car Smell
    I did these all in order you said and right now it works, thank you so much. I didn't install back the Logitech Gaming Software though, don't know if it's worth risking it.
  • steviejay69steviejay69 Member Petrol Head
    I did these all in order you said and right now it works, thank you so much. I didn't install back the Logitech Gaming Software though, don't know if it's worth risking it.
    Make a restore point and install it. If it goes to hell, restore and message Logitech with the issue. 

    More likely just nuking your TM drivers has fixed it. Good job!
    I'm not stupid, I just don't always have all the necessary information,...stupid.
  • DiffusionalDiffusional Member New Car Smell
    Downloaded LGS, FFB still works so no problems. Stevie, thank you for all your help, you're the #1 mate!
Sign In or Register to comment.