Welcome to the Codemasters Forums! Be sure to check the FAQ and Forum Rules before you get started.

Steering Device settings not saving

Trying to map my AccuForce and HE pedals to the controller settings with the new settings, but the settings do not persist after exiting the game.  I have to map my controls every time I launch the game.  Is this a known issue, or is there a workaround/fix?

Comments

  • zuzekmasterzuzekmaster Member New Car Smell
    I have the same issue with Logitech GT, I need to set up steerings every time.
  • RacingBaronRacingBaron Member New Car Smell
    Look here. ("In the first Screen of the game do not use the return button to start the game")
    Maybe it is also a workaround for you.



  • RacingBaronRacingBaron Member New Car Smell
    edited August 2015
    Look here.
    Maybe it is also a workaround for you.

    Edit:
    What ist wrong with this forum?
    Yesterday only my first post in this thread could be seen.

    @Moderator:
    Please delete this post.
    THX
    Post edited by RacingBaron on
  • RacingBaronRacingBaron Member New Car Smell
    edited August 2015
    Look here.
    Maybe it is also a workaround for you.

    Edit:

    What ist wrong with this forum?
    Yesterday only my first post in this thread could be seen.

    @Moderator:
    Please delete this post.
    THX
    Post edited by RacingBaron on
  • mrbedomrbedo Member New Car Smell
    The "press your controller's key at startup" fix doesn't work.  I set the game options to my wheel, and the next time I start the game not a single button one wheel, a pedal, or anything other than the Enter key works for getting past the initial load screen.
  • zuzekmasterzuzekmaster Member New Car Smell
    It's works for me, thx.

    @mrbedo, do not choose wheel presets, but define your steering changing keys in the keyboard presets.
  • mrbedomrbedo Member New Car Smell
    That works partially unfortunately.  It does seem to save my wheel gas and brake assignments, but once I change into H-Pattern + Clutch, it won't let me assign from my shifter.

    Assigning from my shifter ONLY works when overriding the non-default keyboard profile.
    However, if I go into another profile, setup my shifter and clutch, go back to the keyboard profile, I'm then able to assign the shifter and clutch.
    However, then it doesn't save.  :s

    I give up.
  • iratebeggariratebeggar Member New Car Smell
    @zuzekmaster  , do you know if this works for control pads (PS3 controller, etc) as well? Just wondering before I go home and try and then have to get back on the forum if it doesn't work. 
  • OzoreXSOzoreXS Member Race Steward
    This may be a estupid question. but. do you close the game "properly", I mean through menus?

    If you close the game via ALT+F4, for some reason settings will not be saved.
    RAM: G.Skill TridentX 2400 16GB || CHASSIS: Cooler Master Silencio 650 Pure || CPU: Intel Core i7 4790K 4,8Ghz || GPU: Gigabyte GeForce GTX 970 WindForce OC 4GB || PSU :Cooler Master G750M 750W || MOBO: Asus Z97 Pro Gamer || CPU Cooling: Cooler Master Seidon 120M || SSD: Samsung 840 Evo 250GB || HDD: ...many || Wheel: Logitech Driving Force GT

    >>"SEÑOR OZORES" on Steam!<<
  • mrbedomrbedo Member New Car Smell
    Yes, I close properly. Have you actually got it to save settings with a wheel, where the shifter and pedals plugin as separate USB devices?
  • OzoreXSOzoreXS Member Race Steward
    mrbedo said:
    Yes, I close properly. Have you actually got it to save settings with a wheel, where the shifter and pedals plugin as separate USB devices?
    Nope, sorry; since I own a stock Driving Force GT wich have just gas/brake pedals and no H shifter...

    The only thing I noticed was the commented.

    Hope you can get it solved soon, I guess it has to be easy to "fix". GL
    RAM: G.Skill TridentX 2400 16GB || CHASSIS: Cooler Master Silencio 650 Pure || CPU: Intel Core i7 4790K 4,8Ghz || GPU: Gigabyte GeForce GTX 970 WindForce OC 4GB || PSU :Cooler Master G750M 750W || MOBO: Asus Z97 Pro Gamer || CPU Cooling: Cooler Master Seidon 120M || SSD: Samsung 840 Evo 250GB || HDD: ...many || Wheel: Logitech Driving Force GT

    >>"SEÑOR OZORES" on Steam!<<
  • Rallyman164Rallyman164 Member New Car Smell
    okay I had the exact same problem when I went from a g27 to my current config
    I'm now running HE pro pedals, custom button box, sequential shifter, hydraulic handbrake and g27 that I have modified(while I build a osw)
    the issue (i think) is what the game considers joystick 1and how you start the game
    the fix for me was this
    download a great program called JoyToKey
    setup the joystick 1 in joytokey to the one you want to start the game with and map a key to be the Enter button. for me it was the button box
    now setup your custom setting in dirt rally and it should now be saved
    also don't forget to over ride them to steering wheels

    if you press enter on the keyboard then the game will think you now wish to use this and convert your setting back to default (that's how I think it happens anyway)

    hope this helps and good luck with it
  • mrbedomrbedo Member New Car Smell
    I tried the JoyToKey method, and unfortunately it does not work. I also don't see how the game would think you're using a steering wheel, when JoyToKey specifically emulates the keyboard, so the game should think you're pressing ENTER from the keyboard.

    Eitherway, I had high hopes for 0.7, but same issues.

    When I set the settings on the Keyboard settings, they save. However, I'm unable to assign gears 1-7.  I select a gear to assign to, and as soon as I shift my shifter (Fanatec SSQ) into a gear, the assignment changes from "WAITING" to "UNASSIGNED". It refuses to take the input.

    The only way I can assign all of my controls is to assign to one of the [STEERING WHEEL] profiles, but unfortunately they don't save, and the JoyToKey method does not work.


    To codemaster's devs:  
    How can you not get the controls right? No other game has such issues. This is ridiculous. 
  • DoohieDoohie Member New Car Smell
    Exactly the same here...
    With my G27 can I set up everything and then go to Load/Save Device Configuration to make a profile.
    As long as I do not quit the game, I can call it back or see the profile that I make under load device.
    Exit the game means also exit profile configuration....and consequently no .xml file in My Documents\My Games\DiRT Rally\wheelsettings.
    Help please !!
     



  • MisterBeepMisterBeep Member New Car Smell
    Hey Mr Bedo I don't know if you have seen this....it's from a gentleman that knows what he's doing.
    http://www.isrtv.com/forums/topic/17665-accuforce-and-non-supported-wheel-fix/
    i5-4690k @ 4.3GHz - ASUS Z97a - MSI GeForce GTX 970 Gaming 4G 4GB - GSkill 8GB DDR3 1866 - Realtek HD Onboard - 3x Dell 2209WA/nVidia Surround - Windows 10 x64 Home - Accuforce SimXperience Wheel - Main Performance PC SimPedals - Fanatec CSS 7sp - DSD Sequential - DSD Button Box - Z1 LCD Screen/Dashboard - Obutto Race Frame/Seat

    F1 2016 - pCARS - rFactor2 - Assetto Corsa - DiRT Rally - Automobilista - Raceroom Racing Experience - Race07 


  • mrbedomrbedo Member New Car Smell
    Yes, this was from a while ago. I was hoping this issue would have been fixed by now, but seems like only partially.
  • TonyRickardTonyRickard Member Pit Crew
    If you remap the pause button then the settings will not be saved. Leave the pause as default and all should be fine!
  • DT1959DT1959 Member New Car Smell
    For those who have a Thrustmaster T500RS, it is impossible to find a button giving the same result as the enter key. That is if you have selected the "Advanced mode" (25 buttons).
    You must choose instead the "normal mode" (13 buttons). Then press the Nr 6 button. It works !
Sign In or Register to comment.