Welcome to the brand new Codemasters Forums! Be sure to check the FAQ and Forum Rules before you get started.

Steering input lag in Dirt Rally

I've seen this problem posted both here and on the Steam forums. It seems to be affecting quite a few of us, regardless of OS or wheel. I've even seen it described with Dirt 3

Here's a video from within the controller menu. The lag is clearly noticeable in the steering input:


obviously this is under optimal conditions, the game is hardly running anything substantial so I know this is not a performance issue.
I have already talked to tech support but they were, ahem, less than helpful.

Really it would be nice if someone from Codemasters would even admit that this was a bug. Even better, since we're all paying customers would be if someone put in just the smallest of efforts to fix it or even help with troubleshooting this issue.
«1

Comments

  • OzoreXSOzoreXS Member Race Steward
    Hey, try unpluggin everything but keyb+mouse+wheel.


    RAM: G.Skill TridentX 2400 16GB || CHASSIS: Cooler Master Silencio 650 Pure || CPU: Intel Core i7 4790K 4,8Ghz || GPU: Gigabyte GeForce GTX 970 WindForce OC 4GB || PSU :Cooler Master G750M 750W || MOBO: Asus Z97 Pro Gamer || CPU Cooling: Cooler Master Seidon 120M || SSD: Samsung 840 Evo 250GB || HDD: ...many || Wheel: Logitech Driving Force GT

    >>"SEÑOR OZORES" on Steam!<<
  • Superd00psSuperd00ps Member Unleaded
    If your steering wheel is well used like mine,...take it apart and clean out the wheel pots with some good quality contact cleanear /lubricant. An while you're at it do the pedals as well. I had to do my pedals recently as I had a dead spot.
    ASRock z170 Extreme 7+, i6700K@4.6, Corsair H110i, 16G G.Skill Trident, SLi MSI GTX 1070 Gaming z 8G, 3-Way RAID0 Samsung 950/960 Pro m.2, BenQ XL2420Z, Corsair RM1000i, Corsair 750D, G27, Win10-64.
  • hakonphakonp Member New Car Smell
    Thanks for the help guys,
    This is however a brand new wheel, and this behavior is not seen in neither the configurator nor any other game
  • RaidoLeppRaidoLepp Member New Car Smell
    I have the exact same problem with my G25. Other games are fine. Im on Windows 10

  • ximistximist Member New Car Smell
    hello, did you find a solution to the problem ? I have exactly the same concern !!! I think many people have the same problem with nvidia card 
  • geovas77geovas77 Member New Car Smell
    I have the exact same issue with my CSW V2 wheel that works flawlessly in every other game out there. This problem persists through multiple game updates, fanatec and nvidia driver updates, even an upgrade from windows 8.1 to windows 10.

    Shame really cause Dirt Rally is the first codemasters title in a really long time that I find fun and worth playing but it looks like Codemasters is either incapable of fixing the issue or just doesn't care as it only seems to affect a relatively small amount of people.
  • DeputyDiRTDeputyDiRT Member, Codemasters Unleaded
    Hi Guys

    I would like to troubleshoot this issue as I have not encountered this using a G25 on Windows 10 using Nvidia GTX 570 with 355.82 and an AMD FX 6350.
    1. Are you using USB 2 ports? I have encountered some wheel issues using USB 3 ports which are logged with the dev team.
    2. Can this lag be observed during steering inside the Advanced Wheel Options menu in the steering test section?
    3. Open Task Manager > Select Performance > Open Resource Monitor  then run the game in a window. When the lag triggers see if any other software is spiking at the same time. 
    Thanks



  • OzoreXSOzoreXS Member Race Steward
    Avoid using USB hubs to connect your wheel. This worked for some people.
    RAM: G.Skill TridentX 2400 16GB || CHASSIS: Cooler Master Silencio 650 Pure || CPU: Intel Core i7 4790K 4,8Ghz || GPU: Gigabyte GeForce GTX 970 WindForce OC 4GB || PSU :Cooler Master G750M 750W || MOBO: Asus Z97 Pro Gamer || CPU Cooling: Cooler Master Seidon 120M || SSD: Samsung 840 Evo 250GB || HDD: ...many || Wheel: Logitech Driving Force GT

    >>"SEÑOR OZORES" on Steam!<<
  • DeputyDiRTDeputyDiRT Member, Codemasters Unleaded
    I managed to recreate this in Windows 10 using an AMD FX 6350 based system with the Thrustmaster TX wheel using the VIA USB 3.0 controller. This has been logged with the devs.  It doesn't occur using the USB 2.0 ports but this wont help with PC's that do not have USB 2.0 ports.

    It doesn't occur using USB 3.0 ports on another PC I tested based on an i5-4690K in Windows 7.


  • hakonphakonp Member New Car Smell
    Hey,

    my problem persists still. I'll just go through the list DeputyDirt posted earlier.

    1. I'm running USB 3 ports. Running on an Alienware 13 that I specked up to the newest i7 and Nvidia. No USB 2 available
    2. Yes it persist in the advance controls menu. Also keyboard commands lag intermittently.
    3. Ran the test. dwm.exe only program that came close to 10% cpu load. However the CPU was routinely spiking between 80-110%. The came ran considerably worse in windowed mode.

    Side note. Before buying my wheel I had used Input Mapper, a program that fools your PC into thinking your PS4 controller is an Xbox360. I ran the controller through the USB3 port with no lagging. Have no dea if that is helpful but here it goes.
  • NahkamarakattiNahkamarakatti Member Wheel Nut
    Has anyone managed to solve this issue? It's frustrating when this title is really starting to shine but the input lag drives you nuts. My wheel is connected through USB2.0 so there shouldn't be any issues with the port. Is this some fundamental issue with the Codemasters engine? Anyone have their F1 titles and is there similar issues with those ones?
  • TuliRallyTuliRally Member Wheel Nut
    edited September 2015
    Similar issues here
    Using Logitech DFGT and starting game from profiler (need to test without it)

    Problems starts:
    - After playing about 20 mins or
    - 3 stages (Edit: forgot to mention it gets worse after every stage)
    - restarted same stage about five times (when testing ffb settings etc)
    - going from full screen to Desktop multiple times (4 or more)
    - idle game for more than 10 mins

    Everything works after restarting game

  • hakonphakonp Member New Car Smell
    Running the new update .80 now. The lag between input and graphics seems to be fixed. However the WHOLE GAME LAGS NOW WITH THE WHEEL PLUGGED IN. Have tested this on multiple stages with wheel plugged in and without. Have tested it on multiple graphics quality setups and always the same lag with the wheel in and no lag without the wheel.

    This lag seems to be something different than the usual overload lag as well. Instead it seems to run on some sort of a pulsewith a very steady rhythm between the pulses.

    The status of the game right now is unplayable until patched.

    TuliRally. Before the patch I had a very similar sort of experience. I always had lag but it progressively became worse the longer I played and the more often I restarted.
  • PiotrAS191PiotrAS191 Member Unleaded
    I have the same problem, when I plug on wheel, the game stutters! My pc specs: Thrustmaster TX, GTX 970, I5-4590.
    "You will never know the feeling of a driver when winning a race. The helmet hides feelings that cannot be understood." - Ayrton Senna.
  • geovas77geovas77 Member New Car Smell
    I found the solution to my problem, it was caused by an external USB Hub I had connected to my PC. I now have to disconnect the hub and the lag is gone but it's not really practical since I am actually using the hub to connect my mouse and a a couple of other USB devices.

    At least I narrowed down the problem so hopefully Codies can look into it.
  • hakonphakonp Member New Car Smell
    I have seen this help with a few guys here. Over here I have no hub involved but still have the same problem whichever USB port I use.
    I really hope they get this thing fixed. Dirt Rally is the sole reason I got back into simming and bought this wheel in the first place. Am itching to drive through Finland at full speed.
  • m0LN4rm0LN4r Member New Car Smell
    I have relative big input lag with my dftg pedals, but not in AC or Pcars or simraceway
  • PorkhammerPorkhammer Member Champion
    edited December 2015
    New PC (Windows 7 Ultimate 64-bit, i5 4570, 16gb ram, GTX 960), and I have massive steering input lags with my G27. The steam compability thing is not an issue, nor the USB ports (tried both USB 2 and 3). It's like a constant deadzone in the steering.

    EDIT: It disappeared... and I did nothing. Seems legit.
    Post edited by Porkhammer on
    "it's the decisions you make, when you have no time to make them, that define who you are"
  • bradmaybradmay Member New Car Smell
    edited January 2016
    Input lag issue resolved on G27 by deleting registry key as in this post:

    http://forums.codemasters.com/discussion/38671/potential-stutter-fix-steam-compatibility-mode

    Hope it helps someone else so they can play this amazing game!

    Brad

    Edit:  Updated to reflect Codemasters forum post, this is the original: http://www.edugeek.net/forums/gaming/39417-fix-steam-thinks-its-running-compatibility-mode.html

  • hakonphakonp Member New Car Smell
    Hey Brad,
    thanks for the suggestion. I checked the registry but did not find any entry leading the steam.exe so no go for me.

    Just tried the game for the first time since the 1.0 release. Would have before but was travelling for the last month. The input lag is still there but without the graphics slowdown. So now the game is no longer ruinously unplayable but merely unplayable.
«1
Sign In or Register to comment.