Welcome to the Codemasters Forums! Be sure to check the FAQ and Forum Rules before you get started.

GRID Autosport (with all DLC) don't start on Linux / SteamOS

Hi,

I bought GRID Autosport - Pack ALL DLC via Steam on GNU/Linux (Fedora 24) but after clicking the START button, GRID logo is displayed in fullscreen mode but nothing else happens...
Please help CODEMASTERS !!

Comments

  • MTonlyMTonly Member New Car Smell
    edited April 12

    The same issue under Ubuntu 17.10 and 18.04, including 100% clean install to an empty drive.

    GRID Autosport hangs FOREVER at the starting logo splash screen.

    nVidia driver version does not matter: tested e.g. with 384.47, 390.48 and several versions in between.

    The game does NOT support Linux.

    My relevant hardware:

    • 4K monitor: Dell P2415Q connected via DisplayPort.
    • Graphics card: GeForce GTX 650 Ti BOOST (2 GB) (Gigabyte GV-N65TBOC-2GD).
    • Mainboard: Gigabyte GA-Z68X-UD4-B3.
    • CPU: Intel Core i7-3770T (4 cores).
    • RAM: 16 GB (4×4 GB, Hynix).
    Post edited by MTonly on
  • MTonlyMTonly Member New Car Smell
    edited April 21

    Looks like there is a trivial bug in GRID Autosport with comma as separator between integer and fractional number parts, and a workaround is changing regional format in Ubuntu settings to one that uses dot as separator instead:

    Region & Language → Formats → United States

    Thanks to madbad82 from the Steam community for the tip.

Sign In or Register to comment.