Welcome to the Codemasters Forums! Be sure to check the FAQ and Forum Rules before you get started.

Dirt Rally Crashing on splash screen (Steam)

VajootVajoot Member New Car Smell
Hi, I bought dirt rally last night and after a looonggg install I tried to play it and it doesn't want to start, it gets to the splash screen then just stops responding, does anyone know how to fix this? I've verified integrity, restarted my computer, restarted steam, tried anything I could think of. I know my laptop probably doesn't meet the minimum requirements but works fine on games with almost identical minimum requirements.

PC SPECS: 

Processor
Intel(R) Core(TM) i7-2630QM CPU @ 2.00GHz
 
Video Card
AMD Radeon HD 6700M Series
 
Video Card #2
Intel(R) HD Graphics 3000
 
RAM
8.0 GB
 
Operating System
Microsoft Windows 10 (build 10586), 64-bit

EDIT: Ended up fixing this after trying anything I could, all I did was reinstall (even though I really didn't want to due to the big download) then setting it to run as admin.
Post edited by Vajoot on

Comments

  • pablo2kellypablo2kelly Member New Car Smell
    I am having the same issue. Purchased last night - almost 3 hours to download & install. Double click on desktop Dirt Rally icon and a brief splash screen and crashes back to desktop. Reverifyed and same issue - Won't Start :-(

    What's up Codemasters/Steam??
  • XtraBeatsXtraBeats Member New Car Smell
    Hi,

    I'm having the same problem for almost 2 months. I bought DR a year ago and never had problems.
    I tried several things to get this crashed fixed, but none of them worked. I tried to:
    - Verify game cache.
    - Save the game folder from Steam, uninstall the game and then reinstall it from the save.
    - Unplug game controllers.
    - Reinstall an old graphic card driver (driver from a period the game used to work fine).
    - Removing a corrupt update.

    If it's possible, I would like to avoid to download more than 20Go again... and loose my game save btw.
    Really want to try it with Oculus Rift...

    Hope there will be a fix for this issue!
  • XtraBeatsXtraBeats Member New Car Smell
    Also tried to totally download the game again... Same issue :/
  • McCunMcCun Member New Car Smell
    edited January 2017
    I have a simmilar issue. When I click the button PLAY (on Steam) my avatar turns green as if I started playing Dirt Rally, but after a couple of seconds (the game crashes) my status is reverted back to online and not playing the game anymore. This has started on the 12. of January right after Win 10 X64 installed the horrible KB3213986 patch which ruined multi-monitor gaming. So I was wondering if perhaps I'm affected as well, but I don't have a multi-monitor setup but I do have a TV as my monitor.

    I've tried to verify integrity, deleted DRT.exe, deleted the Dirt Rally folder in my documents (to reset graphical settings) and god knows what else but to no avail. My specs are:

    CPU - i7 860
    MOBO - ASUS Maximus Formula
    RAM - 8 GB @ 1600
    GPU - 6950 with 15.7.1 drivers (officially the latest stable)
    OS - Win 10 X64

    Any suggestions? :'(

  • mitchc1985mitchc1985 Member New Car Smell
    Same exact issue here. Glad it's not just me.
  • mitchc1985mitchc1985 Member New Car Smell
    @CMMcBabe Any ideas? I've purchased the game through Steam AND the Oculus store, and tried every crash related fix I can dig up on the net.
  • XtraBeatsXtraBeats Member New Car Smell
    Well, I tried to install the game on my other computer (laptop) by downloading it from Steam and there were no problem, the game launches correctly.

    @McCun For me it started last October, I don't think it's a 100% Windows related problem... 

    Could it come from a hardware issue?
  • DidierDemangeDidierDemange Member New Car Smell
    même problème
    pas de pro dans le coin ??? 
  • Superd00psSuperd00ps Member Unleaded
    Dirt is kinda finiky with usb stuff, so I would start by disconnecting usb devices first, anti virus, backround running programs etc.
    ASRock z170 Extreme 7+, [email protected], Corsair H110i, 16G G.Skill Trident, SLi MSI GTX 1070 Gaming z 8G, 3-Way RAID0 Samsung 950/960 Pro m.2, BenQ XL2420Z, Corsair RM1000i, Corsair 750D, G27, Win10-64.
  • IntoTheTreesIntoTheTrees Member New Car Smell
    For me, this problem related to the number of cores my PC was using.
    To anyone with four or more cores to their CPU, this might work for you too (i was using Windows 10 at the time):
    1. hit start, type 'msconfig.exe' in search
    2. the executable should be the first result - open it. On Windows 10 it has the subtitle 'Run command'
    3. switch to the 'Boot' tab of the window that opens
    4. click 'Advanced options...'
    5. tick the 'Number of processors' box
    6. using the dropdown box, select '4' as your number of cores
      --> If you have less than 4, try the highest number of cores you have. If you have more 4, still choose 4.

    My computer had 5 cores but was booting with 1. Setting this option to 4 made DiRT Rally fire up on first try and every try since.
    Best of luck. Hope this helps someone.
Sign In or Register to comment.