Welcome to the brand new Codemasters Forums! Be sure to check the FAQ and Forum Rules before you get started.

Multiplayer - Hosts FPS gets worse as people disconnect

CodiesBlogBotCodiesBlogBot Member, Codemasters, Drivers admin
This discussion was created from comments split from: [1.8] FPS drop to ~10 after first race.

I am the Codies Blog bot, bringing you all the latest news from www.codiesblog.com. I am not human.

«1

Comments

  • ChokDKChokDK Member, Drivers Wheel Nut
    Having a talk about this issue with the other F1 2016 hosts at AOR in this thread http://apexonlineracing.com/community/threads/aor-pc-split-3-main-thread.15700/page-14#post-316147 

    The problem seems to have been worse after 1.0.8 (but not 100% confirmed) and several earlier hosts mention that it is when drivers disconnect the problem starts (for the host).
    The more drivers the more low FPS/lag when people disconnect.
    @Lozzy would love a word on this and hoping for a possible suggestion for a solution.

    ♥ Let's have TOCA 2 tracks and cars back please! ♥

  • LozzyLozzy Member, Codemasters Champion
    Hi @ChokDK I've made this a new tread because this is not the same as the other FPS issue that some people have reported post patch 1.8.

    I'll do some investigation in to this problem but it sounds like I'm going to need as close to 22 players and therefore PCs to see this issue occur so it's not going to be trivial to investigate.

    I don't suppose anyone has seen this happen on PS4 or Xbox One have they?
  • ChokDKChokDK Member, Drivers Wheel Nut
    Hi @Lozzy
    Thanks a lot to investigate.
    It's no problem at all to find 22 WAN players if you want something to be tested.
    We can invite you to participate as a "driver" or as a host.
    Feel free to PM me if you prefer.
    Regards
    ChokDK

    ♥ Let's have TOCA 2 tracks and cars back please! ♥

  • ChokDKChokDK Member, Drivers Wheel Nut
    Ready for some hosting if needed :)
            

    ♥ Let's have TOCA 2 tracks and cars back please! ♥

  • LozzyLozzy Member, Codemasters Champion
    Oh how other countries internet makes me feel inadequate.

    Leave it with me for a while, if we're struggling to get the numbers or can't make it happen I'll be in touch @ChokDK.
  • massa88massa88 Member New Car Smell
    edited February 12
    lately is not good to be host of the lobby
    I saw this last night, when I was host
    every time someone joins or leaves lobby fps drops during the race
    Lozzy good luck in finding this bug or whatever it is
    Post edited by massa88 on
  • DH1806DH1806 Member, Drivers New Car Smell
    Hey Guys,
    I'm racing in leagues as a pretty fast driver and I got the same problem since the 1.8 patch: In the lobby, loading screen and (thats the worst thing) before the start procedure I have very, very low FPS (this means down to 4-6). In the race, formation lap, qualy etc is everything fine and I have ~80 FPS as always (also if the first person crosses the finish line).
    This causes that I am always the person who has to wait the longest in the loading screen (like 1 minute longer than before the patch), I can't change my setup before the start cause it takes more than 30 seconds to open that tab and - thats the worst thing - because of these 4 FPS when the red lights are on I always start alot later than all the other people. I guess it's because they have a better PC than me (which doesn't mean that mine is bad, and before 1.8 patch everything was fine) and that destroys every league race for me already before it even started.
    In the race today I got the pole position by 0,007 in a lobby with 18 drivers, and I knew that I would fall back with like 10 positions already before the race. And it was Brazil, a very short way from the start to the first corner.

    I've put the starts into a video, first a start before the 1.8 patch (you see everything is normal), then the way it lags in the pre-race settings and then 3 of my starts after the 1.8 patch. It feels like it gets worse if more people are in the lobby.



    In the way it is at the moment it makes it impossible for me to do (competitive) league racing. All my races will be lost on the start. We also have a guy who has a very good PC and he has amazing starts since the 1.8 patch is there so he has an unfair advantage of that too.
    I really hope that this will be fixed, I do league races 3 times a week, I was beta tester for this game and in my opinion it is really the best game so far. I really enjoyed racing in this game, but this new bug after patch 1.8 destroys it for me completely :(
    I hope you will take a look in this @Lozzy

    Greetings
    DH1806
  • ChokDKChokDK Member, Drivers Wheel Nut
    I got to add that "my" problem started before 1.0.8 patch.
    Before me, 2 others were hosting but they complained about this issue - hence I wanted to host as I got a great connection and a pretty okay PC (i7, 12 gb ram, 960 GTX, SSD), but I got into this as well.
    No other programs running while gaming except firewall.

    I can't tell if this have become worse or not after 1.0.8 as I wasn't hosting for more than 4-5 players before that (practise stuff).
    But I guess that MP will loose interest if it is a fight about not being a host :/

    ♥ Let's have TOCA 2 tracks and cars back please! ♥

  • FoxOneeFoxOnee Member New Car Smell
    A fast solution, you can not continue like that! Persistent bug with a large number of players.

     :( 
  • ChokDKChokDK Member, Drivers Wheel Nut
    Just info @Lozzy
    Hosted a 20 car race with that "giant speed connection" and the lag was there alright when people disconnected one after the other (rain) but I found out it disappeared again when I was not close to any other cars..

    ♥ Let's have TOCA 2 tracks and cars back please! ♥

  • D4rioD4rio Member Unleaded
    DH1806 said:
    Hey Guys,
    I'm racing in leagues as a pretty fast driver and I got the same problem since the 1.8 patch: In the lobby, loading screen and (thats the worst thing) before the start procedure I have very, very low FPS (this means down to 4-6). In the race, formation lap, qualy etc is everything fine and I have ~80 FPS as always (also if the first person crosses the finish line).
    [..]
    Yeah i got the exact same issue as yours... 
  • LozzyLozzy Member, Codemasters Champion
    @ChokDK please just clarify is the issue a drop in framerate or an increase in latency to other players?
  • ChokDKChokDK Member, Drivers Wheel Nut
    edited February 17
    @Lozzy it's not that easy to answer.
    I did a recording on this race as well and my FPS was running.
    It doesn't show anything is "bad" (recording was 30 FPS)
    I remember the car feeling jerky/jittering, and about 6-7 drivers had left the race at that time.
    However, in the first vid I linked to, the car was feeling much worse and non steerable, and the FPS was dropping way below 60.

    Don't hesitate to ask for anything we can do to bring more info, we are eager to get this solved :)

    Link to "Vid 2" (latest) Lap 26 close racing https://www.youtube.com/watch?v=pqmFpQFfwrA&feature=youtu.be&t=2788
    Link to "Vid 1 (the first) Lap 28 low FPS: https://youtu.be/po9EEuXcvWw?t=3666

    ♥ Let's have TOCA 2 tracks and cars back please! ♥

  • massa88massa88 Member New Car Smell
    edited March 2
    Hi i have little update in relation to  FPS drop after the last patch
    today online I noticed  :created lobby  and selected team and driver, and then pressed x enable career driver FPS goes down from 60 to 55 and press again for disabled customized driver and fps went back to  60  I repeated several times and has always happened  same 
    I noticed also, if more people choose career driver fps drops even more
    Post edited by massa88 on
  • FoxOneeFoxOnee Member New Car Smell
    Always the same problem with the lobby, large number of players, drop fps = 7. Patch planned? Help us, communities that organize championships and make the game live...
  • MickeyMoTiOnZMickeyMoTiOnZ Member New Car Smell
    Have you tried turning vsync on. It sucks having to turn it on but that resolves a lot of problems for Codemasters F1 games. It sorted out my Logitech Force Feedback problems with two different wheels. 
    First ever F1 Youtube Director. (Youngroup 2009, xscop3gaming 2010, MickeyMoTiOnZ 2011, MickeyMickeyMoTiOnZ/OversteerNetwork 2015) 
    ------------------------------


  • DH1806DH1806 Member, Drivers New Car Smell
    massa88 said:
    Hi i have little update in relation to  FPS drop after the last patch
    today online I noticed  :created lobby  and selected team and driver, and then pressed x enable career driver FPS goes down from 60 to 55 and press again for disabled customized driver and fps went back to  60  I repeated several times and has always happened  same 
    I noticed also, if more people choose career driver fps drops even more
    Man thanks for that information, we will try out that in our leagues next weekend, but sounds good. Thanks for your information!
  • ChokDKChokDK Member, Drivers Wheel Nut
    Arrgh.. race completely destroyed by server lag.
    This was my last hosting.
    I'm sorry to see there was no solution for this problem :(

    ♥ Let's have TOCA 2 tracks and cars back please! ♥

  • DH1806DH1806 Member, Drivers New Car Smell
    A big thanks to @massa88 : You found the solution for the FPS Bug!
    It was really like you said, if people pick their career driver the FPS drop more and more, we tried it out in our league this firday when nobody took his career driver - and it worked just as perfect as it was before the bug. Thanks alot man!

    For all others with the problem (CM didn't seem to fix it or find out that the problem is): This is how you can fix the bug and have normal competitive races again :)
  • HubaBubaVHubaBubaV Member New Car Smell
    Эй разрабы, может вы оторвёте свои толстые задницы и наконец исправите этот чёртов баг с падением ФПС в меню? Или хотя бы заблокируйте в игре по сети возможность выбирать свой профиль пилота. За что люди деньги платили, что бы были лаги изза какойто мелочи?
«1
Sign In or Register to comment.