Welcome to the brand new Codemasters Forums! Be sure to check the FAQ and Forum Rules before you get started.

Steering wheel not detected anymore (Logitech Driving Force Pro)

main80main80 Member New Car Smell
Dear forum, after the D4 announcement I got hyped so much I wanted to do some more racing in Dirt Rally again. Last time I raced was 22.12.2016. Everything worked great that time. Launched the game last week and my Logitech DFP wasnt detected ingame, it works great in other games, cant play Dirt Rally anymore. Is there something devs or I can do to fix that?

Many thanks
Desperate fan
main
Post edited by main80 on

Answers

  • versediversedi Member Champion
    Do you have Nvidia Experience installed? Which version?
  • main80main80 Member New Car Smell
    edited February 14
    versedi said:
    Do you have Nvidia Experience installed? Which version?
    I have NVGE, used it all the time to record Dirt Rally before. Current ver I have is 3.3.0.95, not using eperimental, and todays GPU driver
    Post edited by main80 on
  • versediversedi Member Champion
    Try following steps from here, it might help but no assurance:
    http://forums.codemasters.com/discussion/46442/nvidia-experience-issues#latest
  • main80main80 Member New Car Smell
    thanks Versedi for your effort but no luck, I dont have any of those processes running.
    this is a bummer, cant play what i paid for and what i like :(
  • DytutDytut Member Team Principal
    Does your wheel show up as an option in the controller settings in DR?
    Arete or 43. M. Andersson on steam/leaderboards.


  • main80main80 Member New Car Smell
    Dytut said:
    Does your wheel show up as an option in the controller settings in DR?
    It doesnt. All I get it to pick from two keyboard layouts, the game doesnt detect the wheel, any other game does, was working great before no problem.
  • TURBODEVIN19TURBODEVIN19 Member Petrol Head
    edited February 16
    Does your wheel show up correctly in Logitech Profiler?
    I used to have the Logitech Driving Force GT, and last year Windows (I guess) started automatically updating my drivers to an incompatible one, resulting in showing some legacy wheel in Logitech Profiler and the wheel not working ingame, reinstalling the old drivers fixed it for me.

    These should work for you:
    http://support.logitech.com/en_us/product/driving-force-pro

    Not sure this fixes your issue but might be worth a try.


    Steam
    : turbodevin | GFWL: TURBODEVIN19 | Twitter: turbodevin

    DiRT | DiRT 2 | DiRT 3 CE | DiRT Showdown | DiRT Rally VR | DiRT 4 | DTM Race Driver 3 | GRID | GRID 2 | GRID Autosport LBE | F1 2013 CE | Toybox Turbos

    Thrustmaster TX Racing Wheel Leather Edition
  • Alf72Alf72 Member Co-Driver

    Last year, many of us with Logitech wheels, suffered from what @TURBODEVIN19 describes in his post. At that time, i made a thread on Steam, about the issue.

    Thread has some solutions to the issue, particularly the vídeo in the thread has a fix that worked for lots of people so, you might wanna check. Video is for G27 but Works for all Logitech wheels.

    http://steamcommunity.com/app/310560/discussions/0/357286663687079488/

    CMR | DiRT | DiRT 2 | DiRT 3 | DiRT Showdown | DiRT Rally | DiRT 4 | GRID | GRID 2 | GRID AutoSport | F1 2013

    Wheel - G27 | Pedals - G27 w/ Nixim Springs | Shifter - G27 | Handbrake - Extreme 3D Pro

    " Good drivers have dead flies on the side windows " - Walter Rohrl

  • main80main80 Member New Car Smell
    TURBODEVIN19: yes the wheel shows up correctly in Logitech Profiler, both before and after I did what Alf72 suggested, i always had the correct wheel in the profiler

    ALF72: after trying the fix in the video you posted still no luck
  • main80main80 Member New Car Smell
    Just wanted to say, that my wheel still doesnt work after I tried so many things, it works great with any other game - Assetto Corsa, Project Cars etc.

    In february I emailed to the support at dirtgame@codemasters.com, no answer at all, so dont even bother guys.

    I paid for the game I cant play so thats all done right? Well I dont think so.

  • DidzisDidzis Member Team Principal
    Not showing up as a preset is one thing but did you try just binding buttons to it?
    i5-3350P | Be Quiet! Shadow Rock 2 | MSI B75A-G43 Gaming | MSI HD7870 OC | Kingston HyperX Red 8GB | Kingston SSDNow V300 120GB | WDC Blue 1TB | Corsair VS550 | Fractal-Design Core 3000 | Logitech Driving Force GT

    DiRT2 | DiRT3 CE | DiRT Showdown | DiRT Rally | GRID | GRID2 | GRID Autosport
  • main80main80 Member New Car Smell

    Didzis said:

    Not showing up as a preset is one thing but did you try just binding buttons to it?


    I did, nothing works apart from the Dpad on the wheel, which for some reason responds as WASD
  • dgeesi0dgeesi0 Member Champion
    if the wheel is not faulty it will work. i know i use one.its fine with win 10 / win 7 aslong as you dont go through geforce experience or have certain win 10 updates installed.

    if you are upto date with win 10.remove all traces of logitech drivers and cfg. make sure hidden folders can be seen and remove all traces of logitech.

    then reinstall.dont put usb for wheel in until it tells you to when installing.common mistake.
Sign In or Register to comment.