Welcome to the brand new Codemasters Forums! Be sure to check the FAQ and Forum Rules before you get started.

FPS Drop / Performance hit when Fanatec Clubsport Wheel is plugged in upon launch

Bobpies2Bobpies2 New Car Smell

So, I sat and debugged this problem I am getting for hours and managed to pin it down to what looks to be the Clubsport wheel base.


To reproduce the error:

If I drive in a straight line and slam on the brakes I get a huge performance dip causing the FPS to drop from 90fps all the way to its failsafe of 45fps when using my Oculus Rift.

Now - if I use the keyboard to initiate acceleration and braking (with the clubsport still plugged in) I STILL get the performance dip.


Here's where things get weird(er)

If I turn the Clubsport wheel base off - and use the keybaord to accelerate and brake, the performance is now perfect it maintains a steady 90fps no performance dip / no fps drop whilst braking.

If I then turn the wheel base back on and reassign everything from the in game menus - the performance REMAINS perfect. Until i got back to the menus and selected another track - at which point we are back to square 1.


I do not have any logitech profiler apps running etc. - i did have Fanaleds running but disabled it and the problem remains.

I use simcommander / i bypassed this and the problem is still there.


Has anyone else got this problem?

p.s. i had to create this post on a new account as for some reason the forums is bugging out when i sign into my original account?

Comments

  • Bobpies2Bobpies2 New Car Smell
    edited February 16
    seems this has been mentioned before
    https://steamcommunity.com/app/310560/discussions/0/523890046868696527/?ctp=4

    possible solution re: deleting drivers for the wheel did nothing...


    Post edited by Bobpies2 on
  • Bobpies2Bobpies2 New Car Smell
    So i can confirm after again - a lot of testing.

    Start race with fanatec clubsport wheel connected - Frame rate dips every time i hit the brakes - dropping to 45. i have to run low shadows, no ground cover.

    Turning the wheel off, and back on again mid race - going through the setup of the buttons again results in a perfect 90 FPS
    i can even turn on Ultra Shadows and ground cover 1.6 super sampling etc. etc. and its perfect 90 fps the entire time. its crazy.

    starting a new race and im back to square one again.

    something sinister is happening when i get back to the menus - whats going on???? i don't want to have to reset my wheel up every stage!



  • With everything connected, delete the My Documents\My Games\Dirt Rally folder. Start DR and it should redetect all your hardware. Are you using the latest video card drivers?
    If using Nvidia Experience=disable.
    Disable/uninstall Oculus Rift.
    ASRock z170 Extreme 7+, i6700K@4.6, Corsair H110i, 16G G.Skill Trident@3466, MSI GTX 1070 Gaming z 8G, Samsung 950 Pro m.2 RAID0 and Samsung EVO850 500G SSD, BenQ XL2420Z, Samsung DVD, Corsair RM1000i, Corsair 750D, G27, Win10-64.
  • Bobpies2Bobpies2 New Car Smell

    So I found 2 solutions to my problem.

    Disabling a line in the hardware config xml file (fanatec = true) or similar gave me the same performance I was getting from turning the wheel off and back on again.

    However on testing a bit further, what it was actually doing was disabling rumble to the pedals and engine rumble to the wheel.

    The reason both these values were causing a problem was linked to USB bandwidth it seems. Providing both those extra bits of feedback (i.e. when braking ) was choking the USB bandwidth it seems.

    Taking the club sport and going direct to the motherboard input stopped the choke and I can now run at full 90fps with all bells and whistles.


    TL;DR 

    club sport wheel base causing frame rate dips resolved by going direct to USB 3.0 on motherboard 

    Problem was USB bandwidth for force feedback to the wheel and pedals

  • Glad you solved it.
    I also responded to your post on Steam and suggested going directly to the back I/O panel of the motherboard as well. What you will also find is disabling any sort of power management in the BIOS/UEFI,...usually in the chipset section, AND setting your OS power management to "High performance" will also help, by disabling hardware sleep modes. If you use your PC mainly for gaming disabling "C States" and Intel Speedstep will also give a little boost overally for gaming and reduce the chances of stuttering and pausing.
    ASRock z170 Extreme 7+, i6700K@4.6, Corsair H110i, 16G G.Skill Trident@3466, MSI GTX 1070 Gaming z 8G, Samsung 950 Pro m.2 RAID0 and Samsung EVO850 500G SSD, BenQ XL2420Z, Samsung DVD, Corsair RM1000i, Corsair 750D, G27, Win10-64.
  • Bobpies2Bobpies2 New Car Smell
    Glad you solved it.
    I also responded to your post on Steam and suggested going directly to the back I/O panel of the motherboard as well. What you will also find is disabling any sort of power management in the BIOS/UEFI,...usually in the chipset section, AND setting your OS power management to "High performance" will also help, by disabling hardware sleep modes. If you use your PC mainly for gaming disabling "C States" and Intel Speedstep will also give a little boost overally for gaming and reduce the chances of stuttering and pausing.

    Hey
    so it seems I spoke too soon

    the issue was back in full force again today - and appears to be unrelated to the USB slots.

    So the solution I have found is this - go to the hardware_config xml in the user documents area, and edit the line
    <fanatec enabled="true" pedalVibrationScale="1.0" wheelVibrationScale="1.0" ledTrueForGearsFalseForSpeed="true" />

    change it to
    <fanatec enabled="false" pedalVibrationScale="1.0" wheelVibrationScale="1.0" ledTrueForGearsFalseForSpeed="true" />

    then install FANALEDS, and enable the engine & brake feedback so that you get the same forces sent to the pedal.

    No idea why it decided to revert back today, perhaps because I was messing with the xml file and it was using one in memory - no idea. but with fanatic enabled = "true" - the performance is terrible (when hitting the brake pedal)

    in this current setting - the wheel is feels slightly lighter, but the FF can be dialed up to compensate




  • If you're editing the hardware file in My Games\DR folder it may not stay. I think you have to go to the files in the Steam\DR folder:
    C:\Program Files (x86)\Steam\steamapps\common\DiRT Rally\system
    ASRock z170 Extreme 7+, i6700K@4.6, Corsair H110i, 16G G.Skill Trident@3466, MSI GTX 1070 Gaming z 8G, Samsung 950 Pro m.2 RAID0 and Samsung EVO850 500G SSD, BenQ XL2420Z, Samsung DVD, Corsair RM1000i, Corsair 750D, G27, Win10-64.
Sign In or Register to comment.