Welcome to the brand new Codemasters Forums! Be sure to check the FAQ and Forum Rules before you get started.

Dirt 4 PC Stutter 60fps.

24

Comments

  • versediversedi Member Champion
    Phire said:
    I am having the same issues stutters like crazy to the point I cant play its driving me mad I am going back to play Dirt rally
    Please fix I am using a g29 wheel with usb controller as a hand brake
    Did you tried if the issue persists when you disconnect the wheel and USB controller (handbrake)?
  • versediversedi Member Champion
    edited June 12
    Support email is:

    dirtgame@codemasters.com
  • CMMcBabeCMMcBabe Member, Codemasters Co-Driver
    Could you send the files to dirtgame@codemasters.com please?  I can grab them from there.
  • HinjimaHinjima Member New Car Smell
    CMMcBabe said:
    Could you send the files to dirtgame@codemasters.com please?  I can grab them from there.
    Sent you Dxdiag and MSinfo32.  I tried to play Dirt 4 again with wheel / shifter but not keyboard and mouse plugged in and it was a stuttery mess, I tried with only keyboard and mouse and it was silky smooth.  Let me know if you need anything else.
    Hinjima.
  • siffonensiffonen Member New Car Smell
    Same thing happening here with T500RS, i had this problem with F1 2015 & 2016 and in Dirt Rally.
    In those games i managed to fix this by connecting my wheel straight to pc without my usb hub but that wont work with this.
    No issues with W7 in those games when using my hub, but with W10 the problems starts.
  • HinjimaHinjima Member New Car Smell
    siffonen said:
    Same thing happening here with T500RS, i had this problem with F1 2015 & 2016 and in Dirt Rally.
    In those games i managed to fix this by connecting my wheel straight to pc without my usb hub but that wont work with this.
    No issues with W7 in those games when using my hub, but with W10 the problems starts.
    Oh wow thats plenty games, I have only had this issue in Dirt 4 so far.. I know many had this problem in Dirt Rally but they patched it and it fixed it for me atleast.  No issue with any other game ( Dirt Rally / Assetto corsa / Iracing / Dirt 3/Showdown and Need for speed. )
  • siffonensiffonen Member New Car Smell
    Hinjima said:
    siffonen said:
    Same thing happening here with T500RS, i had this problem with F1 2015 & 2016 and in Dirt Rally.
    In those games i managed to fix this by connecting my wheel straight to pc without my usb hub but that wont work with this.
    No issues with W7 in those games when using my hub, but with W10 the problems starts.
    Oh wow thats plenty games, I have only had this issue in Dirt 4 so far.. I know many had this problem in Dirt Rally but they patched it and it fixed it for me atleast.  No issue with any other game ( Dirt Rally / Assetto corsa / Iracing / Dirt 3/Showdown and Need for speed. )
    Yeah, its only Codemasters games that i have this stutter/lag issue, and those other games worked fine with W7. This doesnt has such bad stutter than those so i can play it with my wheel but still its annoying
    Assetto Corsa, Project Cars, etc are working fine with W10 and my usb hub. 
    Really weird issue
  • HinjimaHinjima Member New Car Smell
    siffonen said:
    Hinjima said:
    siffonen said:
    Same thing happening here with T500RS, i had this problem with F1 2015 & 2016 and in Dirt Rally.
    In those games i managed to fix this by connecting my wheel straight to pc without my usb hub but that wont work with this.
    No issues with W7 in those games when using my hub, but with W10 the problems starts.
    Oh wow thats plenty games, I have only had this issue in Dirt 4 so far.. I know many had this problem in Dirt Rally but they patched it and it fixed it for me atleast.  No issue with any other game ( Dirt Rally / Assetto corsa / Iracing / Dirt 3/Showdown and Need for speed. )
    Yeah, its only Codemasters games that i have this stutter/lag issue, and those other games worked fine with W7. This doesnt has such bad stutter than those so i can play it with my wheel but still its annoying
    Assetto Corsa, Project Cars, etc are working fine with W10 and my usb hub. 
    Really weird issue
    Its a very strange issue, with only keyboard and mouse my game is silky smooth. I uploaded a video where I disable both keyboard and mouse and run the game with only the wheel and shifter in... take a look for yourself lol, recorded in native 4k 60fps so its easier to see.  Its very strange cause it keeps dipping to 56 and 57 fps and jumps back up to 60, it still stutters at 60fps though.


  • CMMcBabeCMMcBabe Member, Codemasters Co-Driver
    Are any of you running Game Mode from the Creators Update to Windows 10?  If so, could you try disabling it please?
  • HinjimaHinjima Member New Car Smell
    CMMcBabe said:
    Are any of you running Game Mode from the Creators Update to Windows 10?  If so, could you try disabling it please?

    Hey! I am running a slightly older version of Windows 10 due to issues with creators update.  I am using version 1607 known as Anniversary Update.
  • Shaoling74Shaoling74 Member New Car Smell
    edited June 13
    I have a similar issue here.

    I noticed it the first time when I drove through the town in Spain. My FPS on Ultra dropped to 42 with an i7 6700k GTX 1080. Unplugging the wheel raised it to 67 in the same spot.
    After some testing I see that whenever the wheel is plugged in my FPS drops by 20-30 on average. With the wheel plugged in I never saw more than 85fps anywhere. With it unplugged my average is around 90-120. I don't get stutter, it just permanently lowers my fps as long as the wheel is attached. 

    I figured it was because I  had an old Microsoft Force Feedback wheel, so it doesn't have drivers, but it functions perfectly in the game and in most other games as well.

    I wasn't going to talk about this in my review for the above reason, but if this is affecting more than just me, then perhaps it needs to be mentioned.

    EDIT: Not running creators update. Windows version (2017-06 Update for Windows 10 Version 1607 for x64-based Systems (KB3150513)

  • siffonensiffonen Member New Car Smell
    I am not using creators update, so its 1607 for me.
    Strangely i have had this same problem from F1 2015 and it was caused by D-Link usb hub, but in this my wheel is causing this issue.
  • jespedjesped Member New Car Smell
    CMMcBabe said:
    Are any of you running Game Mode from the Creators Update to Windows 10?  If so, could you try disabling it please?
    I was running Dirt4 with "Game Mode"= Off. Changed it to On and didn't make a difference.
  • mraz0mraz0 Member New Car Smell
    Same here terrible stutter every 2-5 sec. Running high end system with nvidia titan x pascal, i7 4960X, 32gb RAM! This needs to be fixed as for me it is unplayable like this, when doing precision turns this stutter kills it. Will play when fixed!
  • HinjimaHinjima Member New Car Smell
    mraz0 said:
    Same here terrible stutter every 2-5 sec. Running high end system with nvidia titan x pascal, i7 4960X, 32gb RAM! This needs to be fixed as for me it is unplayable like this, when doing precision turns this stutter kills it. Will play when fixed!
    I agree. I haven't played it since release date and I won't play it until its fixed, its unplayable like this.  They are aware of the issue and are somewhat active on this post to try and figure out whats causing the problems.  Lets hope they fix it soon and keep us updated with feedback:)
  • crysisxforcecrysisxforce Member New Car Smell
    edited June 14
    FX8350
    Win 10 Creators Update (Game Mode On)
    16GB DDR3
    Sapphire R9 Fury Nitro
    Latest AMD Drivers

    With the following specs: I get stuttering on Michigan and Spain. It especially bad when I am watching a stream on my second monitor. When I turn that stream off game runs a little longer between stuttering. I am playing the game on a Xbox360 Gamepad (Afterglow vers). I can say this that I running with clean (DDU) installed drivers DiRT Rally runs much better than DiRT 4 for me. Only time I got stuttering in DiRT rally was on Germany and Monte Carlo. DiRT 4 it seems that the stuttering for me is only on Michigan and Spain. Hopefully they can find what leads to this issue. I will definitely try unplugging all controllers and try with mouse and keyboard. 

    I do hate though the game just like in DiRT Rally starts up in a 800x640 window forcing me to ALT+Enter and refresh my settings for full screen. Even then my mouse still hovers over the other monitor, but that's more of a pet peeve. 

    Edit: I had a stream open, unplugged my XBOX 360 controller. Had no stuttering at all, FPS remained at 72 on High 4xMSAA @1080p
    Post edited by crysisxforce on
  • sammyboy123sammyboy123 Member New Car Smell
    I'm running an RX470 on a 1080p 144Hz Freesync screen with VSync off and like everyone else here my FPS is great except for the stutters, happens with my G29. Tried running at lowest settings and it made no difference. It does make the game difficult to play like this.
  • zissakos1zissakos1 Member Unleaded
    Guys try this:
    When in game, change the refresh rate in the graphics mode to something else (e.g. 50Hz), APPLY, and then change it back to 59/60Hz, APPLY.
    This gives me constant 60fps, while on startup of the game I have like 40-50.
    Win 10 64bit, GTX 1070.
  • ilborga70ilborga70 Member New Car Smell
    FIX NO STUTTERING Unfortunately it is the same problem that has always had and still has a dirt rally, if you dumb the first time you have to reboot your dear PC and the problem disappears.
  • siffonensiffonen Member New Car Smell
    No one understands that cos its not in english
Sign In or Register to comment.