Welcome to the Codemasters Forums! Be sure to check the FAQ and Forum Rules before you get started.

F1 2017 - Fanatec pedals doesn't work

I have the Fanatec CSL Elite PS4 steering wheel along with the Clubsport V3 pedals.
In V1.0 the wheel and pedals worked with the generic drivers.
In the latest V1.10 the CSL elite specific drivers greatly improved the steering wheel but the pedals doesn't work. Completely dead.
Tried different cables, different usb settings, different control settings etc but they simply doesn't work.

This is a total disaster! I've bought the wheel and pedal setup specifically to run this game and now it doesn't work!?


  • Ho3n3rHo3n3r Member Race Steward
    I have this same problem now. Got the Clubsport V3's, and now I can't assign them at all. After selecting the axis I want to assign, and pressing the relevant pedal, it just says "Waiting for input".

    Wonder if anyone has managed to get these pedals working with this game.
  • Ho3n3rHo3n3r Member Race Steward
    Bumping this.

    Anyone have a workaround to get the Clubsport V3 pedals to work with this game?
  • nyusziagyarnyusziagyar Member New Car Smell
    edited March 23
    I have the same Fanatec v3 pedals problem. Finally I installed the cracked version of the game the 1.7 version and it is working without any problem. Congratulation for Codemasters. I hope this help you to understand the problem. 
  • davidantxdavidantx Member New Car Smell
    Does anyone know if the Clubsport v3 pedals are still broken in F1 2018?
  • davidantxdavidantx Member New Car Smell
    anyone? ..........................................
Sign In or Register to comment.