Welcome to the Codemasters Forums! Be sure to check the FAQ and Forum Rules before you get started.

F1 2017 and Fanatec Pedals

Hi, I'm running F1 2017 on Steam on my Asus Laptop.  I use an older Logitech Momo steering wheel and just received  the Fanatec Club Sport V2 Pedals.
When I try to calibrate the pedals, I have no problem with the brake or clutch. It is the Throttle pedal that gives me the setup problem. 
In the games setting for the pedals, I have to set the DEAD PEDAL setting at 51 in order to stop the car from accelerating on it's own. That gives me less than half my throttle pedal movement left, which isn't realistic at all. How can I adjust my Dead pedal setting closer to 0 without setting my accelerator at 1/2 power? 
In my Fanatec Property page my pedals work just fine. Please help, I don't want to throw the old 2 pedal Logitech base back on just for F1 2017.

Thank you for your help.
Grumpy17.

Answers

  • ReggieBazReggieBaz Member New Car Smell
    Hi,
        just try my new Fanatec CSL Elite Pedals LC, and F1 2017 see my throttle pedal in reverse, every other racing game are OK

    Hope Codemaster fix this soon

    Rejean

  • Ho3n3rHo3n3r Member Race Steward
    I played it with my V2's and it was fine. No extra configuration was necessary - assign pedals and forget about it.
Sign In or Register to comment.