Jump to content
DiRT Rally 2.0 - New Player Guide Read more... ×

Archived

This topic is now archived and is closed to further replies.

g27 not being recognized as a controller.

Recommended Posts

I used to play a few games last year. Dirt3, WRC4, Grid Autosport. I have the full G27 kit, wheel, pedals, shifter.  I stopped playing when my harddrive crashed. I recently bought Dirt Rally which got me back into the simulators. This game is working 100% with thew G27.

 A few days ago I went to play Grid Autosport again for the 1st time. I optimized settings, validated cache (on steam) but no matter what I do, it does not see my g27 as a controller. Only Keyboard and AZERTY Keyboard.


Dirt rally, dirt 3, wrc4 all recognize the g27 and allow me to play with it 100%, but I cannot get Grid even let me select it as a controller. Does not recognize wheel, pedals, shifter, buttons on shifter etc even when trying to manually assign controls. 

I've tried uninstalling the game and re-installing. I've deleted the Logitec g27 drivers and gaming/profile managers and re-installing.

 

All drivers are up to date. I've even tried disconnecting/reconnecting the usb while in game. After everything, it still works with the other games, but nothing with Grid Autosport.

 

The only differences in my rig since last time I played are a new harddrive (which is same make/model as pervious one that failed). A new nvidia 980 card. and Windows 10 (was previously on 7).

 

Any ideas? Thank you for your time.

Share this post


Link to post
Share on other sites
Delete C:\Users\xxxxx\My Documents\My Games\GRID Autosport\hardwaresettings folder,...it will allow the game to re recognize your hardware.


Share this post


Link to post
Share on other sites
i have the same problem, the game cant see my g27 .GRID work fine but Grid Autosport no, only keyboard or gamepad. how can i fix it?

Share this post


Link to post
Share on other sites
So mine is doing it again. Even if I delete the folder again, it still just doesn't recognize.
uninstall GeForce Experience beta version and install non beta

Share this post


Link to post
Share on other sites
So mine is doing it again. Even if I delete the folder again, it still just doesn't recognize.
uninstall GeForce Experience beta version and install non beta

Thank you very much. Uninstalling Geforce Beta Experience solved my problem.

Share this post


Link to post
Share on other sites
Deleted the GRID folder, Geforce Experience doesn't even recognize GRID(already tried to add it manually). Still not recognizing the game.

Share this post


Link to post
Share on other sites

×