Jump to content Jump to content

Logitech G29 FFB and Shifter issues on PC


vocos

Recommended Posts

Hi All,
I am using Logitech G29 wheel + Shifter on Windows 10 Pro machine (i7 4790k + GTX970) with the latest Logitech Gaming Software (8.82.151) installed. The wheel works amazing with every other game I've tried -  Assetto Corsa/ Project Cars/ Euro Truck etc. but not with Dirt Rally unfortunately  :(
I've been trying to solve my wheel issues with this game for a while now but still not able to get my wheel working properly. My wheel in this game acts and looks very strange like it's being detected as a PS4 controller even though in the input menu it says G29 :/ . I'll try to explain in details issues experienced and things tried so far and also attach some screenshots below:
1. No H-Pattern/H-Pattern+Clutch options presenting in the menu, seems like the shifter is not getting recognized at all by the game.
2. No advanced FFB wheel options (only controller vibration settings like these on my xbox one controller). The wheel is acting super weird and only rumbling during gameplay.

Things I've tried so far:
1. Reinstalled Dirt Rally/ Steam/ Logitech Drivers (Including the registry as per some suggestions on the internet) 
2. Deleted input and ffb folders from the game and restored via Steam   in order to force the game to re-detect my wheel
3. Tried to fiddle around with the game files/settings/priority of the inputs and so on
4. Disconnected xbox one controller and every other input device from the computer physically, performed reboots, retries and so on... 
5. Tried all USB 3.0/2.0 ports, even those on the motherboard itself
6. Other: DirectX/ Windows Redistributable Packages and many more tweaks that I'm not able to recall at the moment

I've received this game as a present back in August and have spent many so many hours on trying to get my wheel to work properly but still nothing. :/
Please share with me your suggestions and ideas.



Thanks in advance! :)

Victor


Link to post
Share on other sites
It's weird ur having issues like these ingame since it works in other games, i have the g920 variant and it works pretty well, what u could try if u didn't do it before, downloading latest firmware for your wheel on the logitech site (if there is one). If u have the option ingame to calibrate ur wheel that might also help. The wheel is officially supported by Dirt Rally so the issues you' re having is pretty weird.
Link to post
Share on other sites
Destim said:
It's weird ur having issues like these ingame since it works in other games, i have the g920 variant and it works pretty well, what u could try if u didn't do it before, downloading latest firmware for your wheel on the logitech site (if there is one). If u have the option ingame to calibrate ur wheel that might also help. The wheel is officially supported by Dirt Rally so the issues you' re having is pretty weird.
My wheel is with the latest firmware and I do not see calibrate option in the game menus, tried to calibrate in Windows  -> joy.cpl but did not help. When I got the game back in August the wheel was not in the support list so I waited it to come on September....... after the patch nothing has changed.
Link to post
Share on other sites
vocos said:
Stevie777 said:
Is there a switch on the wheel to switch between ps4 and pc maybe?
I know my T150 wheel has one.
On G29 the switch is to choose between PS3 and PS4 options. For PC the PS4 possition of the switch is to be selected.
Have you tried it in the PS3 position just in case?
Link to post
Share on other sites
  • 2 weeks later...
I have the same issue and about the same hardware, Windows 10 Pro machine (i7 4790k + GTX980 Ti)
After reinstalling Windows the issue was fixed, but now it's come back.
I have tried to remove all the Logitech drivers and cleaned the USB devices etc.. but to no avail.
Still having the friggin Advanced Gamepad Settings in Dirt Rally and no FFB in F1 2015 (F1 2014 and other games work fine).

Edit: Will try the Project Cars calibration as fix, reported by user IAmGreiG in https://m.reddit.com/r/dirtgame/comments/3wrzoo/g29_no_soft_lock_option_or_calibration_menu/

SUCCESS! Running the config in PCars actually fixed the problem.. Go figure. 
Link to post
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...