Jump to content Jump to content

Rain causing Black Screen with Sound!!!


Recommended Posts

PC Specs: 
Gpu: MSI Nvidia GTX 460 1GB
CPU: i5 3470 @ 3.20 GHZ
Mobo: Asrock Z77 Pro3
Ram: Kingston 8GB 1600MHz DDR3 Non-ECC CL9 DIMM

I tried everything, i looked on all posible forums with similar issue, even for different games but same issue, nothing has worked for me, after short time when Rain starts in race, the screen eventually freezes 1 second then goes Black Screen and sound still works, the game still works, untill i bring up the Pause Menu, that makes the game crash in desktop and automatically Launches game again.

Its the only game i have this issue, never happened on other games wich are even heavier on requirements than F1






Link to post
Share on other sites
I have the same problem and also have a GTX 460 1GB. A lot of other problem do have the same problem (see Steam forums). A dev answer would be very much appreciated, at least that somebody is working on the problem. I just got back into F1 and really like the game but I cannot buy a sequel if I cannot be sure that it works.
Link to post
Share on other sites
if the 2 of you have the same graphics card then it may be that card if that's the case you may want to upgrade it or at the very least update the drivers
updated drivers, downgraded drivers, reinstalled Windows, nothing works.

Also i always had this issue with Pixelated Rain Drops on Lens, watch ... 
http://postimg.org/image/altciylul/
http://postimg.org/image/4wd3ynfod/
http://postimg.org/image/mxw8wg9p9/

You can see best on White colour of Helmet how bad they look

Link to post
Share on other sites
i posted my Specs, is ASROCK
Sorry didn't see.
I had same problems with Asrock X58 Extreme.
I had NVIDIA GTX 450 and then changed to GIGABYTE GV-R785OC-2GD Radeon HD 7850. 
But problem persisted even with new graphic card. Then I changed PCI-e slot and problems where gone....

PS. I tried at least 20 different solutions with CM support and they didn't solve problem.


Link to post
Share on other sites
well as i said, using Medium Graphic only for reflections fixed the issue, i doubt its a Hardware problem, because 3 months ago i had older PC Build, totally different, but same issues.

 Then i changed to the SPECS i have now, the only thing i havent changed is the GPU, but i doubt GPU has any issue at all, i Stress tested it in different programs wich gave my GPU an 90 Celsius degrees and didnt crashed or didnt had any Error at all.
In F1 it stays between 58-60 degrees.

Formula 1 is not such a hard game in requirements, its works easily on older rigs aswell. For example why in Battlefied 4 i have no issues to run it on HIGH, but Formula 1 gives this black screen during rain randomly, sometimes early in the race, sometimes later.
Link to post
Share on other sites
well as i said, using Medium Graphic only for reflections fixed the issue, i doubt its a Hardware problem, because 3 months ago i had older PC Build, totally different, but same issues.

 Then i changed to the SPECS i have now, the only thing i havent changed is the GPU, but i doubt GPU has any issue at all, i Stress tested it in different programs wich gave my GPU an 90 Celsius degrees and didnt crashed or didnt had any Error at all.
In F1 it stays between 58-60 degrees.

Formula 1 is not such a hard game in requirements, its works easily on older rigs aswell. For example why in Battlefied 4 i have no issues to run it on HIGH, but Formula 1 gives this black screen during rain randomly, sometimes early in the race, sometimes later.
My guess is also that this has something to do with F1 2013...and it won't be solved...
Link to post
Share on other sites
  • 2 weeks later...
another fix that some might wanna try is to go in C:\Users\******(your username)\Documents\My Games\FormulaOne2013\hardwaresettings and open with Notepad hardware_settings_config, then folow the 1st line untill you find <directx forcedx10="false" /> , what you must do is to change false to true, that way you force the game running on DX10 instead of DX11.

For some reason my GPU gets bugged with this game and ONLY with this game, its like it struggles to run it properly in DX11 but fails at some point, so turning it to DX10 sorts my Black Screen for good. 
Hope this helps!!!

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...