Jump to content Jump to content

F1 2015 on a PC with Windows 10 and G920 - brake is always on


n1msr

Recommended Posts

I bought a Logitech G920 for using with F1 2015 and Project Cars.  The wheel is fine with Project Cars.  However, in F1 2015 the car stops as if the brakes are on all the time.  When pressing the accelerator the car does move but it accelerates slower than normal (compared to how it used to play and compared with other cars).   This occurs when I use the default G920 setup recognised in F1 2015, and with a Custom setup/

Has anyone a fix for this?  I have looked in the forums here (and googled) and whilst I find many, many issues with the G920 pedal assigment, I have not found any advice on this problem.  I am using very recent (the latest I think) drivers for the G920 (G920Update_96_3_49) and the latest Logitech Gaming software (v8.83).

Thank you.
Link to comment
Share on other sites

Sounds like the brake pedal needs to be inverted. I think it can be done by going into customising controllers in the settings menu. Go to the brake pedal assignment and there should be an option to invert that specific pedal assignment. I have the option on Xbox one version, the Y button specifically. 
Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...