Jump to content
DIRT 5 - Chat about the game and get support here. Read more... ×
How to contact Customer Service Read more... ×
F1 2021 | BETA | Details and how to Apply Here Read more... ×

Archived

This topic is now archived and is closed to further replies.

DiRT Rally Update - PS4 Patch for Thrustmaster peripheral hardware

Recommended Posts

Pepe55 said:
Yeehaaw, I can drive my car's again! Settings are all back and after some tweaking again I was able to do today's daily challenges without being in the ditch all the time.  :) I'll reserve commentary about the FFB, as I haven't done the hill climbs yet. Still don't know if the car's are going to have better feedback on the front and rear and not so light since the beginning??

It's just great having the settings back, so I'll be enjoying things again for now. Worry  about the other stuff another day!!!!!
Thanks CM for the prompt fix. 

Cheers,

I'll be sure to post more thoughts after I've had time to do some races in every category. After two quick runs earlier this morning, it wasn't my impression that this patch was new,verses a rollback? More driving required for me to make an accurate assessment.

Cheers,

Share this post


Link to post
Share on other sites
Has anyone tried with a T500 yet? Am reluctant to try. Still on first patch at present and like how it feels. Any feedback would be appreciated.
I've had a play with my T500 and it feels great. Feels similar to before the patch, with maybe a bit more feedback on tarmac but it's hard to tell as it's been some time! 
Thanks  :)

Share this post


Link to post
Share on other sites


Pepe55 said:
I'll be sure to post more thoughts after I've had time to do some races in every category. After two quick runs earlier this morning, it wasn't my impression that this patch was new,verses a rollback? More driving required for me to make an accurate assessment.
That's the proof the FFB improvements are not obvious...

Share this post


Link to post
Share on other sites
Yeah I can concur it feels just as good as it did pre patch. So glad they got this fixed for the weekend. I can now come out of Dirt retirement. Great stuff Codemasters for getting the patch out in a week, I lost all hope this would get released this month!

Share this post


Link to post
Share on other sites
For the first time I am able to play Rally X without worrying about the life of my T500. What a little gem that is, loving it.

Share this post


Link to post
Share on other sites
Hi,

Not working properly for me in 1.03

The wheel itself works fine, but my Thrustmaster TH8A h-shifter is not working, and every time I restart dirt rally, the transmission controls reset to Automatic, regardless of what setting they were on previously (manual H Shifter, Manual H-Shifter+Sequential)

It has been a few weeks since I played Dirt Rally so I did not try the previous patch (1.02) but it was working fine on 1.01

Details :

PS4
Thrustmaster T300 wheel
Thrustmaster TH8A h-shifter, attached to the T300 wheel
Original T300 pedals (Accelerator+brake pedals, no clutch pedal)

Cheers,
Jason

Share this post


Link to post
Share on other sites
Dont know if its patch related but I cant seem to acces any on-line events or leagues through racenet. Also cant access any leagues or events on the official dirt website.

Share this post


Link to post
Share on other sites
uchian said:
Hi,

Not working properly for me in 1.03

The wheel itself works fine, but my Thrustmaster TH8A h-shifter is not working, and every time I restart dirt rally, the transmission controls reset to Automatic, regardless of what setting they were on previously (manual H Shifter, Manual H-Shifter+Sequential)

It has been a few weeks since I played Dirt Rally so I did not try the previous patch (1.02) but it was working fine on 1.01

Details :

PS4
Thrustmaster T300 wheel
Thrustmaster TH8A h-shifter, attached to the T300 wheel
Original T300 pedals (Accelerator+brake pedals, no clutch pedal)

Cheers,
Jason
@uchian
Try plugging the shifter into the PS4 instead of the wheel and then assigning the gears, mine works fine like that :smile:

Share this post


Link to post
Share on other sites
After installing 1.03 my wheels works like it was, too week on FFB, that's right, but the cars are steerable again ...
My NEW problem is, that I am not able to connect to Racenet ... and ...

The same problem with not being able to log into RACENET ist posted by jwboelhout ,Turbocharl and novcze .

Is
that a new or known problem or is RACENET really down ...
I was trying for several hours now ....
And ... btw ... I checked my connections and network ... My PS4 is connecting to the Playstation Store ... so ... internet connection is not the issue ...

HELP!!!!!!

Sb else experiencing that problem?

Share this post


Link to post
Share on other sites
June 24 afternoon or so, racenet not connecting on ps4...this seems to have happened after this fix was installed on my system

Share this post


Link to post
Share on other sites
Racenet and leagues have been down for over 24 hours now on the xbox as well. Don't know who's running things at codies but they seem to have a one step forward three steps back policy

Share this post


Link to post
Share on other sites
madwak said:
uchian said:
Hi,

Not working properly for me in 1.03

The wheel itself works fine, but my Thrustmaster TH8A h-shifter is not working, and every time I restart dirt rally, the transmission controls reset to Automatic, regardless of what setting they were on previously (manual H Shifter, Manual H-Shifter+Sequential)

It has been a few weeks since I played Dirt Rally so I did not try the previous patch (1.02) but it was working fine on 1.01

Details :

PS4
Thrustmaster T300 wheel
Thrustmaster TH8A h-shifter, attached to the T300 wheel
Original T300 pedals (Accelerator+brake pedals, no clutch pedal)

Cheers,
Jason
@uchian
Try plugging the shifter into the PS4 instead of the wheel and then assigning the gears, mine works fine like that :smile:
I agree, shifter needs to be plugged into the PS-4. Off topic, my second shifter is due to arrive Wednesday June 29th. It will plugin to the wheel and be my park brake!!! Can't wait.

Cheers,

Share this post


Link to post
Share on other sites
FFB too weak for T300 SOLVED !  B) 
I made a copy of my save Dirt progress on a USB storage. I deleted all dirt stuff on my PS4. Re-installed the game, and started a new career.  At this point the FFB was "GOOD".
I deleted the new dirt progress and put back my previous one from the usb storage to the PS4.
Restart Dirt and... It's working ! :smiley: 
To be clear : FFB is GREAT on gravels/mud/snow, better than ever. On tarmac, it's really better than before, but not fantastic at all (that seems "normal" with this game).
I made the wheel calibration at default 1080°. I pushed quite hard the wheel at the end to have 100% and not 96%.
After that I play with soft lock on and wheel set to 1080°. It's feels really better like this than putting 540° on the wheel.

Share this post


Link to post
Share on other sites
Thanks Codemasters, I can finally enjoy my favorite game.
P.S. C
an be the rally of  Portugal, or Sardegna, Poland, Mexico for the next patch?  ;)

Share this post


Link to post
Share on other sites
Back to Dirt, thanks, T300 working well,  i dont know if it was after the update cant connect to racenet?

Share this post


Link to post
Share on other sites
Well, the racenet is not available from the webpage as well, so I don't think it's because of the patch.

Worse yet, it tells me that it was actually me that broke the website. O_O Sorry guys, will try to fix it with a patch, working on it now.

On a serious note, I don't even care racenet is down now. I have so much fun with the game after the last patch. T150 behaves great, the Pikes Peak course is fun as hell (gone are those wierd spins out of nowhere), so is Rally Cross. It's a complete game now, the ultimate rally experience we've all waited for for so many years. Codemasters, respect from Poland. ;] 

Share this post


Link to post
Share on other sites
Well, the racenet is not available from the webpage as well, so I don't think it's because of the patch.

Worse yet, it tells me that it was actually me that broke the website. O_O Sorry guys, will try to fix it with a patch, working on it now.

On a serious note, I don't even care racenet is down now. I have so much fun with the game after the last patch. T150 behaves great, the Pikes Peak course is fun as hell (gone are those wierd spins out of nowhere), so is Rally Cross. It's a complete game now, the ultimate rally experience we've all waited for for so many years. Codemasters, respect from Poland. ;] 
I wish I could say the same thing!! For me and my T300RS, life was much better with the original release. It took some tweaking and getting used to, but once I got used to it, it was great! Ever since that update, than whatever the last patch was intended to do, not so much fun anymore!!

Cheers,

Share this post


Link to post
Share on other sites
Dear Codemasters,

are u planing repair this weakness problem?

I paid this game i bought for the game a T300RS wheel and its till update unusable.
What are u planing?.
Tell us please!

Share this post


Link to post
Share on other sites

Gabor1980 said:
My T300RS is too weak after this update, i want the first ps4 release back.

Did you tried to save your progression to an USB storage and restart the game from scratch ? It worked very well for me, I was having the same issues than you. After that, I deleted the new progression, put back my previous one, and all is now fine (except on tarmac where the FFB is strong but not accurate). Try this, calibrate normally your wheel (1080°, saturation 95 or 100, linearity 0, soft lock ON), and go !

Share this post


Link to post
Share on other sites
Okay I have have both the TX & the T300 so I can A/B both wheels and definitely the T300 feels better if not pretty good.
It's not wishful thinking either because I have both wheels so I'm being objective and I can go back and forth relatively quickly. I'm running 360 degrees of rotation  and my wheel saturation to 20 percent.  
I just did one stage of  Greece and I could feel the little bumps and it had good FFB. The TX is pretty strong to the point were It has made my arm sore so I'm not sure it's at that level  but I don't think you need that much FFB anyway. I didn't do any file deleting or anything like that.
Changing the rotation made a huge difference. I like to run 360 to as low as 270 on both wheels.

Share this post


Link to post
Share on other sites
Okay I have have both the TX & the T300 so I can A/B both wheels and definitely the T300 feels better if not pretty good.
It's not wishful thinking either because I have both wheels so I'm being objective and I can go back and forth relatively quickly. I'm running 360 degrees of rotation  and my wheel saturation to 20 percent.  
I just did one stage of  Greece and I could feel the little bumps and it had good FFB. The TX is pretty strong to the point were It has made my arm sore so I'm not sure it's at that level  but I don't think you need that much FFB anyway. I didn't do any file deleting or anything like that.
Changing the rotation made a huge difference. I like to run 360 to as low as 270 on both wheels.
I really hope you meant self aligning tourque at 20 and not wheel saturation. If you are infact using 360 degrees and wheel saturation at 20, that gives you 72 degrees of rotation :open_mouth:

Share this post


Link to post
Share on other sites

×