Jump to content
DIRT 5 - Chat about the game and get support here. Read more... ×
How to contact Customer Service Read more... ×
F1 2021 | BETA | Details and how to Apply Here Read more... ×

Archived

This topic is now archived and is closed to further replies.

GAME WON'T LAUNCH

Recommended Posts

Hey guys, I'm new here. I don't know much about the game, I just installed it but it won't go past the starting screen. The Dirt Rally logo comes up with black background, but it stays there. If I start pressing Enter or Esc. it kicks me out of the game.
Any ideas of how to fisx this would be appreciated. 
Thanks

Share this post


Link to post
Share on other sites
cpetrou said:
I don't know much about the game
I expect a certain thread popping up soon...

Anyway, if it's an error 41, here's a quick check list that you can do: http://steamcommunity.com/app/310560/discussions/1/490124466462960094/

Other steps are as simple as making sure you can actually run the game (check the minimum requirements), updating drivers for the graphics card, verifying the game cache (sometimes download can be corrupted) and restarting the PC. Other than that, you can try using program like CCleaner to check for registry errors, though don't expect miracles there. Also disable any and all overlay software aside from Steam, like Dxtory, Fraps etc. Chances are that they may cause a crash.

Share this post


Link to post
Share on other sites
cpetrou said:
I don't know much about the game
I expect a certain thread popping up soon...

Anyway, if it's an error 41, here's a quick check list that you can do: http://steamcommunity.com/app/310560/discussions/1/490124466462960094/

Other steps are as simple as making sure you can actually run the game (check the minimum requirements), updating drivers for the graphics card, verifying the game cache (sometimes download can be corrupted) and restarting the PC. Other than that, you can try using program like CCleaner to check for registry errors, though don't expect miracles there. Also disable any and all overlay software aside from Steam, like Dxtory, Fraps etc. Chances are that they may cause a crash.
Hey Mate, 
Thanks for the reply. I tied ALL of the above but nothing works. I guess the only think I can do now is to uninstall and re-install the game.
I'll let you know if its fixed or not!
Thanks again

Share this post


Link to post
Share on other sites
cpetrou said:
cpetrou said:
I don't know much about the game
I expect a certain thread popping up soon...

Anyway, if it's an error 41, here's a quick check list that you can do: http://steamcommunity.com/app/310560/discussions/1/490124466462960094/

Other steps are as simple as making sure you can actually run the game (check the minimum requirements), updating drivers for the graphics card, verifying the game cache (sometimes download can be corrupted) and restarting the PC. Other than that, you can try using program like CCleaner to check for registry errors, though don't expect miracles there. Also disable any and all overlay software aside from Steam, like Dxtory, Fraps etc. Chances are that they may cause a crash.
Hey Mate, 
Thanks for the reply. I tied ALL of the above but nothing works. I guess the only think I can do now is to uninstall and re-install the game.
I'll let you know if its fixed or not!
Thanks again
When you uninstall the game, make sure there are no files left in the DiRT Rally folder in steam/steamapps/common. If there are, delete them, or better yet, delete the whole DiRT Rally folder. After that you can redownload the game

Share this post


Link to post
Share on other sites
Unfortunately I'm back here again. I tried everything you guys suggested but even after the re-install the game refuses to start. I get a window saying "Dirt Rally Executable has stopped working".
I know my system is a bit old but it meets the requirements. These are my specs, if you think I'm wrong please let me know:

CPU:
 Intel Core i7 860 @ 2.80GHz Lynnfield 45nm Technology
RAM: 8.00GB Dual-Channel DDR3 @ 668MHz (9-9-9-24)
Motherboard: Alienware 0RV30W (CPU 1)
Graphics: W2343 (1920x1080@60Hz) ATI Radeon HD 5670 (Dell)
Storage: 465GB Samsung SSD 850 EVO 500GB ATA Device (SSD)
931GB Seagate ST31000524AS ATA Device (SATA)
465GB Seagate ST95005620AS ATA Device (SATA)

Thanks again guys! 


Share this post


Link to post
Share on other sites
To me it honestly sounds like outdated drivers. Not just graphics, but motherboard as well. Given that it is a laptop, it's possible that can be the issue.

Other than that, I don't really know. There may be something that you do on that laptop that you don't think matters, while it does or... honestly, everything is possible. Especially when we have to include laptops.

Share this post


Link to post
Share on other sites
To me it honestly sounds like outdated drivers. Not just graphics, but motherboard as well. Given that it is a laptop, it's possible that can be the issue.

Other than that, I don't really know. There may be something that you do on that laptop that you don't think matters, while it does or... honestly, everything is possible. Especially when we have to include laptops.
It isn't a laptop. Its a alienware Aurora R2. I updated all the drivers but still nothing

Share this post


Link to post
Share on other sites
Check your specs on here

http://www.game-debate.com/games/index.php?g_id=4320&game=Dirt%20Rally

It'll tell you if there is a problem with your hardware


Share this post


Link to post
Share on other sites
Try another re-install but this time turn off your firewall and any anti virus you have before you download, turn it all back on after a successful install.


Share this post


Link to post
Share on other sites
hey guys,
I solved the problem. It looks like my graphics cards were not crossfired so only one of them was working. My PC system is a bit old but looks like it still gets the job done.

Thanks a lot for your help!

Share this post


Link to post
Share on other sites

×