Jump to content
DIRT 5 - Chat about the game and get support here. Read more... ×
How to contact Customer Service Read more... ×
F1 2021 | Arrives July 16 | First Look Here Read more... ×
Sign in to follow this  

I can't get DIRT 3 to start

Recommended Posts

Hi folks this is my first post so constructive criticism please. OK so this is the deal I start up my steam, click DIRT 3 and hit play, then a little square that says DIRT 3 pops up, then splash screen and crash, I've been n contact with the support site and sent them a DXDiag file they told me I had two sound cards active (I'm only using onboard sound no extra cards) did any of you have the same issue, and if so how did you resolve the issue? Any help would be much appreciated, thanks

Share this post


Link to post
Share on other sites
yea tried all of the usual methods verify cache, run as admin, force windowed mode, force resolution edited the xml and nothing

Share this post


Link to post
Share on other sites
Kev579 said:
yea tried all of the usual methods verify cache, run as admin, force windowed mode, force resolution edited the xml and nothing
Are you running the game through the Steam client or GFWL?

Share this post


Link to post
Share on other sites
sorry guys for leaving you in the lurch I'm trying to launch from steam client and have uninstalled gfwl and reinstalled at least a dozen times and it works because GTA 4 works no problem

Share this post


Link to post
Share on other sites
In that case I'd suggest sending an email to custserv@codemasters.com with some details about your rig and they should be able to help out.

Share this post


Link to post
Share on other sites
Yea I've done that already and they told me that I had more than one sound card turned on but I'm using on board sound they were not realy much help

my rig
mobo
asus p8z77-v lx
RAM
corsair vengeance
CPU
intel 3570K
GPU
amd sapphire hd 7790 1gb gddr5

Share this post


Link to post
Share on other sites
You could try updating you're mobo sound driver's, had more than my fair share of issues with onboard sound and games. Particularly assus boards.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×