Jump to content Jump to content

[F1 2015 PC] Game switches to windowed mode and loses focus


skiwi

Recommended Posts

Hello all,

I have a very frustrating issue that occurs on average once per hour and sometimes twice after each other within a few seconds: The game switches from fullscreen to windowed mode (as if you had pressed Alt+Enter) and on top of that also loses focus.
Needless to say that this ruined a lot of races.

I tried to capture a screenshot, but it seems like it didn't save, it's just literally the game in windowed mode with the title bar greyed out, using Windows 10 now but it also happened on Windows 8.1 a couple of weeks ago.
I cannot see any active messages or popups that should mean that anything caused it to switch.

Any clue how to fix it?
I do have quite some programs installed on this PC, is there a way to find out what one would be causing an issue if it's not the game?
Link to post
Share on other sites
Screen Savers and Lock Screens disabled? 
http://forums.codemasters.com/discussion/42748/f12015-pc-randomly-exits-out-of-fullscreen-mode
http://forums.codemasters.com/discussion/7743/f1-2015-pc-game-windowed-minimizes-on-it-self-and-windows-8-1-lockscreen-comes-on/p1

Check power management settings also, maybe something is set to occur after X number of minutes and thats kicking it into windowed mode as a side effect.

Its quite unlikely you'll get help from anyone from Codemasters in this forum unfortunately. Apparently this forum only counts for the first few months of each release DOT DOT DOT
Link to post
Share on other sites
I don't have any screen savers or lock screens enabled nor is there any power management active.

The only thing I can think of is that the GPU (or CPU) has some power management related to the sensor temperature but that should effect the fans not Windows I think.
Link to post
Share on other sites
@skiwi
I wouldn't have a clue about that sorry. Possibly you could find more pertinent information on Steam forums rather than in the Codemasters F1 Technical Assistance Forum.

As little sense as that makes!!!

This might work if you can still edit XML files etc. 
Originally Posted by natasha8384 View Post
if other methods don't work -- with the game closed (not running) find the *MyGames -> FormulaOne -> hardwaresettings* and open the file (copy it first to a safe place just in case):
*hardware_settings_config.xml*
Find the line 11 or the line starting with the word *resolution*. At the end of that line you'll find:
fullscreen="false"
-> change it (back to original) to: fullscreen="true"
and save.

FROM...

http://forums.steampowered.com/forums/showthread.php?t=1446470

That relates to 2010, I'll see if there are more recent ones...

Similar for F1 2013 - http://www.gamespot.com/forums/pc-mac-linux-society-1000004/cant-get-f1-2013-to-play-in-fullscreen-29456423/


EDIT: Steam only has subforums for F1 2010/2011 which I think was around the time the F1 forum was taken offline.

********
create a shortcut for f1_2015.exe
right click on that shortcut and go to properties..
in the "target" line add this to the end

-availablevidmem 6.0

this will fix the problem
********

FROM...

https://steamcommunity.com/app/286570/discussions/0/537402115079480173/



Link to post
Share on other sites
I haven't been able to test it yet, but based on various other reports I am pretty confident that I fixed the problem.
I figured out which program was taking focus by running a logger that tracks what programs lose and gain focus.

It turned out to be the following program: C:\Users\Frank\AppData\Local\Akamai\installer_no_upload_silent.exe
Some reports say that it was bundled with Autodesk CAD software, which I also have installed.

Hopefully this will help someone in the future.


Link to post
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...