Jump to content
Want to report an issue? Have a bug to report? Please look here first!!!! Read more... ×

Archived

This topic is now archived and is closed to further replies.

***Logitech G920 Brake Pedal Inverted and won't function!!** (PC)

Recommended Posts

I'm playing with the G920 and the brake pedal is jammed on. I can only go if I press DOWN on the brake and the gas at the same time. When I go to change it in the settings, it immediately reverts back to the inversion, making the game unplayable with the wheel. I tried making the clutch the brake and it does the same thing.

Pretty sure this exact thing happened with this wheel on Dirt Rally...and it took quite a while to fix it. Disappointed to say the least.

I thought it might be a wheel issue, but everything works perfectly fine with Project Cars and Dirt Rally

Share this post


Link to post
Share on other sites
''Glad'' to see I'm not the only one... I'm just as lost..

Making the clutch the brake did seem to fix the brake for me, but the accelerator is just constantly active, EVEN if i decide to change to keyboard controls..

Share this post


Link to post
Share on other sites
I'm have the same issue. It is also a problem in other high profile sims.  I'm beginning to think we have a bad batch of controllers.

Share this post


Link to post
Share on other sites
ZachLW said:
I'm have the same issue. It is also a problem in other high profile sims.  I'm beginning to think we have a bad batch of controllers.
Mine works for every other game I own, from project cars to Iracing, so I don't think so

Share this post


Link to post
Share on other sites
BastiaanW said:
ZachLW said:
I'm have the same issue. It is also a problem in other high profile sims.  I'm beginning to think we have a bad batch of controllers.
Mine works for every other game I own, from project cars to Iracing, so I don't think so
Ive used this wheel for a few years now, rFactor 1 and 2, F1 2010/12 , F1 Challenge 99-02 etc and no issues with any of them at all, so i agree with what you said

Share this post


Link to post
Share on other sites
BastiaanW said:
ZachLW said:
I'm have the same issue. It is also a problem in other high profile sims.  I'm beginning to think we have a bad batch of controllers.
Mine works for every other game I own, from project cars to Iracing, so I don't think so
In those games you have more latitude in setting and customizing hardware settings. I use those programs without a hitch thanks to the customization options.  Thing is, default G920 profiles in all titles exhibit the same reversed pedal behavior until I manually change them.

Share this post


Link to post
Share on other sites
Hi guys, do you have any additional controllers plugged in at all? A wired Xbox controller for example.

If so, try removing it and restarting the game.

Share this post


Link to post
Share on other sites
Is there any way of inverting the pedal axes outside of the game through the profiler?


Currently, no. I've been searching. Logitech's software is bare bones basic.

Britpoint said:
Hi guys, do you have any additional controllers plugged in at all? A wired Xbox controller for example.

If so, try removing it and restarting the game.

No other hardware, Brit'.

Share this post


Link to post
Share on other sites
Britpoint said:
Hi guys, do you have any additional controllers plugged in at all? A wired Xbox controller for example.

If so, try removing it and restarting the game.
No additional controllers plugged in for me

Share this post


Link to post
Share on other sites
I think I figured it out. I had to update my version of the logitech profiler. From there, I had a firmware update. I then went into the profiler and under the brake axes properties, I checked "combined pedals". Seems to work now.

Share this post


Link to post
Share on other sites
I think I figured it out. I had to update my version of the logitech profiler. From there, I had a firmware update. I then went into the profiler and under the brake axes properties, I checked "combined pedals". Seems to work now.

Just about 100% sure that's not a fix.  Tried it, no joy here.

Share this post


Link to post
Share on other sites
I think I figured it out. I had to update my version of the logitech profiler. From there, I had a firmware update. I then went into the profiler and under the brake axes properties, I checked "combined pedals". Seems to work now.
I've just tried this out but no good for me :(

Share this post


Link to post
Share on other sites
If I could simply reverse the axis in the overly simplified menus, I'd be racing right. Now. I really believe it's that simple.

Share this post


Link to post
Share on other sites
ZachLW said:
If I could simply reverse the axis in the overly simplified menus, I'd be racing right. Now. I really believe it's that simple.
It's worse than that, the game just decides that Y-, when you press the paddle down, can't be right and promptly changes it to Y+ as soon as you exit the menu.

Share this post


Link to post
Share on other sites
f1 isn't recognizing my G27 thinks its a formula force or something plus having same issue as pointed out above :(

Share this post


Link to post
Share on other sites
ZachLW said:
I think I figured it out. I had to update my version of the logitech profiler. From there, I had a firmware update. I then went into the profiler and under the brake axes properties, I checked "combined pedals". Seems to work now.

Just about 100% sure that's not a fix.  Tried it, no joy here.
You are right. This doesn't work. The brake works, but now the gas is always on....

Share this post


Link to post
Share on other sites
BastiaanW said:
ZachLW said:
If I could simply reverse the axis in the overly simplified menus, I'd be racing right. Now. I really believe it's that simple.
It's worse than that, the game just decides that Y-, when you press the paddle down, can't be right and promptly changes it to Y+ as soon as you exit the menu.
Yep, this is happening to me. Even if I try to use my clutch as a brake...the gas pedal gets inverted.

Share this post


Link to post
Share on other sites
Same Problem as in F1 2k15. But there was an Option to invert the pedals to fix it. This option is missing in F1 2k16. This means i got the same problem as you guys do.

Win10, Logitech g920 (all drivers up to date)

Share this post


Link to post
Share on other sites
I had the same problem, easy fix. Go into your f1 2016 folder and find actionmaps then open up the file within that and find the G920 mappings (Ctrl + F and put in G920) Then find Accelerate and below there should be (type="uniDirectionalPositive") Now change that too (type="uniDirectionalNegative") and then repeat that for the Break and then save the file and now it should work! 

Share this post


Link to post
Share on other sites
I had the same problem, easy fix. Go into your f1 2016 folder and find actionmaps then open up the file within that and find the G920 mappings (Ctrl + F and put in G920) Then find Accelerate and below there should be (type="uniDirectionalPositive") Now change that too (type="uniDirectionalNegative") and then repeat that for the Break and then save the file and now it should work! 
Thank you so much! It worked!

Share this post


Link to post
Share on other sites

×