Jump to content
Want to report an issue? Have a bug to report? Please look here first!!!! Read more... ×

Archived

This topic is now archived and is closed to further replies.

***Logitech G920 Brake Pedal Inverted and won't function!!** (PC)

Recommended Posts

The same Things and Bugs Over and Over and Over again!!

@Lozzy, where is your "sorry"?
QA seems again not the best @ Codemasters F1-Team!

Share this post


Link to post
Share on other sites
That worked!  Thank you, sir.

That I paid $60 USD for this game and received technical support from another player 12 hours after launch (for a relatively simple config change) is beyond me.

Share this post


Link to post
Share on other sites
OFFICIAL FIX:

ASSIGN BRAKES AND THROTTLE TO YOUR RESPECTIVE PEDALS AND PRESS INVERT ACTIONS ON BOTH THE THROTTLE AND BRAKES.

IT IS IMPORTANT TO DO IT BOTH ON THROTTLE AND BRAKES.

Had this issue on 2015, good luck report back please

Share this post


Link to post
Share on other sites
Same issue with the combined+reversed pedals, installed the Logitech Gaming Software and it fixed it;
http://support.logitech.com/en_us/product/g27-racing-wheel

Share this post


Link to post
Share on other sites
With the firmware upgrade from logitech, the axis for the pedals have changed, and this will be fixed in a patch. You should still be able to create without any issue a custom preset, but seems like it does not work. We will investigate.

Share this post


Link to post
Share on other sites
Hi guys, we've identified what happened with this and working on the fix now. We'll get it out to you ASAP but I don't know exactly when that will be yet.

Share this post


Link to post
Share on other sites
I had the same problem, easy fix. Go into your f1 2016 folder and find actionmaps then open up the file within that and find the G920 mappings (Ctrl + F and put in G920) Then find Accelerate and below there should be (type="uniDirectionalPositive") Now change that too (type="uniDirectionalNegative") and then repeat that for the Break and then save the file and now it should work! 
This worked!!

follow Microlanders instructions above, then launch F1 2016, go to the control mapping and re-map the accelerater and it doesnt change back once closed.

thanks a lot Microlander

edit: one thing to note, i didnt need to change the brake as that was already working so go into advanced settings on the game and press the pedals. they should go from 0 to 100 when you press them. if this is 100 - 0 then make the change.

also.. do one change at a time to limit screwing up your .XML.

Back this file up first to another location before editing

Share this post


Link to post
Share on other sites
Found and fixed this issue. You will need latest driver and firmware from logitech in order for it to work properly once the patch is out which will happen asap

Share this post


Link to post
Share on other sites
I had the same problem, easy fix. Go into your f1 2016 folder and find actionmaps then open up the file within that and find the G920 mappings (Ctrl + F and put in G920) Then find Accelerate and below there should be (type="uniDirectionalPositive") Now change that too (type="uniDirectionalNegative") and then repeat that for the Break and then save the file and now it should work! 
Hi, which windows do you run, and do you have latest firmware? because on Win 10 with latest firmware, this is the correct setting:

<Action actionName="Accelerate">
        <Axis axisName="di_y_axis" type="uniDirectionalNegative" deadZone="0.0" saturation="1.0" />
    </Action>
    <Action actionName="Brake">
        <Axis axisName="di_z_axis_rotation" type="uniDirectionalNegative" deadZone="0.0" saturation="1.0" />
    </Action>

The configuration you posted above, worked with the older firmware. With the patch, you will have to update your firmware.

Share this post


Link to post
Share on other sites
I have just donwloaded it again this morning to fix this issue and the Logitech Gaming Software tells me that the latest firmware is 96.3.49.

Share this post


Link to post
Share on other sites
None of these fixes are working for me on Win7 & latest firmware. Any attempt at remapping my G920 causes  the config screen to flicker and weird out.

The controls are inverted. Hoping for a patch soon, there are a lot of disappointed G920 users out there I am sure.

Share this post


Link to post
Share on other sites
DGreco said:
I have just donwloaded it again this morning to fix this issue and the Logitech Gaming Software tells me that the latest firmware is 96.3.49.
Yes, I downloaded this, this morning. It made no difference, I assume I was already running a revision that had the problem.

Anyway, it works fine with iRacing, Dirt Rally and others. I had an issue a long time ago with Asseto Corsa but that was fixed easily as I was able to invert the axis in game.




Share this post


Link to post
Share on other sites

×