Jump to content
Want to report an issue? Have a bug to report? Please look here first!!!! Read more... ×

Archived

This topic is now archived and is closed to further replies.

Large Deadzone on Pedals, Same Bug from F1 2015 !!

Recommended Posts

I am using HE Sim Pedals. They are configured in DiView in windows and appear and are configureable within F1 2016. However when i create a new or existing profile and input the pedals there is a large deadzone of about 30-40%.  These pedals work fine in every other game i've tried including Codemasters Dirt Rally. This leads me to believe there is a fundamental bug/flaw in the F1 series which introduces these large deadzones. I am wondering if it occurs when using multiple controllers. For example my CSWv2 is one device and the HE Sim Pedals are seen as another device. 

It really would be great if you could look into this, it was officially reported as an issue towards the end of the closed beta. To have this issue present in F1 2015 and F1 2016 is frustrating, it makes the game unplayable with pedals and if this same hardware will work fine in another Codemasters title such as Dirt Rally it should work in the F1 series.

Share this post


Link to post
Share on other sites
Here is a video showing the exact same issue from F1 2015. 

https://www.youtube.com/watch?v=wfnsgKUZHLY

Share this post


Link to post
Share on other sites
Reported Here as well

http://forums.codemasters.com/discussion/44081/not-again-same-as-f1-2015#latest

and also the thread from F1 2015 which was ignored

http://forums.codemasters.com/discussion/11158/he-sim-pedal-still-not-fixed#latest

Share this post


Link to post
Share on other sites
Another person here with the same issue in F1 2016, but this time with G27 standalone pedals

http://steamcommunity.com/app/391040/discussions/0/355043117508427104/

Share this post


Link to post
Share on other sites
I really cannot understand why it works here in the office even with 3 devices plugged in, and then it doesn't work. We will investigate.

Share this post


Link to post
Share on other sites
I am having the exact same problem.
A clear 50% deadzone on the pedals only on this title.
I have to say I use Leo Bodnar standalone adapter on the G27 pedals.

Share this post


Link to post
Share on other sites
I too have found this problem.
I am using PC.
I have a rig setup of G27 wheel, Bodnar standalone pedal adapter and a bodnar universal usb joystick interface (used for handbrake on dirt rally).
Dirt Rally just simply works, so why is F1 2016 being awkward?
If I connect pedals directly to G27 all is fine, but that's not what I want, I shouldn't have to keep swapping.
I'm sure you'll sort it soon. :smile:

Share this post


Link to post
Share on other sites
I had the same, but after the patch it was fixed. This is what I did:
1. Select keyboard as input method and select one of the keyboard presets (not sure if this is necessary)
2. Select your wheel as input method again and select one of the presets.
3. Click the key that creates a new custom controls profile and overwrite the old one.

This should fix it, at least it did for me.

Share this post


Link to post
Share on other sites

×