Jump to content

Archived

This topic is now archived and is closed to further replies.

Audio glitch when in pack of cars PC version

Recommended Posts

Any time I am driving around other cars I get weird audio glitching/crackling.  It doesn't happen when I am not near other cars.  It happens in any mode (quick race, championship, career).  Some people on the Steam forums suggested setting my audio settings in windows to 44khz/16bit or 48khz/16bit instead of 96khz/24bit, but that didn't solve the problem either.  Here is a video of the glitch I am talking about:

https://youtu.be/E9O1xXbEWLU

Share this post


Link to post
Share on other sites
Hi bptrav. Which version of the game are you running? You'll find this on the start screen. Also, what soundcard are you using?

Share this post


Link to post
Share on other sites
Hi bptrav. Which version of the game are you running? You'll find this on the start screen. Also, what soundcard are you using?
Version 1.2.0 and I am using an Asus Xonar DG (PCI) sound card with the newest drivers available for it.  My motherboard also has onboard sound that is disabled right now but I will try that tomorrow to see if it has the same problem.  I haven't had issues in any other games with the Xonar DG though, including past F1 games.

Rest of my system specs in case they are relevant:
Windows 7 Pro (64-bit)
i5-2500K | ASUS P8Z68-V LX | Crucial Ballistix DDR1600 16GB | EVGA GTX970 SC
Philips 272G5DYEB | Dell U2312HM | EVGA Supernova 750W G2
2x WD Blue 6TB | 2x WD Green 2TB | Crucial MX200 500GB

Share this post


Link to post
Share on other sites
Ok, thanks. Let me know how the other soundcard performs. I'll look into this. Is there a number of cars/distances at which this appears to stop?

Share this post


Link to post
Share on other sites
I am having exact same problem on PC version.

PC Specs:
Windows 10 PRO (64 Bit)
i5-750 2.66 GHZ
8 gb RAM
Nvidia GTX 750Ti

Share this post


Link to post
Share on other sites
Hi @Leviosa.  As asked of OP, could you give me an idea of how many cars it takes for this to happen, and how close they are?

Also, what soundcard and output (e.g. 5.1 surround) are you using?

Share this post


Link to post
Share on other sites
I cannot just say an exact distance or number of cars yet but I think you have to have a 2-second gap or more between you and the closest car to get rid of the glitch. On the other hand, I don't use a soundcard by itself, I use my motherboard's audio device. However, I think it has a Realtek chipset for it. I've tested it several headphones and a speaker,  all had the same problem.

Motherboard: Foxconn H55MXV

Share this post


Link to post
Share on other sites
I've been trying to solve the problem all the day and what i realized is I think me and OP, we both customized our camera view. I restored my camera view to default and it still sounds a bit weird but I think I got rid of the laggy sound bug.

Edit: Apparently, this wasn't the solution. The problem is still here.

Share this post


Link to post
Share on other sites
Having this problem as well on PC.

Windows 10 Home 64 bits
ASUS P8Z77-Le Plus
Intel Core i5-3570 @ 3.40 Ghz
8 GB RAM
ASUS GTX 970 Strix

Share this post


Link to post
Share on other sites
Ok, thanks. Let me know how the other soundcard performs. I'll look into this. Is there a number of cars/distances at which this appears to stop?
It seems to start glitching out a little bit when I'm within about 1.5sec of another car, then gets noticeably worse when I am within about 1 second.  It happens even when I am only near 1 other car (I dropped to the back of the pack to test this)

I tried disabling my PCI sound card and enabling my motherboard sound (Realtek ALC887) and I still had the same problem.  My speakers/headpones are just standard 3.5mm jacks by the way, not optical/digital.  I've also tried running the game as administrator which made no difference either.

Share this post


Link to post
Share on other sites
@bptrav, @CapitanCavernic, @kipkluif, @Leviosa, @JLFSL could you all see if you're running audio at 48kHz, and report back to me. If you're not, set system audio to output at 48kHz and see if that rectifies the jittering.

Share this post


Link to post
Share on other sites
Yep I tried running both my PCI sound card and my onboard sound at 48khz and still had the same issue.  I also tried 44.1khz and 96khz.  Also tried both 24-bit and 16-bit.  Same issue with all of those settings.

Share this post


Link to post
Share on other sites
@bptrav, @CapitanCavernic, @kipkluif, @Leviosa, @JLFSL could you all see if you're running audio at 48kHz, and report back to me. If you're not, set system audio to output at 48kHz and see if that rectifies the jittering.
Changing it to 48kHz doesn't solve the problem for me.

Share this post


Link to post
Share on other sites
Same problem here with bad audio stuttering and clipping. Tried 16/48 in audio properties and it did not help. Using onboard sound on an Asus Z170 M8 Hero motherboard.

Share this post


Link to post
Share on other sites
Exactly same problem here except for me it overwrites the other cars engine noises and is extremely loud, I'm on PC and whenever I got near another car the audio for their engine cuts in and out really fast so it sounds like theyre constantly going on and off throttle even when theyre not, quite annoying, does it in all views and with all cars and in all game modes.

Share this post


Link to post
Share on other sites
Just did a quick race, 25% Abu Dahbi in the Force India. There I experienced this issue as well.

Soundcard: Soundblaster Z, 24 Bit / 48K Hz
CPU: intel i7-4700K
RAM: 16GB
GPU: ASUS Strix GTX 980

Share this post


Link to post
Share on other sites
I have the same issue. It's very noticeable in the benchmark test, especially at the start of the race. I hear all the AI car sounds glitching and it gets very choppy at the end of the front stretch.

Setting the system audio to 48 kHz didn't fix it.

I saw that many people with the same issue have GTX 900 series GPUs, so I updated the NVIDIA drivers to the latest version and disabled the HDMI audio output in the NVIDIA Control Panel (I never use it), but it didn't fix the issue either.

I also checked my audio drivers to make sure they were up-to-date.

System specs:
Windows 10 Home x64
Core i5-2320
8GB Kingston HyperX DDR3-1600
ASUS P8Z68-V LX (Realtek ALC887 onboard audio)
EVGA GTX 970 SC

Share this post


Link to post
Share on other sites
I get the same when next to other cars sound crackles and with inconsistent volume.
Tried various setting from using 5.1 surround to normal stereo sound. Also changing to 16 bit and 24 bit variations 

Windows 10
I5 6600k
16 gb gdr 4 ram
1070 gfx
Realtor alc 887

Share this post


Link to post
Share on other sites
I have the same issue.
Tried all settings ingame, did not help.
Changing the Audio quality to normal in the hardware_settings_config.xml did not help.
Changing 16 bit and 24 variations did not help.
Uninstalled my Realtek Audio driver, installed the default from Microsoft Updates did not help.

Then i pluged in my Philips SHG7980 USB Headset because it has its own soundchip, and the problem is gone!!!
Have no problems with the USB Headset.

I have a Realtek ALC892 onboard chip this might be the problem.
Codies look into it ;)

Windows 10
Intel Core i5 2320
8GB DDR3
AMD Radeon R9 280x
Realtek ALC892



Share this post


Link to post
Share on other sites
Got the same Problem and couldn't fix it with the above posted solutions. Also sometimes the sound of cars on other parts of the track are weird and high pitched. What I mean with other parts is when two different parts of the track are very close to each other and you can hear the cars over the grand stands or something else. For example in China the last hairpin or parts of the monaco circuit like the start-finish straight.

Windows 10 x64
i5 2500
8GB DDR3
Sapphire Dual-X R9 280
Asus P8P67 (Realtek ALC892)

Either using a 2.1 speaker system or headphones.

Share this post


Link to post
Share on other sites

×