Jump to content
Want to report an issue? Have a bug to report? Please look here first!!!! Read more... ×

Archived

This topic is now archived and is closed to further replies.

Unable to save settings on PC

Recommended Posts

Unable to save settings on PC - graphics settings do save, but wheel settings do not. Manual saves do not work at all. I have an 'F1 2016' folder in 'Documents' --> 'My Games' with two files, 'hardware_settings_config.xml' and 'hardware_settings_info.xml' but no wheel settings are contained within.

OS: Windows 10 Pro x64
M/B: MSI X99A Gaming Pro Carbon
CPU: i7-6800K - 4.0GHz
GFX: MSI GamingX GTX 1070 (912-V330-001)
RAM: 16GB DDR4-2666 - 15-15-15-32 1T
AUDIO: ASUS Xonar DX
CASE: Siverstone FT-02B
PSU: EVGA Supernova 850 P2
MOUSE: Logitech G700s
KEYBOARD: Logitech G510
WHEEL: Thrustmaster T300 Ferrari GTE



Share this post


Link to post
Share on other sites
Savegame is located at:
C:\Program Files (x86)\Steam\userdata\<your_steramID>\391040

Don't know why they moved it there! It's the same as in Dirt Rally.
This stuff belongs to:
C:\Users\<user_name>\Saved Games

Share this post


Link to post
Share on other sites
Savegame is located at:
C:\Program Files (x86)\Steam\userdata\<your_steramID>\391040
That wasn't my issue, my issue was settings not being saved.

However it did lead me to think of something else (so, thank you for the nudge EnsiFerrum)....

The problem in my case was (as bloody usual!) Steam Cloud. Even though it was turned off in the Steam client settings. However, the problem was that if you check F1 2016 properties in the Steam client, Steam Cloud setting was greyed out. If you then turned on Steam Cloud in Steam client settings then you will see that the tick becomes visible in F1 2016 properties. I unticked the Steam Cloud settings in F1 2016 properties, turned off Steam Cloud in the Steam client and everything works as it should, the settings are now being saved. I did also delete everything in '...\\Steam\userdata\<your_steamID>\391040' to be on the safe side, belt and braces stuff.

Your mileage may vary, especially if data has already been sent to Steam Cloud.

No idea if it will help anybody else...


Share this post


Link to post
Share on other sites
I'm having the same problem but with video settings instead of wheel settings. I tried Rapster's fix but nothing changed. I don't have any "hardwaresettings" folder inside My Documents/My Games/F1 2016. The F1 2016 folder is just empty.

Share this post


Link to post
Share on other sites
I'm having the same problem but with video settings instead of wheel settings. I tried Rapster's fix but nothing changed. I don't have any "hardwaresettings" folder inside My Documents/My Games/F1 2016. The F1 2016 folder is just empty.

Have you tried to verify your game files from within steam?
Might also be an Option to delete the F1 2016 Folder in My games.

Share this post


Link to post
Share on other sites
I'm having the same problem but with video settings instead of wheel settings. I tried Rapster's fix but nothing changed. I don't have any "hardwaresettings" folder inside My Documents/My Games/F1 2016. The F1 2016 folder is just empty.

Have you tried to verify your game files from within steam?
Might also be an Option to delete the F1 2016 Folder in My games.

Just tried both things, none of them worked. If I delete the F1 2016 folder then the game creates a new empty one when starting again :(

Share this post


Link to post
Share on other sites
Just installed the game.
It started with failed to load file
Cannot save anything.
Tried every solution written above. But nothing works.
I work in Windows 10
I run as administrator. But I a "little" frustrated now. Please HELP!!!

Share this post


Link to post
Share on other sites
adjet and jjbuisan97, try installing everything from the '_CommonRedist' folder in the games installation directory. The installation location should be somewhere like: ...\STEAM\steamapps\common\F1 2016

The problem for you guys lies with your PC's, not the game. That's why it's difficult for people to help you, as we don't know the state of your systems and/or your level of knowledge.

Share this post


Link to post
Share on other sites
For me this didn't help either. The My Documents/My Games/F1 2016 folder is empty.
Graphics driver re-installed: no help
Nvidia Experience uninstalled: no help
No benchmarks are saved, either.
Could it be a problem with file paths and languages? My username on Windows contains ß, the system language is German and I run the game in English.

Share this post


Link to post
Share on other sites
Could it be a problem with file paths and languages? My username on Windows contains ß, the system language is German and I run the game in English.

Yes!

That could very well be it!

Edited to add: This has happened in so many games and applications before, not being able to handle non-Latin characters.

Share this post


Link to post
Share on other sites
@Lozzy @jennyannem You might pass this over to your developers ASAP. It's a simple amateur-error, fixable in about 5 lines of Code!

Share this post


Link to post
Share on other sites
Ich habe ein Problem mit meinen Pedalen. (Beschleunigen y- und Bremsen/Rückwerts y-) :/
Sie werden bei in den Einstellungen (Steuerungsschemata) als y- angegeben und lassen sich auch nicht ändern wenn ich es versuche.
Ich kann ansonsten das Spiel F1 2016 nicht spielen weil sich die Bremse und das Gaspedal gleichzeitig aktivieren.
Habe das Lenkrad Logitech Formula Force RX (Brauche Beschleunigen auf y- und Bremsen/Rückwerts auf y+) :)

Share this post


Link to post
Share on other sites
@Rapster
Don't think so. His wheel's axis isn't recognized. Has nothing to do with settings.
@Petnici
Schau mal in den Logitech Einstellungen (außerhalb des Spieles), ob Du für die Pedale/Y-Achse irgendwas mit "kombiniert" einstellen kannst.

Share this post


Link to post
Share on other sites
I don't have any special characters in my Windows username and still get the issue. Game language is English and PC language is Spanish, could that be the problem?

Share this post


Link to post
Share on other sites
I don't have any special characters in my Windows username and still get the issue. Game language is English and PC language is Spanish, could that be the problem?

Maybe. You have a blank in your Windows username?

My Windows is german, game is english, Username only characters from A-Z and a-z, no numbers, no Special characters, no blanks. And it saves as it should.

What also might be a Problem is described  in this Forum post over @ RaceDepartment. Scroll down to "Additional recommendations".

Share this post


Link to post
Share on other sites
I don't have any special characters in my Windows username and still get the issue. Game language is English and PC language is Spanish, could that be the problem?
Sorry to ask, but which issue? Not saving video settings, not saving controller settings?
Check for the steam cloud problem Rapster mentioned in the third post of this thread.

Share this post


Link to post
Share on other sites
I don't have any special characters in my Windows username and still get the issue. Game language is English and PC language is Spanish, could that be the problem?
Sorry to ask, but which issue? Not saving video settings, not saving controller settings?
Check for the steam cloud problem Rapster mentioned in the third post of this thread.
Video settings. I tried all the fixes written in this thread, including the Steam Cloud one.

Share this post


Link to post
Share on other sites
Perhaps the special character is before your username. Please post the full path to your My Games\F1 2016 folder.
Perhaps the problem lies in the Spanish translation of My Games?

Share this post


Link to post
Share on other sites
Hi!

I finally found the problem and fixed it! The error lies in the Windows user folder name; mine was "C:/Users/JoséJavier", and that "é" accent was messing the game up. I formatted my PC and created a new account without any special characters, as it seemed impossible to change that user folder name without having to deal with registry stuff. Now the video settings save properly and the F1 2016 folder in My Documents is NOT empty, as it contains a "hardwaresettings" subfolder.

Share this post


Link to post
Share on other sites

×