Jump to content
Want to report an issue? Have a bug to report? Please look here first!!!! Read more... ×


This topic is now archived and is closed to further replies.

F1 2016 PC- car will not accelarate with g27 logitech

Recommended Posts

When I'm in a race I can hear the revs, the car tyres move left to right but the car stays put. It's as if acceleration and brake are mapped to the same pedal.

What I could see in settings -

First the correct steering wheel wasn't matched. It came up with Logitech force. When I disconnected the steering usb cable it detected it as the correct input device but the scheme remained for Logitech force. Tried the game and the same.

I manually custom mapped all the buttons and the same thing. I've tried different motherboard ports, pc and game restarts and the same thing, I can hear revs but no movement. Pretty certain this a bug.

I've been waiting ages for this. Suppose I need to wait a little longer unless code masters can help in a solution.

Share this post

Link to post
Share on other sites
Hi @Bighead8181, try the suggestions in the linked post and let us know if that fixes this problem for you.


Share this post

Link to post
Share on other sites