Jump to content
Want to report an issue? Have a bug to report? Please look here first!!!! Read more... ×

Archived

This topic is now archived and is closed to further replies.

Huge deadzone using separate pedals and steering wheel

Recommended Posts

Hi,

The steering wheel seems fine, but the pedals calibrated with DIview have a huge deadzone of around 40-50%. Any idea where in my system the controller files are? But it is a bug, please consider this for the first patch, thank you.

Share this post


Link to post
Share on other sites
I have the same issue as many others. You have both Brake and Throttle stuck on. It also doesn't remember the assignments if you change the throttle axis from Y- to Y+ or vice versa.

I have a Logitech Driving Force (not the GT but the very 1st original one) and it works fine in F1 2015 and other games such as Project Cars.

Share this post


Link to post
Share on other sites
DGreco said:
We are looking into it. which pedals do you have?
That is quick, thank you!

The pedals are conventional mechanic setup linked with potmeters, wich are connected to the widely used (by controller mods) Bodnar Joystick controller BU0836X

http://www.leobodnar.com/products/BU0836X/

These axis are then calibrated in the little utility DIView

http://www.leobodnar.com/shop/index.php?main_page=page&id=12

Ive read another user using HE Sim pedals also calibrated with DIView experiencing the exact same problem.

Until and if a patch comes out adressing this, is there a controller.xml file in the game folder where I could try and tweak something?

In DIview the pedals work fine. In F12016 the revs only start to rise when the pedal is pressed 40-50%. IN the advanced options screen de bar and counter only rise when 40-50% of the pedal is pressed. Changing sat and or lin only changes the reaction within that band, but doesnt expand the travel response. I hope this info will help you locate whats the problem.

Share this post


Link to post
Share on other sites
DGreco said:
We found the problem. It is a bigger problem than expected, but rest assured that we are working on it.
Thank you! I havent driven a lap in anger yet, so no idea wheter its a huge hinderance, but you guys acknowledging this is a big, big step in customer service by Codemasters. Appreciated!

Share this post


Link to post
Share on other sites
DGreco said:
We found the problem. It is a bigger problem than expected, but rest assured that we are working on it.
That would be fantastic if you could fix this issue. I also use pedals connected via the BU0836 joystick controller and have the same deadzone issue since F1 2015.

Share this post


Link to post
Share on other sites
Yes I am having the same issue with He Pedals configured within diview. The same issue existed in f1 2015 and made that unplayable. Thanks for looking into and trying to fix this, I know a few other people with HE Pedals who are having the same issue. The pedals work fine in Dirt Rally...

Share this post


Link to post
Share on other sites
Dont count on it moosed i have only been waiting over a year for a fix with the he sim pedal since f1 2015 day one they said the same thing, and am still waiting.

Share this post


Link to post
Share on other sites
GsmEuk74 said:
Dont count on it moosed i have only been waiting over a year for a fix with the he sim pedal since f1 2015 day one they said the same thing, and am still waiting.
well count on it because we are working on it. if we cannot fix it is not because we are not working on it.

Share this post


Link to post
Share on other sites
DGreco said:
GsmEuk74 said:
Dont count on it moosed i have only been waiting over a year for a fix with the he sim pedal since f1 2015 day one they said the same thing, and am still waiting.
well count on it because we are working on it. if we cannot fix it is not because we are not working on it.
Thank you for working on it, it's a game breaking issue which is a shame as this years game seems otherwise impressive !

Im sure you can't answer this but i'll ask anyway... is there any kind of time frame within which you think this could be fixed ? It sounds as if it's not an easy fix which perhaps suggest it might take a while.

Share this post


Link to post
Share on other sites
DGreco said:
We are looking into it. which pedals do you have?

I have the same issue thank you. I have G27 pedals plugged in using the Ricmotech cable. All is fine in the DI View but there is a 50% dead zone in game. Only the last 50% of pedal travel is recognised. Therefore currently I can't play the game :(   

Share this post


Link to post
Share on other sites

Try creating your custom mapping again and see if the changes take effect then.

EDIT: I should caveat this by saying that we haven't tested this on all devices, but think the fixes we made should work on more pedals that we have listed in the latest patch notes. For devices that still don't work, we'll need enough info to try and replicate the setup here for further testing.

Share this post


Link to post
Share on other sites
New patch released today has fixed everything, very happy with the quick solution to this issue.

Cheers Mr Greco/Codemasters

Share this post


Link to post
Share on other sites
Hoo said:

Try creating your custom mapping again and see if the changes take effect then.

EDIT: I should caveat this by saying that we haven't tested this on all devices, but think the fixes we made should work on more pedals that we have listed in the latest patch notes. For devices that still don't work, we'll need enough info to try and replicate the setup here for further testing.


The latest patch hasn't fixed my issue. My setup is;

- G27 pedals with the Ricmotech usb cable/ adapter. (DIview setup)  
- Logitech DFGT

- PC; AMD - FX-9590
                    R9390X
        RAM - 8GB
          OS  - WIN10

Do you need any other details?

Just did a new custom controller settings. It now registers my pedals as fully 100% pressed down even though I am not touching them :(  

Share this post


Link to post
Share on other sites
My problem was solved by creating a new save game and creating custom controls!
In all the confusion I think I had to do it twice to be successful so try this more than once if its not fixed.
Fyi I am on G25 pedals with Leo Bodnar cable.

Share this post


Link to post
Share on other sites
My problem was solved by creating a new save game and creating custom controls!
In all the confusion I think I had to do it twice to be successful so try this more than once if its not fixed.
Fyi I am on G25 pedals with Leo Bodnar cable.

Hoo said:

Try creating your custom mapping again and see if the changes take effect then.

EDIT: I should caveat this by saying that we haven't tested this on all devices, but think the fixes we made should work on more pedals that we have listed in the latest patch notes. For devices that still don't work, we'll need enough info to try and replicate the setup here for further testing.

A new game save fixed the issue. Lucky for me I hadn't played the game at all really :D Thanks so happy!

Share this post


Link to post
Share on other sites

×