Jump to content
Want to report an issue? Have a bug to report? Please look here first!!!! Read more... ×
Scheduled Updates and BETA Shutdown - 06/07/2020 Read more... ×
F1 2020 | KNOWN KEY ISSUES | READ ME!!! Read more... ×

Archived

This topic is now archived and is closed to further replies.

Having a wheel issue? Look in here

Recommended Posts

here is a link to my DFGT wheel setting they may help some one .
http://forums.codemasters.com/discussion/45365/my-dfgt-wheel-settings#latest

Share this post


Link to post
Share on other sites
 i have problems with the steering wheel in game. If i dont do anything. Brake and throttle are both on 50%. And whatever i do. I cant drive. Really weird stuff. Because it said that the dfgt would be compatible with the game.

Share this post


Link to post
Share on other sites
@jennyannem

Hi, I hope the G27 settings are going to be improved, i love this game but hold disappointment in the wheel settings area for the g27.

Having driven many if not all major simulators this is the biggest area this game can improve on massively and i understand it is not meant to be a simulator, if you are to support wheels they need to be very well implemented  and worked on seems it is a driving game (probably the biggest ballache to work on along with gpx drivers), yes the steering has has improved alot since f1 2015 for sure and thanks to @DGreco i hear this is so.

-FFB Options work fine for the wheel and offer more than enough adjustment for all.
-Wheel rotation/Degrees Why are users changing this in the logitech profiler? Above we are told to use 360 degrees which i agree feels great but surely this can be set when selecting the g27 wheel in-game and then if we feel we need to change do so via the LP.
-Pedal Options are were i feel this whole thing hits the ground hard, No Pedal feels like they are linear instead they feel nothing more than on/off buttons, the worst being the accelerator even with 100% Linearity, the last 2 inch of the pedal is now where the on/off button moved too! I have worked on the brakes enough to get them very close with a 20% Linearity.

I feel if both Saturation and Linearity were to be worked on for the g27 lots of us may finally be able to take off the traction control, personally with this wheel and the game settings for the g27 i cannot drive in full manual. (only game that i can't fully drive manual).

I hope the above helps and also refined soon in a patch.

Share this post


Link to post
Share on other sites
Finally I was able to retrieve my password :smirk:
I run a G27 base, with funny enough, no issues, but...On top of my G27 I have a Roso-wheel, running SLIMax Manager with the hardware from Leo Bodnar. In every other SIM I have ever encountered (quite a few) I have never had any problems. With previous titles from Codemasters, apart from a few glitches, no problems. But with 2016...damn :open_mouth:  none of my buttons, or switches work at all, the input does not respond. Naturally they are all visible in Windows (Win10-64) tweaked and usually very precise and responsive, both analogue and digital. But with F1 2016, so far I have only been able to drive auto-gears, and use the buttons on my keyboard, making the whole thing ridiculous since I have build a full cockpit...PLEASE fix this Codemasters, the sooner the better !
Can't you just copy what we had in 2015 ffs, even though the game says it doesn't support SLIMax, it is actually working flawlessly.

Share this post


Link to post
Share on other sites

We are currently looking at wheel issues, but here are things for you to try if you're having issues:


Logitech G25/27:

·         If you use nVidia graphics, uninstall the NVIDIA Geforce Experience. (For now)

·         Restart your PC and try to launch the game. It should work right away. If not, try a second launch of the game right after.

 

If it still doesn't work:

 

·         While in Windows, unplug the wheel.

·         Uninstall the Logitech profiler.

·         Re-download the Logitech profiler for the G27 and your OS from here: http://support.logitech.com/en_us/product/g27-racing-wheel#download

·         Plug in the wheel when the program prompts you to.

·         Open the Logitech profiler and go to global device setting, and make sure "report combined pedals" is NOT ticked.

·         Set the degrees of rotation to 360 and David Greco has personally recommend using the FFB settings from top to bottom as follow; 100,0,0,0 and Enable Centering Spring in Force Feedback Games make sure is NOT ticked.

 

Logitech G29/920:

·         While in Windows, unplug the wheel.

·         Uninstall the Logitech Profiler.

·         Re-download the Logitech profiler for the G29 or G920 and your OS from here:

o   G29 http://support.logitech.com/en_us/product/g29-driving-force#download

o   G920 http://support.logitech.com/en_us/product/g920-driving-force#download

·         Plug in the wheel when the program prompts you to.

·         Update the firmware if the Logitech software asks you.

·         If you use nVidia graphics, uninstall the NVIDIA Geforce Experience. (For now)

·         Reboot your PC and try to launch the game. It should work right away. If not, try a second launch of the game right after.

 

Thrustmaster wheels and any wheel in supported list come up as unrecognized:

 

·         Always make sure you have latest drivers and firmware.

·         If you use nVidia graphics, uninstall the NVIDIA Geforce Experience. (For now)

·         Reboot your PC and try to launch the game. It should work right away. If not, try a second launch of the game right after.


Windows doesn't recognize the G920. Tried everything. USB's work. Uninstalled, installed, etc. Anyone the solution?

Share this post


Link to post
Share on other sites
Latest patch has borked my wheel and the whole game..was working fine last night..

Whenever I turn the wheel more than 45 degrees the whole wheel shakes and the FFB is so strong shaking back and forth i have to shut down the game..

Was fine last night before the patch..

Fanatec Clubsport wheel V2 and F1 Rim.. Fanatec pedals V3.

Windows 10

2 x GTX 1070's

Share this post


Link to post
Share on other sites
with last nights patch the wheel issues still havent been resolved, the biggest issues im having personally in online races
where it still cuts out on me, before last nights patch i had instances where it did run occasionally but as of last night the wheel will cut out in the first 5 laps which makes online unplayable atm , ive done everything codemasters suggested (uninstall geforce, dont run any other usb device , update every driver) i can only conclude that its something wrong in the game as these problems are getting worse and worse with every patch thats gets put in.

Share this post


Link to post
Share on other sites
I'm not sure if this is normal or not, but I've got my Bodnar FFB wheel, HPP pedals, and Ascher Paddle shifter plate all working fine with the game(so *FAR*). I just set controller scheme to "Custom" and I was able to assign everything one by one. Which is surprising, considering how much of a hard time I had setting things up in GRID 2 and the earlier Dirt games.

Have you guys with Logitech Wheels tried doing that?

Share this post


Link to post
Share on other sites
Never mind.....game suddenly doesn't even acknowledge my Bodnar wheel any longer. When trying to assign the X-axis to steering, and I turn my wheel, it'll simply revert to unassigned. WTF????

Share this post


Link to post
Share on other sites
F1 2016 on PS4, using T300 wheel. Sometimes the wheel (turning & fbb) responds not immediately when exiting the pit lane. Sometimes within a second, sometimes it take seconds. 

If this was already addressed in another topic. Sorry could not find it easily after reading/searching in a lot of topics :) 

Share this post


Link to post
Share on other sites
I've had to update the game and my PS4. But now the camera always shows my rear view, eventhough I'm going forward. What am I doing wrong?
System; PS4
Wheel: thrustmaster T500RS

Share this post


Link to post
Share on other sites
F1 2016 on PS4, using T300 wheel. Sometimes the wheel (turning & fbb) responds not immediately when exiting the pit lane. Sometimes within a second, sometimes it take seconds. 

If this was already addressed in another topic. Sorry could not find it easily after reading/searching in a lot of topics :) 
Yes this has been raised before earlier in the topic and I believe even a video has been posted earlier in the topic. I think CM were looking into it.

Share this post


Link to post
Share on other sites

My new Thrustmaster Ferrari Racing Wheel Red Legend Edition don't work with the F1 Game.
Message: The input device "FGT Rumble 3-in-1" is incompatible.
What can I do?

Sys-Spec:

AMD Phenom II X4 955, 12 GB RAM, AMD Radeon R7 360 graphic card, Windows 7 Professional SP1, 64 bit

Share this post


Link to post
Share on other sites
So I had posted elsewhere, but no responses. 

Hi all,

So I just fired up the game to find that my steering wheel settings have gone weird - As you can see each of the assignments is showing "error", and I can't seem to find a way to re-register any of the bindings. Anyone else come across this issue?

EDIT: http://imgur.com/a/5RYhG - Imgur link as I can't seem to embed the screenie.

I'm using Thrustmaster T80 on PC if that makes a difference - I have checked that it's working correctly in Project Cars, so I don't think it's driver based.

Cheers

Share this post


Link to post
Share on other sites
@DGreco An issue I'm having with the T150 on PS4 is some very inconsistent feedback levels across different sessions. It's hard to explain just how and when it happens, the best example I can give was my career race at China, during the practice sessions FFB felt great and the wheel weight very good, but once I get to qualy and especially the race, it feels like 50% of the weight and feedback was gone, it all felt very floaty and too light, to the extent that I wasn't really enjoying the driving anymore. During most sessions I'd say the FFB and weight feels much nicer in practice than it does in the race somehow, it happens every time after playing for a while.

EDIT: I have to add I always started with these practice sessions first when I started up the game, so it could also be an issue of FFB just reducing somehow after playing for a while and/or doing something, like going to the garage, restart session, using a flashback etc? I'll try and see what happens if I go straight into a race the next time I start up the game.
I think i've the same issues. With my t150, on PS4 when I start a session,career or week end etc. I have feedback, vibration just for one lap and after nothing. Like you is floaty and light. I have to restart the PS to have it just for one lap again. I was thinking about a wheel problem but I dont know. I put the wheel on a PC for the last firmware but it's the same. 
Maybe I have to send back the wheel to take a t300 or a g29. It's my first wheel. ( sorry for my english by the way 
Me too. T150 FFB on PS4 is not working properly. I had a few moments in which i really enjoyed the game, but now it;s all gone for some strange reason. I got realy tired of it so i simply stopped playing. It's frustrating if i'm gonna play the game like this, so it's better to just stop. What now? Am i to sell my T150 steering wheel or could it be that there will come a solution to this issue?

Share this post


Link to post
Share on other sites
Myself and two of my friends are all having issues with our Fanatec CSW V2s where the FFB is turned off when starting multiplayer. Switching the wheel off and on again will fix it most times.

Share this post


Link to post
Share on other sites
Im thinking. Maybe it's because of the fact that i accidently forgot to move the PS3/PS4 silder on the steering wheel when i connect it to the pc for calibration and back to the PS4. There is a warning on the website of Thustmaster if you check out the features of the T150 that you should always slide it to PS3 when you connect to the pc and always back to PS4 when you connect it to the PS4. I admit there were a few incidents in which i forgot to put it in the right direction. Maybe it messed up the wheel.

Share this post


Link to post
Share on other sites
Its definitely a Codemasters issue.
I've followed all the steps, multiple times to get the ForceFeedBack (Ffb) working on my Logi G920 and this god forsaken game. 
I really love how we are all having to pay Codemasters full price for the 'Honour' of being Beta testers for them. Warms my bloody heart <not>.

I've now lost 2 days of my life debugging for them and am no closer to getting Ffb working.
The game is all but unusable without it.

My wheel works with every other game i have and even the old F1-2015.

I'm neither willing or able to re-install my pc, as it is a dual-use HTPC & Gaming machine and will take a full week to set it all up again and reprogram all the video capture cards and tuners. I am not doing this, just for your game.
I've not reinstalled the game, as i don't savour the idea of having to download another 27 Gigs of data on my poxy slow connection, just for something that won't work anyways. Steam validation of the game confirmed it was all correct anyways.

Findings so far:
* Uninstalling GeForce Experience, Ffb=fail.
* Have rebooted and restarted game multiple times, Ffb=fail.
* Latest Wheel firmware, LogiProfiler (Lp) and game patches fixed pedal problems, but Ffb=fail.
* Unplugging wheel during and/or after F1 game loads = fail.
* Alt+Tab'g tween windows re-enables Ffb on wheel, but tabbing back to game see's it fail as soon as driving starts.
* New Windows LogiG920 usb driver, gives proper pedal assignments, Ffb=fail
* Killing process=Lp before and after game, Ffb=fail





Share this post


Link to post
Share on other sites
U know i purchased PS4 + wheel + wheelstand for this game. But actualy ... of course there are more cool racegames on PS4 in which the FFB on my T150 would work fine probaby. There is Forza Horizon 3 coming up and of course i can wait for F1 2017, by then they should have solved the FFB issues. :)

Share this post


Link to post
Share on other sites
I just can not make my G27 pedals work: either it goes directly from 0 to 100 or if I combine and assign the brakes to the clutch pedal, the accel pedal range goes from 50 to 100...no idle. Fix is not working...tried all the suggestions.
Also, I just cannot save my settings and they even change from the main menu setup to an in-lap adjustment. Quitting and restarting bring my game to its "zero" state where I have to configure everything again.
It is just impossible to drive! Does anybody have any tip or clue? Thanks.

Share this post


Link to post
Share on other sites
Still no fix or statement regarding this:

http://forums.codemasters.com/discussion/comment/219783/

Share this post


Link to post
Share on other sites
For me this is what helped (solved):

OK...found a workaround for the G27: logitech profiler set to combined pedals (I need those for PCars) - assigned the brakes to the clutch pedal (should work fine right away) - check your controls advanced settings range for the accel (mine ranged from 48 to 100) - set the deadzone for it in the same amount (48 in my case) - move accel linearity to 100...solved.

As for the saves, I read your user/account name must NOT have any other character other than letters.

Share this post


Link to post
Share on other sites
I tried to see if the game has enjoyable ffb after the new patch ... but no, its terrible. All i can do is hope that there will come a future patch in which it does work fine again. I wont play the game like this because it isn't enjoyable.

Share this post


Link to post
Share on other sites
I have just done the latest update for the game on the ps4 and found my Logitech G29 wheel not responding. Buttons are okay but no wheel. Car goes straight over to the left. Everything was great up till the update.

Share this post


Link to post
Share on other sites

×