Jump to content Jump to content

F1 2016 (PC) Issues- No engineer or announcers


jlp0209

Recommended Posts

Hi-
I posted this (and requested delete) in the general forum, sorry to double post, figured this is the appropriate forum for my question.

Installed the game in Steam last night and I'm getting strange errors. There is no voice at all- engineer or announcers. When starting a quick race or championship season, once I hit the loading screen I am unable to select any options; the screen is mostly solid white but I hear the sound of some cursor moving when I move the directional stick on my controller. So the options are not appearing for me for some reason. During races and in garage there is no engineer voice at all. Prior to starting a race, when the announcers should be speaking while the camera pans over the entire track, there are no announcers and it is dead silent. My audio settings in the game are set to stereo speakers. I've been playing other games and they all sound as they should. 

I tried deleting the game and hardware settings and re-installed, it did not help. I tried sweeping my graphics drivers and re-installed the latest ones from Nvidia. Also did not help. I am running a GTX 980 Ti card and Windows 10 Pro anniversary edition update. I rolled back my GPU to stock settings and it is not overclock related. I have not heard of anyone reporting this issue, it is so strange. Any help would be appreciated!
Link to post
Share on other sites
I got the same problem since today. I am missing the voices of the announcers, the teammembers in career mode and te radio pit messages during the game. I guess it went wrong for me since i canceled the subtitles.
Tried the reinstall and all but no luck sofar

Any suggestions on how to solve this problem?
Link to post
Share on other sites
jlp0209 said:
[...] When starting a quick race or championship season, once I hit the loading screen I am unable to select any options; the screen is mostly solid white but I hear the sound of some cursor moving when I move the directional stick on my controller. So the options are not appearing for me for some reason.
You might be running into the 144Hz Bug. Set the refresh rate to 120Hz or lower.

About your Sound Problöems I have no idea, but the F1-201x series is famous for their flaws in Audio design.
Link to post
Share on other sites
Got the same issue as jlp0209 and Asphert - and I didn't disable the subtitles. I did a clear install of my graphics card drivers and re-installed the game but with no success yet. If you find any solution for this please share. It's quite a good game, much better than the 2014 and especially 2015 version - but I need my technicians voices during the race! :-)
Link to post
Share on other sites
I fixed my issues. It was a combo of the 144hz bug (set the refresh rate in game to 119/120) and wrong audio settings in Windows. Windows 10 anniversary update reset my audio settings to 5.1. I changed it back to "stereo speakers" in Windows and also within the game, and now everything works as it should.

The horrible audio clipping and cutting out when driving near other cars is still there, and it's awful, but CM is aware of it and working on it per another thread. 
Link to post
Share on other sites
  • Codemasters Staff
Not sure what the workaround is doing other than turning the volume of the AI down, but I'll check that tomorrow to see if it's actually having some sort of interaction with the problem.

We are investigating the problem, though. :)
Link to post
Share on other sites
Tried adjusting the volume as suggested. Still doesn't fix the stuttering and cutting in / out audio. In my case when the audio severely stutters / clips / whatever you want to call it, the video also gets choppy ever so slightly. Game is unplayable when this happens. It even happens during practice sessions in career mode with 1 other car nearby, enough to mess up my whole lap. Game is otherwise fantastic and I'm already addicted. Can't wait until this is fixed.
Link to post
Share on other sites
  • Codemasters Staff
jlp0209 said:
Tried adjusting the volume as suggested. Still doesn't fix the stuttering and cutting in / out audio. In my case when the audio severely stutters / clips / whatever you want to call it, the video also gets choppy ever so slightly. Game is unplayable when this happens. It even happens during practice sessions in career mode with 1 other car nearby, enough to mess up my whole lap. Game is otherwise fantastic and I'm already addicted. Can't wait until this is fixed.
Hi jlp,
1) Is the engineer / announcer issue now resolved, was this simply your setup being incorrect?
2) The"choppy audio" could be one of  three issues.
 - Sound driver issue. We've submitted a fix which will be in the next patch.
 - Stuttering AI cars. A fix in currently being worked on for this and will be in a future patch.
 - Performance. If video is also stuttering this could be a performance issue rather than something specifically concerning audio.

Link to post
Share on other sites
  • 2 weeks later...
Hi there! Same problem here, no engineer or announcer voices at all. I tried all the hints above but no success. I'm using Realtek onboard audio on a MSI X99 SLI Plus Mainboard connected to a Logitech Z-5500 5.1 system (and Windows 10 Pro and 2x GTX 980 SLI if that matters).

- Tried different connections (optical and analogue) to the sound system
- Changed speakers to CD and DVD quality
- Tried to set stereo and 5.1 in Realtek sound card utility
- Played around with in-game sound settings (Auto, Stereo and 5.1)
- Switched to monitor's built in speakers connected by DisplayPort
- Tried using stereo headphones connected to front panel
- Updated sound card driver

Anything else I could look at? Any help would be highly appreciated, thanks!
Link to post
Share on other sites
  • Codemasters Staff

- Played around with in-game sound settings (Auto, Stereo and 5.1)

Have you tried changing the settings on your PC sound settings?
- Right click on the speaker in your system tray and go on playback devices.
- Ensure you are using the correct output device then configure this and select your correct output configuration e.g. 5.1 if your playing in 5.1 surround.
Link to post
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...