Jump to content
Want to report an issue? Have a bug to report? Please look here first!!!! Read more... ×

Archived

This topic is now archived and is closed to further replies.

[F1 2016 PC] Sudden stuttering/framerate drop

Recommended Posts

Come on Codies! I would love to see your test rigs and how you don't have the problem. Pretty sure I could replicate it or see why you are unable to - IF that is really the case.

Share this post


Link to post
Share on other sites
376.19 and just a whole world of mess - massive stuttering in TT on Austria. Just makes me wonder whether tonight's online race is going to be any use.

Share this post


Link to post
Share on other sites
FINALLY!!! I've got rid of it! I'll share the story so hopefully it can help any of you guys.
After browsing alot of different forums and trying stuff like different general BIOS settings untill doing a raindance (not to be adviced to do indoor :tongue:), I found something that got rid of the silly framedrops from a constant 60 to 30's on random moments. 

Long story short: I got AMD OverDrive and disabled Turbo Core Control which did the trick for me (Nvidia GFE installed and everything on base settings). See the 'longer story' below for the rest of the explanation.

Summary of my setup: AMD FX 8350 on a Gigabyte mainboard, EVGA GTX 960 2GB, 8GB RAM, SSD/HDD, Logitech G29 steering wheel.


I hope that any of you guys can try this and see if this fixes your problems too. Be adviced, make sure your tempatures are within the normal range.

Longer story: I've read somewhere that the Gigabyte mainboard have a default higher voltage setting for the CPU. I went looking for ways to underclock my CPU. The CPU itself wasn't even breaking a sweat during gaming (way below 50% while gaming), so to sacrifice some CPU power wasn't a problem. I rather not mess to much with BIOS setting if not needed, but this issue was driving me nuts! I got the game Dirt Rally on Steam sale which was also showing this problem (yes, also a Codemasters game :)). Since that game showed the problem more consistent on certain parts of the first track I did there, it was easier to test different settings. I stumbled on a link (see below) for 'AMD FX CPU Throttling Fixes' which gives a couple of options to try out. The 2nd tip was the golden one for me (BIOS settings in the 1st tip are back to normal). 

'AMD FX CPU Throttling Fixes' forum link http://www.overclock.net/t/1202751/amd-fx-cpu-throttling-fixes-please-sticky
AMD OverDrive™: http://www.amd.com/en-us/innovations/software-technologies/technologies-gaming/over-drive

Again: watch out while adjusting these settings and make sure that your PC tempature stays within the limits.
When starting OverDrive you can find the Turbo Core Control under 'Clock/Voltage' with a button under the 'Clock' option. Uncheck the tag and Save the settings. Under the 'Preferences > Settings' I've enabled to 'Apply my last setting when system boots' and I also set it as default for now.
I might try to tweak the voltage settings in the Turbo Core Control later on, but for now I'm just happy that the framedrops are gone for me.

If you try this please let us know if it helped or let me know if you got any pointers for me. 

Edit: the settings don't stay after a reboot, so if this helps anyone make sure you disable the Turbo Core Control after a reboot

Share this post


Link to post
Share on other sites
good evening
In case of steam Please check if it is in compatibility mode by right clicking steam icon Program Files (x86) \ Steam (.exe)
If compatibility mode is checked, release
I did not remember changing to compatibility mode

Share this post


Link to post
Share on other sites
Guys case I have a fix for it. 
In my case I have Windows 10 and for some reason, in the past I set the compability mode for steam to windows 8.
Now when I removed it, I have significantly higher fps (from 17 to 130).
Hope it helps for some of you!

Share this post


Link to post
Share on other sites
Hey guys. I had a lot of trouble when I bought the RX 480 8gb card. F1 kept stuttering and Fifa. Tried everything but nothing worked. Went into bios and loaded default values with no over clock and boom, worked absolutely fine. New crimson drivers too. Basically if it ain't broke don't over clock the cpu! My 8320 is already running at 3.5ghz a f that she plenty. No need for over clock. It just causes problems! Running amazing now!!! 

Share this post


Link to post
Share on other sites
Hey guys. I had a lot of trouble when I bought the RX 480 8gb card. F1 kept stuttering and Fifa. Tried everything but nothing worked. Went into bios and loaded default values with no over clock and boom, worked absolutely fine. New crimson drivers too. Basically if it ain't broke don't over clock the cpu! My 8320 is already running at 3.5ghz a f that she plenty. No need for over clock. It just causes problems! Running amazing now!!! 
Maybe research what you're doing, you most likely were overheating due to sub-optimal aftermarket cooling and thus your CPU kept dropping clocks while in-game causing frame drops perceived as stutter whilst the CPU frequency bounces all over the place.

Share this post


Link to post
Share on other sites

These anecdotes are all pretty nice but they don't explain what is going on.

It would be really cool to know the spec of the CM test rigs, then at least we could find or eliminate commonality.

Share this post


Link to post
Share on other sites

×