Jump to content
Want to report an issue? Have a bug to report? Please look here first!!!! Read more... ×

Archived

This topic is now archived and is closed to further replies.

GTX 1070 can't handle Ultra at 1080p?

Recommended Posts

So I've just bought the game, Nvidia drivers are updated to the latest ones, I've set Control Panel settings to Prefer Maximum performance. Yet whenever I get into a full grid race with the heaviest rain settings, framerate drops to the low 50's at the beginning of the race as well as any other part of the lap that has any sort of back straight, and then again on the start/finish straight, yet other parts of the lap, whether I'm in a tight pack or out by myself the framerate stays at 60 until I hit a straight again. If I turn the settings down to the High preset, I still get framedrops at the beginning of the race but by around turn 3 the framerate goes back to 60fps. GPU usage never goes past 75% despite the card showing its running at my 2113Mhz OC when I have V-Sync off for testing (usually I have V-Sync on when playing games normally), but when the framerate drops so does GPU usage to around 50% and CPU usage is around the high 80% mark. Is this normal performance for anyone else with a similar CPU/GPU combo? During clear weather, while framerates aren't exactly stunning but they don't drop below 60. I'm a bit disappointed by the performance I'm getting, while F1 2016 isn't an ugly game by any margin, in my opinion I don't think it looks good as other racing titles on PC such as Need for Speed 2016 and Forza Apex which I have no troubles at keeping above 60fps on Ultra.

Is there some sort of poor CPU optimization going on here as I've seen a couple threads related to weird CPU usage. Oh yeah and I have V-Sync on. My Specs are:

Corsair Obsidian 750D Airflow Edition case with 5 AF140 chasis fans
i5 6500 @3.3Ghz (temps never go past 45c in-game)
Alpenfohn Matterhorn Black CPU Cooler
ASUS Z170-E MoBo
HyperX Fury DDR4 16GB RAM @2113Mhz
ASUS Strix RoG GTX 1070 @2113Mhz temps never go past 50c in-game and on 372.54 drivers
Corsair RM850i PSU

Windows 10 Pro 64-bit version 1607

Share this post


Link to post
Share on other sites
This is going to sound strange but update your audio drivers.  If you use an integrated audio card (built in motherboard) then you may have to update your motherboard chipset drivers too.  I have fixed frame rate issues before by upgrading audio drivers due to the audio calls the game makes and the sound card taking too long due to audio problems.

If not an integrated audio controller then it may be easier to update drivers.  Also Nvidia likes to change your default audio drivers if you are using an hdmi cable on your video card so every time I update my video card drivers I either reinstall my audio drivers or update audio drivers.


Hope that helps.

Share this post


Link to post
Share on other sites
Nope,for me it's ok all settings to ultra at 1080p gameplay very smooth for me.
PS.I have all stock not overclock(cpu/gpu)

My specs is under.

Share this post


Link to post
Share on other sites
Ravanor77 said:
This is going to sound strange but update your audio drivers.  If you use an integrated audio card (built in motherboard) then you may have to update your motherboard chipset drivers too.  I have fixed frame rate issues before by upgrading audio drivers due to the audio calls the game makes and the sound card taking too long due to audio problems.

If not an integrated audio controller then it may be easier to update drivers.  Also Nvidia likes to change your default audio drivers if you are using an hdmi cable on your video card so every time I update my video card drivers I either reinstall my audio drivers or update audio drivers.


Hope that helps.

Cheers for that, I built this rig like a week ago, after installing Windows 10 all I have done was download the latest Nvidia drivers and a BIOS update for the motherboard, I'll give this a go as I am indeed using the motherboard's 7.1 surround where as with my old rig I was using a PCIE soundcard.

Edit: Unfortunately that doesn't seem to of solved it. Although ASUS didnt really make it clear how I was meant to update my chipset or audio drivers, but to be sure, I disabled the Onboard Audio and used my Scarlet FocusRite USB Audio Interface instead and I still got the same drops in FPS during heavy rain.

I'm maxed out @ 1440p with no frame issues on a 980ti ¯\_(ツ)_/¯
Out of curiosity what CPU have you got? Surely my i5 6500 shouldnt be a bottleneck?


Share this post


Link to post
Share on other sites
Ravanor77 said:
This is going to sound strange but update your audio drivers.  If you use an integrated audio card (built in motherboard) then you may have to update your motherboard chipset drivers too.  I have fixed frame rate issues before by upgrading audio drivers due to the audio calls the game makes and the sound card taking too long due to audio problems.

If not an integrated audio controller then it may be easier to update drivers.  Also Nvidia likes to change your default audio drivers if you are using an hdmi cable on your video card so every time I update my video card drivers I either reinstall my audio drivers or update audio drivers.


Hope that helps.

Cheers for that, I built this rig like a week ago, after installing Windows 10 all I have done was download the latest Nvidia drivers and a BIOS update for the motherboard, I'll give this a go as I am indeed using the motherboard's 7.1 surround where as with my old rig I was using a PCIE soundcard.

Edit: Unfortunately that doesn't seem to of solved it. Although ASUS didnt really make it clear how I was meant to update my chipset or audio drivers, but to be sure, I disabled the Onboard Audio and used my Scarlet FocusRite USB Audio Interface instead and I still got the same drops in FPS during heavy rain.

I'm maxed out @ 1440p with no frame issues on a 980ti ¯\_(ツ)_/¯
Out of curiosity what CPU have you got? Surely my i5 6500 shouldnt be a bottleneck?


Hmmm, you really need to install your motherboard drivers, such as chipset drivers...

Your CPU is not a bottleneck. The reason nothing is working is because you haven't got the correct drivers installed.

This is the page where you would download drivers for the Z170-E motherboard. Make sure that 'Windows 10 64bit' is selected in the drop down box. You need to install at least the drivers listed under the 'Chipset' subsection. Make sure you download and install the latest version of each driver as there will probably be several different versions of each driver:

https://www.asus.com/support/Download/1/50/1/18/wqTsdljS1qnLVVIf/45/

'Intel Chipset' is the same as 'Intel Chipset Software Installation Utility', so just install 'Intel_Chipset_V10.1.1.27'. The same goes for the 'Intel Management Engine Interface' or plain old 'MEI', so install 'MEI: V11.0.5.1189'.

Download any other drivers you may need from that page. (You more than likely need the USB (3.0/3.1), SATA and LAN drivers also. Just make sure you only download the latest version of each as some are duplicated with several versions.)

Let us know how you get on and if you have any more questions.

Share this post


Link to post
Share on other sites
Rapster said:
Hmmm, you really need to install your motherboard drivers, such as chipset drivers...

Your CPU is not a bottleneck. The reason nothing is working is because you haven't got the correct drivers installed.

This is the page where you would download drivers for the Z170-E motherboard. Make sure that 'Windows 10 64bit' is selected in the drop down box. You need to install at least the drivers listed under the 'Chipset' subsection. Make sure you download and install the latest version of each driver as there will probably be several different versions of each driver:

https://www.asus.com/support/Download/1/50/1/18/wqTsdljS1qnLVVIf/45/

'Intel Chipset' is the same as 'Intel Chipset Software Installation Utility', so just install 'Intel_Chipset_V10.1.1.27'. The same goes for the 'Intel Management Engine Interface' or plain old 'MEI', so install 'MEI: V11.0.5.1189'.

Download any other drivers you may need from that page. (You more than likely need the USB (3.0/3.1), SATA and LAN drivers also. Just make sure you only download the latest version of each as some are duplicated with several versions.)

Let us know how you get on and if you have any more questions.
Hi, thanks for the reply, although my other games have been running fine except for Just Cause 3 and Need For Speed 2016 which also suffers from random drops into the 50's, I did update my Chipset, USB, and RealTek drivers, although it seems as if my minimum FPS has approved and the drops arent as severe, I'm still getting them unfortunately.

@shaunhutchie what type of display are you outputting to...tv via hdmi?

I'm just conntected to a pretty simple 1080p 60Hz Acer monitor via DVI


Share this post


Link to post
Share on other sites
Anyone tried limiting to 60 FPS and disabling Vsync in game and applying Vsync to F1 2016 in Nvidia control panel?

Share this post


Link to post
Share on other sites

×