Jump to content Jump to content

Possible bug/glitch or might just be my 360


Recommended Posts

Hi folks,

I've found when using my owned Alfa 8C GT car my game/console freezes when at the race results page.  It happened once yesterday but thought nothing of it as I had been playing for over 6 hours straight on my 7 year old 360. After a couple of hours today its happened again on the very same car that I own.

Restarted and created a custom cup. Picked the loaned Alfa 8C GT car and everything was running ok. Then I picked my owned Alfa and again my game/console would freeze at the race results page.

So I decided to buy a different GT car from the same category. I've raced in it and everything works fine. 

With this, I thought stuff it I'll just sell the Afla. Problem is I can't as the cars resale value is at ZERO and the stats show that the car has never been used!!!!

Would this tie in with the corrupted saves others players have being dealing with?? Or should I report this separately??

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...