Jump to content
Sign in to follow this  

Windowed mode bug! [SOLVED]

Recommended Posts

Every time i start game it starts in widowed mode.In options its set to full screen, 1920x1080, refresh rate to 60.Not even ALT+ENTER working.

So, every time i start game i need to go to settings , change refresh rate to something else , than exit settings and it brings me back to full screen and when it ask me to save changes, no matter what option i choose, to save or discard, it stays in full screen until i restart game, than game starts in windowed mode again.I have tried to Verify Integrity of game cache, it doesnt help... 

Need a fix for that, its annoying :(

Share this post


Link to post
Share on other sites

I have the same problem. It really needs a fix, it's indeed very annoying especially if you are racing online - you have to leave the session and the party to fix it and you can't play at 24Hz refresh rate...

Share this post


Link to post
Share on other sites

lol adeadyet i did not know that you have this problem!  :o  . Me and DJ have it too! Every time i open the game its in window mode with low fps (i check them via fraps) .When i go in graphic's settings i change the Vsync to anything and screen becomes full mode with normal fps!  no matter if you change it from on to off or the opposite.I suspect this problem is about AMD cards and desktop scaling! I have this problem in Dirt 3 and Grid 2 too , but NOT in Dirt 2 and F1 2013! Before some months i had nvidia card  and i had not this problem in games i refered ... Yes its annoying anytime i start the game to go settigns to fix it... When you are in game and you minimize the game's window or go desktop happens the same , and you ahve to go again in settings to fix it! I have created a topic after 1-2 days of release date of GAS but i did not get any response  :\

Share this post


Link to post
Share on other sites

I suspect this problem is about AMD cards and desktop scaling! I have this problem in Dirt 3 and Grid 2 too , but NOT in Dirt 2 and F1 2013! Before some months i had nvidia card  and i had not this problem in games i refered ... 

I think you are right cause this problem occurs only when I play on my plasma TV where I have scaling enabled and yes- I am using an AMD video card, yet this needs to be fixed.

Share this post


Link to post
Share on other sites
Boyan said:

I suspect this problem is about AMD cards and desktop scaling! I have this problem in Dirt 3 and Grid 2 too , but NOT in Dirt 2 and F1 2013! Before some months i had nvidia card  and i had not this problem in games i refered ... 

I think you are right cause this problem occurs only when I play on my plasma TV where I have scaling enabled and yes- I am using an AMD video card, yet this needs to be fixed.

exactly i play on 42" TV and i need to enable scaling to cover all screen otherwise i have black lines around screen.. ;)

Share this post


Link to post
Share on other sites

The game seems to launch in windowed mode if it was in windowed mode when you shut it down.

This also applies if you CTRL+ALT+DEL and close the game.

Leave the game full screen and close via the in game shut down method and it'll start full screen next time.


EDIT just tested this and found it to be correct, exiting the game, in almost any other way than the in-game QUIT option results in it starting in windowed mode, it also appears that ALT+ENTER doesn't always work when the game is in the process of loading so you press ALT+ENTER and nothing happens, press it again and still nothing happens BUT, the game hags a few times during the loading screens so just try pressing it once and WAIT. It DOES change to full screen

Share this post


Link to post
Share on other sites

The problem is not only the full screen but the fact that the game runs with refresh rate less than 60Hz and it lags.

Share this post


Link to post
Share on other sites

The game seems to launch in windowed mode if it was in windowed mode when you shut it down.

This also applies if you CTRL+ALT+DEL and close the game.

Leave the game full screen and close via the in game shut down method and it'll start full screen next time.


EDIT just tested this and found it to be correct, exiting the game, in almost any other way than the in-game QUIT option results in it starting in windowed mode, it also appears that ALT+ENTER doesn't always work when the game is in the process of loading so you press ALT+ENTER and nothing happens, press it again and still nothing happens BUT, the game hags a few times during the loading screens so just try pressing it once and WAIT. It DOES change to full screen

I always exit game from in-game quit button and always in full screen... :(

About ALT+ENTER, i cant use it when game starts in windowed mode, i cant even use mouse to move window.I wait for game to get into menu and than i try again but nothing happens..I always need to go to game options, change refresh rate to something and than game go to full screen.

Share this post


Link to post
Share on other sites
Boyan said:

The problem is not only the full screen but the fact that the game runs with refresh rate less than 60Hz and it lags.

yeah exactly this !! it does nbot start in window mode but in full screen with black bars around screen with lower fps (around 25 counted with fraps)  :\

Share this post


Link to post
Share on other sites
After it started to happening in every single game i had, game running in windowed mode or black borders around picture with lower frame rates, i needed to look more seriously into the problem.So i do a research about this on internet and to be honest its a very common issue.But the solution is simple.
Just open your graphic settings and go to resolution panel, also, open windows screen resolution menu.In windows, change one refresh rate settings and click apply, than change in graphic settings to same refresh rate and click apply.Continue the process with all refresh rate settings , both in windows and graphic settings panel.After that set your native refresh rate settings , click apply and restart PC.Now u will run any game in full screen without any problems.

Share this post


Link to post
Share on other sites
Welcome!
I seem to have found a solution to fix fullscreen! F1 2014 crack, go with the mouse and right mouse click and ESULTS attributes and then run at a government maximized! It helped me at least !! And Let Everyone's play f1 2014 fullscreen...

Share this post


Link to post
Share on other sites
I know this is an old thread, but i still see people struggling with this "bug" everywhere.
I am not 100% sure but i think i found a solution.
In your Nvidia control panel go to Set resolution, you will probably see that the resolution is set to 1920x1080 Native, now set resolution to 1920x1080 without the Native and set refresh rate to 60 and hit Apply.

Start Dirt Rally and it should now start in full screen, if not you go into settings and set desired screen options.

This fixed it for me after months of swearing :smile: Now the game plays full screen and with super smooth frame rates.

I am using SLI 760 Ti's, Intel core i7


Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×