Jump to content Jump to content

[F1 2016 PC] Multiplayer Stutters, Teleporting, Ghosting and Rubber Banding? Help?


TuriousHD

Recommended Posts

So I recently purchased this for myself and one friend, for the most part it's enjoyable but there are so many problems with connectivity and performance, in a lot of circumstances, penalties and collisions are being caused by frame stuttering, cars appearing out of no where and generally unacceptable game-play. 

  • Frame stuttering happens perhaps, three times a lap, occurring what appears randomly at certain points and lasting anywhere between a split second up to two seconds. As you can imagine this causes crashes and penalties to occur frequently and rather unfairly. 
  • Cars ghosting and teleporting is the real problem however as it makes racing cleanly and fairly almost impossible. The AI will be two car lengths ahead, then magically appear behind you. You can be in the lead then all of a sudden have one right in front of you breaking, only to hit it and obtain a penalty. With other player drivers this is also true, but additionally you'll see them hoping all over the take, pinging around despite having solid connections. 

Information about myself and my friend:

I'm running a GTX 960, AMD FX-8350 Black, 16GB RAM and all settings on High obtaining about 55-65fps average. My friend has a similar setup obtaining the same results. Lowering graphic options does not reduce the stuttering. It's not a graphical issue. 

We're both based in the United Kingdom, both on ethernet, my ping is 12 and his is 22. No jitter, DL speeds are about 50mb/s + and uploads around 5mb/s+. Connections in the lobby display as 3 or 4 green bars. 

Any help resolving these issues would be massively appreciated. 

Thanks!


Link to post
Share on other sites
These are pretty similar problems for the past 7 versions, usually dependent on the overall connection, feels sometimes like one or two red bars in a lobby ruin it for the rest as everything de-synchs etc.

I've not done much online as I did experience some fairly small rubber banding, which was weird as it was with another racer with a connection similar to mine (wired, Xbox, port forwarded >40mbps down >8mbps up <30m/S ping), who I wouldn't usually have these problems with.

Hopefully some optimizations coming.
Link to post
Share on other sites
That really sucks to here this has been a recurring issue, although I do know it's not our connections. We're able to play and host literally any other game without issue, and the bars in-game are usually maxed but still the ghosting and teleporting continues to an unplayable level. 

I really do hope some optimizations resolve this, but since you mentioned this has been present for seven titles, I honestly think hoping for change on the matter is pointless. Although this does mean that I know not to purchase future games from the company if they don't resolve or even respond to these blatant issues. 
Link to post
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...