Jump to content
  • 0
Sign in to follow this  

GRID Autosport (with all DLC) don't start on Linux / SteamOS

Question

Hi,

I bought GRID Autosport - Pack ALL DLC via Steam on GNU/Linux (Fedora 24) but after clicking the START button, GRID logo is displayed in fullscreen mode but nothing else happens...
Please help CODEMASTERS !!

Share this post


Link to post
Share on other sites

1 answer to this question

Recommended Posts

  • 0

The same issue under Ubuntu 17.10 and 18.04, including 100% clean install to an empty drive.

GRID Autosport hangs FOREVER at the starting logo splash screen.

nVidia driver version does not matter: tested e.g. with 384.47, 390.48 and several versions in between.

The game does NOT support Linux.

My relevant hardware:

  • 4K monitor: Dell P2415Q connected via DisplayPort.
  • Graphics card: GeForce GTX 650 Ti BOOST (2 GB) (Gigabyte GV-N65TBOC-2GD).
  • Mainboard: Gigabyte GA-Z68X-UD4-B3.
  • CPU: Intel Core i7-3770T (4 cores).
  • RAM: 16 GB (4×4 GB, Hynix).

Share this post


Link to post
Share on other sites
  • 0

Looks like there is a trivial bug in GRID Autosport with comma as separator between integer and fractional number parts, and a workaround is changing regional format in Ubuntu settings to one that uses dot as separator instead:

Region & Language → Formats → United States

Thanks to madbad82 from the Steam community for the tip.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×