Jump to content
  • 0
Sign in to follow this  

Dirt 4 - T500RS Disconnection Issue on PS4

Question

Seems like myself and several others are experiencing random disconnections while driving a stage in Dirt 4 on the PS4, and after it's done spinning and it reconnects it doesn't calibrate properly (the gas or brake become either weak or don't not work at all, and/or the steering wheel range shrinks), so then I need to turn the steering wheel power off and on again to be able to re-calibrate it. This issue doesn't happen in Dirt Rally and other racing games.

Share this post


Link to post
Share on other sites

Recommended Posts

  • 0
RT87 said:
Seems like myself and several others are experiencing random disconnections while driving a stage in Dirt 4 on the PS4, and after it's done spinning and it reconnects it doesn't calibrate properly (the gas or brake become either weak or don't not work at all, and/or the steering wheel range shrinks), so then I need to turn the steering wheel power off and on again to be able to re-calibrate it. This issue doesn't happen in Dirt Rally and other racing games.
I replied in the PS4 issues thread, but that is for Rally.

The T500RS is not on our supported peripheral list.  If you disable the force feedback the wheel will not disconnect.

Share this post


Link to post
Share on other sites
  • 0
This recent forum post (and other  forums as well like TeamVVV) said that it was  supported, assuming they retrieved the info from Codemasters: http://www.racedepartment.com/threads/dirt-4-supported-peripherals-revealed.135939/ . Misleading. Guess I didn't expect a very late change to supported peripherals. Hope T500RS gets supported again. Too big an investment and too good a wheel to be worth replacing right now.

Share this post


Link to post
Share on other sites
  • 0
I'm raging. Bought this on the strength of it being a supported device on that very list,  and coupled with the fact it works fine in Dirt Rally, the last thing I expected was a problem with it.

That said, if there was an issue how was it missed in all the extensive testing and not a single review has pointed it out as an issue.. It disconnected three times in a single race for me. 

Binned. Back in the box. If you ask me it was sold under false pretences.

Poor show, codemasters. 

Share this post


Link to post
Share on other sites
  • 0
gadgit7 said:
Where do you set that rotation to be only 540 degrees?

540 degrees, you press the mode button, at the same time you press the direction button to the left, the red light will flash 4 times , you do it again, and it flashes 3 times= 540 degrees

Share this post


Link to post
Share on other sites
  • 0
CMMcBabe said:
RT87 said:
Seems like myself and several others are experiencing random disconnections while driving a stage in Dirt 4 on the PS4, and after it's done spinning and it reconnects it doesn't calibrate properly (the gas or brake become either weak or don't not work at all, and/or the steering wheel range shrinks), so then I need to turn the steering wheel power off and on again to be able to re-calibrate it. This issue doesn't happen in Dirt Rally and other racing games.
I replied in the PS4 issues thread, but that is for Rally.

The T500RS is not on our supported peripheral list.  If you disable the force feedback the wheel will not disconnect.
I read it was to be supported! That's why I pre ordered it, now it's useless. I even bought the PS4 over Xbox one specifically to run dirt 4 with my T500rs set up. It definitely stated it would be supported guys.

Share this post


Link to post
Share on other sites
  • 0
@Munken77

Mmm I tried this - got two stages in - just enough to give me confidence lol - and then 'a controller is disconnected' again...

Looks like it needs a patch - which knowing the process, will take ages....  

It's really taken the shine off the new title for me.

Share this post


Link to post
Share on other sites
  • 0
Finde es sehr schade das mein Lenkrad sich immer trennt, in dirt rally alles super.hoffe Codemasters behebt dies per Patch!!!

Share this post


Link to post
Share on other sites
  • 0
540 didnt work for me. Its so funny. You can even change the different t500 model versions in the settings. And a CM guy said the t500 is not supported? And pre launch it was also confirmed on many sources that t500 will be supported. So what is plase going on here?

Share this post


Link to post
Share on other sites
  • 0
its because T500rs is only supported on PC 

i had to buy it for both platforms after finding it out the hardway:(

Share this post


Link to post
Share on other sites
  • 0
I guess Sony want more ¥¥¥  for license. After having trouble with logitech... G29 sux so much. This game is dead on day 1 for many wheel owners -_-"  Just fail. 

Share this post


Link to post
Share on other sites
  • 0
CMMcBabe said:
RT87 said:
Seems like myself and several others are experiencing random disconnections while driving a stage in Dirt 4 on the PS4, and after it's done spinning and it reconnects it doesn't calibrate properly (the gas or brake become either weak or don't not work at all, and/or the steering wheel range shrinks), so then I need to turn the steering wheel power off and on again to be able to re-calibrate it. This issue doesn't happen in Dirt Rally and other racing games.
I replied in the PS4 issues thread, but that is for Rally.

The T500RS is not on our supported peripheral list.  If you disable the force feedback the wheel will not disconnect.

No that sollution does not work. Keeps having feedback and stil disconnects. We will not buy a new wheel for a 69 euro game. It is to good for me to replace. I almost had every codemaster race game from dtm 1 till now. Had every part of dirt. Always was a tru fan. But if this not wil be fixed it wil be my last one. Think that i am not the only one to make the desission to trow away dirt 4 if it not soon support our wheel.

Share this post


Link to post
Share on other sites
  • 0
If the Ps4 did not support the t500rs than i would understand it would be impossible to work. But it works wiht every other game. It worked with Dirt Rally. Isnt it possible to copie the setting out of dirt rally and past em in a update in dirt 4. Or are there compleet new file formats used? If not i do not see a problem to fix it. Just like you fixed the problems with the t300 in a super fast time. But still no reaction if it will be fixed with the t500

Share this post


Link to post
Share on other sites
  • 0
Try changing the force feedback settings to ffb on and the the 1st 2 settings to 99 then all the others to zero, it stopped my T500 disconnecting and is allowing me to play the game with decent ffb :smiley:

Share this post


Link to post
Share on other sites
  • 0
madwak said:
Try changing the force feedback settings to ffb on and the the 1st 2 settings to 99 then all the others to zero, it stopped my T500 disconnecting and is allowing me to play the game with decent ffb :smiley:

Thanks man. It works. I even lowerd the first 2 to 65 still keeps working. Onfortionatly we mis some ffb and the solution didnt come from codemasters.

Share this post


Link to post
Share on other sites
  • 0
CMMcBabe said:
RT87 said:
Seems like myself and several others are experiencing random disconnections while driving a stage in Dirt 4 on the PS4, and after it's done spinning and it reconnects it doesn't calibrate properly (the gas or brake become either weak or don't not work at all, and/or the steering wheel range shrinks), so then I need to turn the steering wheel power off and on again to be able to re-calibrate it. This issue doesn't happen in Dirt Rally and other racing games.
I replied in the PS4 issues thread, but that is for Rally.

The T500RS is not on our supported peripheral list.  If you disable the force feedback the wheel will not disconnect.
Not supported? But the game recognizes the wheel
and even name it. It doesn't make any sense!

Share this post


Link to post
Share on other sites
  • 0
CMMcBabe said:
RT87 said:
Seems like myself and several others are experiencing random disconnections while driving a stage in Dirt 4 on the PS4, and after it's done spinning and it reconnects it doesn't calibrate properly (the gas or brake become either weak or don't not work at all, and/or the steering wheel range shrinks), so then I need to turn the steering wheel power off and on again to be able to re-calibrate it. This issue doesn't happen in Dirt Rally and other racing games.
I replied in the PS4 issues thread, but that is for Rally.

The T500RS is not on our supported peripheral list.  If you disable the force feedback the wheel will not disconnect.
Not supported? But the game recognizes the wheel
and even name it. It doesn't make any sense!
was it not thrustmaster ho stated when the t300 came out that it uses almost the same firmware as the t500 only on 900 degrees. I now gonna try to set my settings on the pc on 900 degrees. Than calibrate it on ps4 dirt 4 on 900 degrees. maybe it will be fixed that way. Maybe it cant handle the 1080degrees.

Share this post


Link to post
Share on other sites
  • 0
I think they know what's causing it but just not saying? It's more likely to be some bad code in the programming because the wheel appears to disconnect and have a fit every time  a certain type of  ffb event occurs. 
'That's probably why they suggest turning the ffb off as a temp fix, shame they didn't realise that the ffb can be left on and you just need to turn everything off except self aligning torque and wheel friction :wink:

Share this post


Link to post
Share on other sites
  • 0
madwak said:
I think they know what's causing it but just not saying? It's more likely to be some bad code in the programming because the wheel appears to disconnect and have a fit every time  a certain type of  ffb event occurs. 
'That's probably why they suggest turning the ffb off as a temp fix, shame they didn't realise that the ffb can be left on and you just need to turn everything off except self aligning torque and wheel friction :wink:
Maybe youre right. Didnt think about that yet. But for now we stick wit youre earlier sollution. I find it a bad thing that codemasters still did not react.

Share this post


Link to post
Share on other sites
  • 0
in another post a guy said turn, soft lock to 0 and tyre slip or something to 0 rest you could have at 150. havent tried myself im playing pc version until it gets sortet out.

Share this post


Link to post
Share on other sites
  • 0
That was a Tip for T500 PS4 user.
I Test itand it works.
FFB to 150 with both SOFT LOCK AND TYPE FRICTION at 0
  --> T500 working fine  :) 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×