Jump to content

Archived

This topic is now archived and is closed to further replies.

Day One - DiRT 4 v1.02 - Found a bug? Post it here!

Recommended Posts

Can NOT map the clutch to L1

It need to be on L1 for me because I use the sticks for steering, gas and brake. And L2, R2 for gears. R1 is handbrake and L1 NEEDS to be clutch. It's a game breaker for me, please patch ASAP.

Share this post


Link to post
Share on other sites
Issue tonight while playing MP. I finished a 4 stage championship at the top, stage results show me at the top and I also finished every stage at the top but the overall event standings shows me at the bottom with 0 points, screens here: http://imgur.com/a/a0fEU

I went back to the menu screen from the results after taking the screenshots and the game crashed to desktop

Share this post


Link to post
Share on other sites
Im getting serious graphic stutter on xbox one in some stages. The usual trigger is entering a haevilly wooded area, particularly in Wales, or for example taking one of the tighter corners at a fair pace in the welsh woods. Idnt making the game un playable but is annoying

Share this post


Link to post
Share on other sites
tux1991 said:
Im getting serious graphic stutter on xbox one in some stages. The usual trigger is entering a haevilly wooded area, particularly in Wales, or for example taking one of the tighter corners at a fair pace in the welsh woods. Idnt making the game un playable but is annoying
I'm having the same issues. Hopefully CodeMasters fix this and don't forget about it like they did with F1 2016.

Share this post


Link to post
Share on other sites
I have Dirt4 for PC. Was doing the special Hyundai event, finished the first stage, and was on the menu to go to the next stage.

Went to answer a post in the Steam Chat system, via "Shift+Tab" combination, and when I came back to the game, I had been kicked from the event and put in DNF situation.

Can someone help solving it? Not good to have limitations in a Steam Game with the Steam tools available...

thanks

Julio Sousa


Share this post


Link to post
Share on other sites
I have a Soundblaster X7 and my game goes completely silent after playing for a minute or two.
Worse if I am running teamspeak and trying to play with my friends Teamspeak goes quiet as well.

If I turn my X7 off and on again it fixes the problem but only for like another 30 seconds or so and then it just cuts out again.

I have the latest video card and sound card drivers.

Share this post


Link to post
Share on other sites
neil3646 said:
The Xbox achievements for placing in the top 2 tiers on a daily event doesnt seem to be unlocking




hopefully they will patch this

Share this post


Link to post
Share on other sites
human1101 said:
oh i forgot to mention **** is a helicoper doing in spain stirring up dust in the middle of a tarmac road. what dust?
Didzis said:
Not a bug, just very annoying - in the branding suite the camera keeps spinning around. You can stop it by manually rotating the view a bit, but only for a few seconds. There should be a toggle for that or just simply don't start spinning the camera after it has been manually moved. 

Another thing with the branding suite and the sponsors specifically - In GRID games you had the option to choose couple of variants for each sponsor logo, usually a colored one and a white or black one to make them suit different backgrounds, would be great to have something like that here too
Uh.. there's still dust on a tarmac road. 

And as stated, you can change the looks of some decals. 

Share this post


Link to post
Share on other sites
Yea I found a huge bug. Your speedometer is insanely inaccurate. Your speed is 100% based on your tachometer and not how fast you are actually going. Right of the start of a stage, red line in first and says you are going 30~40, shift up into second gear and it says you are going 20ish. How can you make a racing game with a false speedometer?   
How can you not know how a speedometer works? Speed means how fast your wheels are spinning, unless you have a GPS based speed unit. Obviously dependant on speed sensor location. Which is irrelevant for the game. 

Share this post


Link to post
Share on other sites
On PC terrible frame pacing and performance issues, but only on some stages. In career mode, my FPS is usually around 50% worse than if I'm doing a freeplay event.




Share this post


Link to post
Share on other sites
I have a problem with my ECCI 7000 wheel, every time i start the game with it plugged in the game crashes,  was working fine on the original DIRT
With this crash report

<?xml version="1.0" encoding="UTF-8" ?>
<CrashRpt version="1404">
    <CrashGUID>7086f888-3a88-443e-a2d4-52f24f8a1e1c</CrashGUID>
    <AppName>DiRT 4</AppName>
    <AppVersion>0,1,120,908</AppVersion>
    <ImageName>C:\Program Files (x86)\Steam\steamapps\common\DiRT 4\dirt4.exe</ImageName>
    <OperatingSystem>Windows 10 Pro Build 10586</OperatingSystem>
    <OSIs64Bit>1</OSIs64Bit>
    <GeoLocation>en-us</GeoLocation>
    <SystemTimeUTC>2017-06-11T06:21:20Z</SystemTimeUTC>
    <ExceptionAddress>0x180004e61</ExceptionAddress>
    <ExceptionModule>C:\Windows\System32\ImmPID64.dll</ExceptionModule>
    <ExceptionModuleBase>0x180000000</ExceptionModuleBase>
    <ExceptionModuleVersion>3.0.2.0</ExceptionModuleVersion>
    <ExceptionType>0</ExceptionType>
    <ExceptionCode>0</ExceptionCode>
    <GUIResourceCount>48</GUIResourceCount>
    <OpenHandleCount>1576</OpenHandleCount>
    <MemoryUsageKbytes>480876</MemoryUsageKbytes>
    <CustomProps>
        <Prop name="career_description" value="" />
        <Prop name="career_type" value="" />
        <Prop name="device_id" value="0x67df" />
        <Prop name="game_mode_type" value="" />
        <Prop name="game_status" value="55" />
        <Prop name="graphics_driver_version" value="AMD" />
        <Prop name="location" value="Race" />
        <Prop name="node_path_id" value="0" />
        <Prop name="node_path_previous_id" value="0" />
        <Prop name="race_type" value="" />
        <Prop name="steam_id" value="76561198278390916" />
        <Prop name="track_lighting" value="" />
        <Prop name="track_name" value="" />
        <Prop name="track_route" value="" />
        <Prop name="track_weather" value="" />
        <Prop name="vehicle_id" value="ERROR" />
    </CustomProps>
    <FileList>
        <FileItem name="crashdump.dmp" description="Crash Minidump" />
        <FileItem name="crashrpt.xml" description="Crash Description XML" />
    </FileList>
</CrashRpt>

Share this post


Link to post
Share on other sites
And as stated, you can change the looks of some decals. 
Yeah, already tried that out. But my first point about the rotating view still stands

Share this post


Link to post
Share on other sites
I couldn't find a better place to post about in-game problems, bugs and improvement ideas without making a new thread so I hope this is acceptable to post in here. And yeah I play on ps4 with thrustmaster t300rs, t3pa non-pro pedals and the th8a shifter and the game's version is 1.03 if I remember correctly.

In-game problems/bugs whatever:
- The transmission type changes by itself from sequential to h-pattern w/ clutch and the other way around. I've mostly noticed this happening when going from playmode to another, for example going from career to online multiplayer or competitive events. This is weird considering that there shouldn't be a feature in the game yet that adjusts the transmission type according to the car. And it has happened when driving a r2 car in career and going into online multiplayer to drive the same r2 car again, the game changes the transmission/gearbox type from sequential to h-pattern w/ clutch by itself. 
- The game has crashed quite a few times. (sorry I can't remember the error codes, but I did send the report forward on ps4 if that helps) Once it crashed when I was playing pro tour, so the game shut down and I was returned to the PS4 main screen. After I had started the game again and went to the competitive menu, I got a notification saying that I got some sort of penalty for exiting mid-match and that I could end up banned if I keep doing it. I think it is weird/unfair to punish me for something I had absolutely no control over.
- A couple of times my car has been battered/broken at the start service of an event (again, happens mostly in online events) and I've not been able to fix the car at the start service so I had to drive the first few stages with a damaged/broken car.
- I feel like the pacenotes in Sweden are a bit too fast/optimistic compared to the other locations in rallying. Usually a corner that has a note of right 3 or left 3 is in my opinion a left 2 or right 2. But this might be down to personal preference as well. But a couple of my friends agreed with me that the notes there are somewhat optimistic/fast.
- The RX2 cars have a really heavy rear bias on the brakes (or that's how it feels like). The car loses the rear end under braking quite easily. There's no possibility to adjust the brake bias for that car so the RX2 car is somewhat undriveable at the moment. Of course if it's not adjustable in real-life either then I can understand it and then I'll just have to adjust my driving style when driving those.

Improvement ideas:
- It would be great to have some pacenotes even after the finish, since sometimes you're going really fast over a crest to finish the stage and after that there's like a right 2 corner or something and I have no possibility whatsoever to make the corner since I've been given zero warning about that. One of the stages that featured such finish was the 3rd stage of the Hyundai invitational. The problem is visible on this video. If it doesn't start at the correct spot, the incident can be found at 32 minutes and 8 seconds in the video. https://youtu.be/tDNcxkGFFbE?t=32m13s 
- The landrush spotter could say that on which side (left/right) the cars are on. I've had a few problems since I've been racing on a straight against a car and the spotter says that the car is on the inside. I find it tricky to define "inside" on a straight. Also I've had a few troubles with that on the left-right corner sequences, it's really hard to define inside/outside for those situations as well. In my opinion it would work better if the spotter would say you have a car on your left/right. 
- This is somewhat of wishful thinking, but it'd be nice to be able to modify different liveries for different cars, since some liveries work really well on some cars but look completely horrible on others. Also, that would be helpful, if we could at least select the racing number options different on each cars. I like to have orange numbers on the windows, but black number on white background on the car but it's somewhat worthless to go to the branding suite every time when I go from old cars to new cars and vice versa. Also the ability to choose a large door number (as shown here http://www.works-y3f.com/m_cars/5_wrc/IMP/w99/04.jpg ) or a small door number (as shown here http://www.hpiracing.com/assets/images/cache/17505_17505_02p_800_600.jpg ) would be a nice feature.  

These are my problems/suggestions/ideas considering the game at the moment, hope these help you guys at Codemasters. Thanks in advance, I know you guys are doing your best with DiRT4. 

Share this post


Link to post
Share on other sites
Some kind of bug with simulation handling model (I hope). Cannot lose (by mistake) my car's rear. This is also problem with RWD cars. Too easy to drive with all cars compared other "racing simulators".

Edit: Only way to lose car's rear is lock-braking (this is nice feature).

Share this post


Link to post
Share on other sites
Please make a patch to turn vibration off but still keep force feedback for steering wheel. Right now it seems its either vibration & ffb or nothing. I would like ffb but no vibration.

Share this post


Link to post
Share on other sites
Hi, theres a bug in german version in force feedback settings: 

http://imgur.com/OrAoFzs

There are 2 settings with "Reibung Reifen". In english it's "wheel friction" and "tyre friction". In the screenshot i added to compare the german settings from Dirt Rally.

Share this post


Link to post
Share on other sites
PS4
The trophy/achievement Up and up (Get promoted to a new Tier in Pro Tour) is glitched.
For some it unlocks when they get promoted from Division 3, Class 7 to Division 3, Class 6 but others have to rank up a second time and one person even had to rank up 4 times:
https://forum.psnprofiles.com/topic/48847-mandatory-trophy-discussion/?do=findComment&comment=1334094
https://forum.psnprofiles.com/topic/48847-mandatory-trophy-discussion/?do=findComment&comment=1334167
https://www.playstationtrophies.org/forum/dirt-4-a/310390-up-up-glitched.html?s=f304ead6f252a763497013b8c5a3e0b2

Share this post


Link to post
Share on other sites
Potential bug on xbox one: http://forums.codemasters.com/discussion/53063/pro-tour-points-calculation/p1?new=1

Also, achievements for the daily events are not unlocking.

Share this post


Link to post
Share on other sites
Digital Foundry just uploaded a video on Dirt 4. Backs up my claims of frame rate drops on the Xbox One. 

Here's the video: https://www.youtube.com/watch?v=OiqMYDjo34c

Share this post


Link to post
Share on other sites
In Pro Tour the split times do not add up to the result of stage time.
From split times I was 2 seconds slower, in stage time I was actually 10 seconds slower. 

Share this post


Link to post
Share on other sites
I found a fix for the problem in PS4... When the console is in 2160p game gets a massive downgrade like aliassing, shadows resolution lights effects and wet effects (if this is not a bug there should be an option to disable or enable 4k mode , I did this just by chance) the game in PS4 pro on 1080p resolution looks like a proper current gen game ...it's gorgeous...I don't know if this will work on Xbox slim... try it out... 

Share this post


Link to post
Share on other sites
Another game crash, was racing in Loheac with Supercars, was in the lead and into the 3rd corner where the FPS issue is, the game just froze completely and had to close the game

Share this post


Link to post
Share on other sites
So i did the weekly event, quit at the finish of the 4th stage, so far so good, the next day i went to do the rest of the event, all good, but at the finish when i went to see the breadboard it gave a time  of  51:30.104... did i dot penalized for something? or is it a bug?
the stage times are in the image below..

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×