Jump to content Jump to content

Dirt 4 PC Stutter 60fps.


Hinjima

Recommended Posts

Hello, having some issues with Dirt 4 on the PC... Locking the game to 60fps / Vsync creates stutter down to 55fps and back to 60fps every 2-5 seconds.  Unlocking the framerate makes no difference, still getting the stutter.  Tried everything in the nvidia control panel and in game, I will leave a link to a video I made so you can see the issue yourself. 
https://www.youtube.com/watch?v=43cLjkRAJOk
I ran Dirt Rally at 4k 60fps ultra with no issues, so its not a hardware problem. Going to link to a few steam threads where people experience the same issue, running the game in admin mode made no difference to me.
http://steamcommunity.com/app/421020/discussions/0/1354868867714787641/
http://steamcommunity.com/app/421020/discussions/0/1354868867715761929/
If anyone are experiencing the same problems, please post below! Thank you.

I am afraid to test anymore because I am soon exceeding my 2h playtime for a refund on steam, any feedback from developers would be absolutely fantastic!
Hinjima. 980 ti overclocked - i5 6600k @ 4.6ghz - 16gb 3200mhz ram and running on an SSD.



Link to post
Share on other sites
:UPDATE
Reinstalled the game and launched it right after it was reinstalled, and it ran at steady 60 with some microstutters, almost smooth enough!  After exiting the game and opening it up the drop to 55fps was back, restarting the PC or verifying the integrity of game files on steam did not help.
I am not interested in reinstalling the game each time I want to fire it up. But maybe it makes Codemasters job abit easier finding the bug.
Link to post
Share on other sites
versedi said:
Could you try if the same thing happens when you unplug your wheel?

One user reported stutters on similar graphic card but only when his wheel is plugged in. Just to narrow down the options. 
Started the game with only mouse and keyboard 10 times and it did not stutter, plugged in the wheel / usb shifter and it started to stutter, unplugged the wheel and shifter and it was smooth again!
It is definitely causing the issue I am having on my end.
Hinjima.


Link to post
Share on other sites
@KickUp @Hatward @ChristinaMc

We're onto something.



@Hinjima any USB hub that the wheel is connected through? is the port 2.0 or 3.0? 

/e: similar case I've mentioned earlier: http://forums.codemasters.com/discussion/53004/dirt-4-using-a-g27-introduces-hitches-every-3-seconds#latest
Link to post
Share on other sites
The wheel and shifter are connected to the front USB 2.0 of the case, I also tried the front 3.0 and it made no difference. I tried plugging the wheel and shifter into the 2.0 USB and USB 3.1 at the back ( directly into motherboard ) with same results, it still stutters every 2-5 seconds.
I use a TH8A separate USB shifter,  let me know if you want me to try with only the wheel or even only the shifter plugged in to see if that makes a difference.
Hinjima.
Link to post
Share on other sites
@Jepsertti prepare a dxdiag and msinfo32 for support it will help them narrow down if it's related to hardware/software, not sure what the email address was.

@ChristinaMc is it: custservice@codemasters.com ? 
Link to post
Share on other sites
versedi said:
@Jepsertti prepare a dxdiag and msinfo32 for support it will help them narrow down if it's related to hardware/software, not sure what the email address was.

@ChristinaMc is it: custservice@codemasters.com ? 
Just saved DxDiag and msinfo32 so currently waiting for a confirmation on what email address I should send them to :)
Link to post
Share on other sites
versedi said:
@Jepsertti prepare a dxdiag and msinfo32 for support it will help them narrow down if it's related to hardware/software, not sure what the email address was.

@ChristinaMc is it: custservice@codemasters.com ? 
Let me know as well, I'll send my dxdiag and msinfo32. 
Link to post
Share on other sites
Same hitching/fps drops here, but ONLY when connecting my G27 wheel.
Here's a video playing with gamepad until I connect the wheel at 00:50, then it's hitching constantly.

https://youtu.be/5eWNeoYphjg

It does the same even in the start screen:

https://youtu.be/dIqPSnrjP3I
  1. You can see stable 60 fps
  2. At 00:20 I connect the G27 and fps start to drop regularly to 50's
  3. At 00:50 I disconnect the wheel's USB cable, but the hitches/fps drops remain until I exit the game.
Link to post
Share on other sites
versedi said:
Ale1983 said:
Hi, I have the same problem, stutter also in the menu O-O. Windows10 / 64 980ti i7-4770 16Gb ram G-SYNC monitor, stutter also at 100fps!
Does it also occur when you unplug your wheel/controller? 
Yes, with new and old Nvidia driver (382.53 current)
Link to post
Share on other sites
I managed to track down the problem to my keyboard: https://www.gskill.com/en/product/ripjaws-km780-mx--cherry-mx-blue
Tried connecting to other USB ports and disconnecting the extra USB port on the keyboard but the result is the same: If  both the wheel and the keyboard are connected Dirt4 hitches.

So yeah, just having a keyboard in your system can make Dirt4 unplayable. So much for Code"masters".

Do I have to send MsInfo and DxDiag to some email address?
Link to post
Share on other sites
Thats some good findings there Jesped! Maybe I can play some Dirt 4 later if I plug out  my mouse and keyboard then, been putting of playing it since release due to the stutters sadly.  I will report my findings as well.
Link to post
Share on other sites
I am having the same issues stutters like crazy to the point I cant play its driving me mad I am going back to play Dirt rally
Please fix I am using a g29 wheel with usb controller as a hand brake
Link to post
Share on other sites
Phire said:
I am having the same issues stutters like crazy to the point I cant play its driving me mad I am going back to play Dirt rally
Please fix I am using a g29 wheel with usb controller as a hand brake
Did you tried if the issue persists when you disconnect the wheel and USB controller (handbrake)?
Link to post
Share on other sites
CMMcBabe said:
Could you send the files to dirtgame@codemasters.com please?  I can grab them from there.
Sent you Dxdiag and MSinfo32.  I tried to play Dirt 4 again with wheel / shifter but not keyboard and mouse plugged in and it was a stuttery mess, I tried with only keyboard and mouse and it was silky smooth.  Let me know if you need anything else.
Hinjima.
Link to post
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...