Jump to content
  • 0
Sign in to follow this  

Dirt 4 PC Stutter 60fps.

Question

Hello, having some issues with Dirt 4 on the PC... Locking the game to 60fps / Vsync creates stutter down to 55fps and back to 60fps every 2-5 seconds.  Unlocking the framerate makes no difference, still getting the stutter.  Tried everything in the nvidia control panel and in game, I will leave a link to a video I made so you can see the issue yourself. 
https://www.youtube.com/watch?v=43cLjkRAJOk
I ran Dirt Rally at 4k 60fps ultra with no issues, so its not a hardware problem. Going to link to a few steam threads where people experience the same issue, running the game in admin mode made no difference to me.
http://steamcommunity.com/app/421020/discussions/0/1354868867714787641/
http://steamcommunity.com/app/421020/discussions/0/1354868867715761929/
If anyone are experiencing the same problems, please post below! Thank you.

I am afraid to test anymore because I am soon exceeding my 2h playtime for a refund on steam, any feedback from developers would be absolutely fantastic!
Hinjima. 980 ti overclocked - i5 6600k @ 4.6ghz - 16gb 3200mhz ram and running on an SSD.



Share this post


Link to post
Share on other sites

Recommended Posts

  • 0
Hey!  I updated to latest version of windows 10.  I bought an xbox one S controller because the latest version of windows didn't work with the Playstation 4 controller due to a netframe error on a program called SCPtoolkit that emulates all kinds of controllers making windows thinking its a 360 gamepad. I uninnstalled SCPtoolkit and all its files as I didnt need it anymore. I was going to play some other racing game but I though I'd give dirt 4 another go so  I plugged only my wheel in ( t500rs ) to see if dirt 4 would run smooth without the TH8A shifter plugged in and it did, so I plugged the TH8A shifter in and the game is still silky smooth 60fps 4k.  I couldn't believe it so I restarted my computer while the wheel / shifter was plugged in and fired up Dirt 4 and its running buttery smooth without any hitches.   I am unsure if its the program SCPtoolkit that caused the stuttering as I had that program installed while running Assetto corsa / dirt rally at 60fps smooth or if updating to latest version of windows or both.
I still have my old dxdiag / msinfo files on my computer, do you want me to create 2 new ones as dirt 4 is running fine now and send you the old and new ones for you to compare?  I will still do some more testing to see if dirt 4 is 'fixed'
Hinjima.

Share this post


Link to post
Share on other sites
  • 0
Rea9er said:
Hi all just a quick FYI, been playing for 6hrs with a xbox controller and its been worker flawlessly. I decided to plug my G25 wheel in and instantly was having the same issue as all have mentioned (please note that I installed the logitech software at the same time.) Anyway, after reading this discussion I unplugged the G25 but the problem was still there with just my Xbox controller plugged in and visa-versa. I then uninstalled the Logitech Game Profiler program and it was instantly fixed (with just the xbox controller plugged in). Shame as I would rather use the wheel than a game pad. I will be checking back for updates on possible workarounds or upcoming dev patch releases to fix this issue. Thanks for this informative discussion, it has saved what little hair i have left lol
That's interesting. About a month ago, I was having fps issues with Dirt Rally in VR and also when not in VR when I hadn't had the issue before, I use a G25. I couldn't for the life of me fix it however it works fine in D4 and don't have this issue with the Logitech Profiler installed.

Have you tried installing the latest version of the profiler to see if it works now?
Yeah I was using the latest version (lgs510_x64.exe). Will play around with it another day to see if I can get the wheel working without the profiler but from memory it is needed for the wheel to work.

Share this post


Link to post
Share on other sites
  • 0
Rea9er said:
Rea9er said:
Hi all just a quick FYI, been playing for 6hrs with a xbox controller and its been worker flawlessly. I decided to plug my G25 wheel in and instantly was having the same issue as all have mentioned (please note that I installed the logitech software at the same time.) Anyway, after reading this discussion I unplugged the G25 but the problem was still there with just my Xbox controller plugged in and visa-versa. I then uninstalled the Logitech Game Profiler program and it was instantly fixed (with just the xbox controller plugged in). Shame as I would rather use the wheel than a game pad. I will be checking back for updates on possible workarounds or upcoming dev patch releases to fix this issue. Thanks for this informative discussion, it has saved what little hair i have left lol
That's interesting. About a month ago, I was having fps issues with Dirt Rally in VR and also when not in VR when I hadn't had the issue before, I use a G25. I couldn't for the life of me fix it however it works fine in D4 and don't have this issue with the Logitech Profiler installed.

Have you tried installing the latest version of the profiler to see if it works now?
Yeah I was using the latest version (lgs510_x64.exe). Will play around with it another day to see if I can get the wheel working without the profiler but from memory it is needed for the wheel to work.
Try to install the Logitech Profiler again.

Some people had issues and reinstall helped them.

https://download01.logi.com/web/ftp/pub/techsupport/joystick/lgs510.exe



Share this post


Link to post
Share on other sites
  • 0
So...   is the issue really fixed after uninstalling/reinstalling Logitech Profiler or with the new 1.04 patch?

Share this post


Link to post
Share on other sites
  • 0
I had the same problem with F1 2016 ( If my wheel or controller was plugged in, the fps dropped from 60 to 10 in under a minute). I tried to reinstall the game several times through Steam without success.
In the end it worked using the Revo Uninstaller (just Google it) which is also deleting all registry entries of a software. Search for Dirt 4 in this case and click on uninstall. After the "uninstallation" by steam click on the option completely to the right (translated from the German version it's called "intensive" but probably named different in the English version).
Be careful you don't delete something that has nothing in commen with your game (In my case a Uplay Launcher reg entry) and there you go.

Share this post


Link to post
Share on other sites
  • 0
So, I reinstalled Windows 7 on my pc and tried the game again, buttery smooth with my usb wheel plugged in.  So I assume the problem is some combination of Windows 10 and usb.  I think I'll try installing an older version of Windows 10 and see what happens.

Share this post


Link to post
Share on other sites
  • 0
Whiffle said:
So, I reinstalled Windows 7 on my pc and tried the game again, buttery smooth with my usb wheel plugged in.  So I assume the problem is some combination of Windows 10 and usb.  I think I'll try installing an older version of Windows 10 and see what happens.
I have had this problem since F1 2015 and only with Windows 10. With Windows 7 all codemaster games since F1 2015 works fine with wheel, so definetly something to do with W10 & usb, maybe usb drivers is the problem

Share this post


Link to post
Share on other sites
  • 0
Whiffle said:
So, I reinstalled Windows 7 on my pc and tried the game again, buttery smooth with my usb wheel plugged in.  So I assume the problem is some combination of Windows 10 and usb.  I think I'll try installing an older version of Windows 10 and see what happens.
I also did a fresh install of Windows 10 64-bit Pro Creators version and now it is buttery smooth too.

Share this post


Link to post
Share on other sites
  • 0
Ok, I seem to have fixed mine.  What I did was install the AMD chipset drivers from AMD's site which gave me a newer usb filter driver than the drivers from my motherboard site.  Game runs great now, even on ultra!  Yay!

Share this post


Link to post
Share on other sites
  • 0
Guys! For those who own the Logitech wheel G27 or G29 and you have the stutter problem, I've got a solution!

Keep your keyboard and mouse intact. No need to unplug them. Keep your Windows 10, it works fine. You just need to do this: -
1. Download a copy of the Logitech Profiler (Get the latest copy if possible),
2. In the Profiler, add a new profile for the Dirt 4 or Dirt Rally (if you happened to have stutters in DR too),
3. Your profile should point to your current installed D4/DR location (mine is D:\Program Files (x86)\Steam\steamapps\common\DiRT 4\dirt4.exe).

Each time before you launch your Dirt 4 or Dirt Rally, make sure you select the profile in the Logitech Profiler and that's it - no more stutters!



Share this post


Link to post
Share on other sites
  • 0
You will also have to enable FFB and set wheel rotation and "allow the game to adjust settings". If you don't,...it will use the global profile defaults.

Share this post


Link to post
Share on other sites
  • 0
ilborga70 said:
https://steamcommunity.com/sharedfiles/filedetails/?id=974993781
This is a USB device and steering wheel issue in this thread.  If you would take half a second to read you'd have realized this.

Anyways, I had taken a break from D4, maybe I'll get my wheel out and see if the logitech profiler fixes it.

Share this post


Link to post
Share on other sites
  • 0
none of the suggested fixes have worked for me with my G27. why have codemasters not fixed this issue yet? I am at the point of wanting my money back and never buying another Codemasters title again. 

Share this post


Link to post
Share on other sites
  • 0
Same problems with a T150. Of course the FPS are stable, the frametimes are the problem. I'm dirt 4, in dirt rallye it was a problem too! Exactly the same! It is very poor and unless the account binding I asked Amazon for a refund.
It happens on a clean Windows 10 and 8.1 installation!

Share this post


Link to post
Share on other sites
  • 0
i cant' belive, we are in codemaster forum and noone is helping us. I have the same proble when i plug in g27! i dont' want to playwith pad damn! 

Share this post


Link to post
Share on other sites
  • 0
I agree, this is very disappointing and tbh i will be very unlikely to buy another codemasters title (a new V8 supercars perhaps) Codemasters, you need to step up your game, we aren't even talking about an outdated peripheral, the G27 is still current and should be supported and reinstalling Windows 7 should not be a solution nor should a clean install of any OS. You need to patch this to get it working right, I paid good bloody money for this title (as I have for all Dirt titles, yes even Showdown! I expect more for my money.

Share this post


Link to post
Share on other sites
  • 0
Hello guys,

I'm also another guy with a "strong" PC (Asus Z370 / i7 8700K / 16 GB DDR4 / 980 GTX TI) with the same kind of stutter you are describing when my Logitech G29 is connected. I have found an kind of ugly work around that works on my machine that I would like to share. I tracked down the problem to the Logitech G29 driver called "Logitech G29 Driving Force Racing Wheel USB" under "Human Interface Devices" in the Device Manager. When I disable that driver in the device manager and starts Dirt 4 I have no stutter.

My hack to get Dirt 4 running without stutter is as follows:

Preparation steps:
1. Download the Vista driver for the Logitech Gaming Software (Currently the file is called "LGS_8.81.15_x64_Logitech.exe")
2. With 7-zip, open the exe as an archive and extract the folliwing directory to disk: "LGS_8.81.15_x64_Logitech.exe\$_32_\1-LGS-x64\Setup.exe\$_5_\Drivers\LGSHidFilter\"

When that driver is downloaded plus the ordinary Windows 10 version of Logitech Gaming Software is installed follow theese steps:

1. Start Dirt 4 with your Wheel connected in Windowed mode (or Alt+Enter to drop out to windowed mode)
2. Go to Device Manager and install the Vista driver for the device called "Logitech G29 Driving Force Racing Wheel USB
". (Update driver, Browse my computer for drivers, Have Disk, select the inf-file from the Vista driver folder) .
3. The wheel will start to recalibrate/spin and Dirt 4 will tell you that your input devices is changed. Just click Continue two times.
4. In Device Manager, click update driver on the same device and reinstall your Windows 10 driver again. On my machine it's located in "C:\Program Files\Logitech Gaming Software\Drivers\LGSHidFilter".
5. Return to Dirt 4 and click Continue two more times.

Now, on my machine the stutter is gone. I have to repeat this every time I start the game, but at least it works. Just Alt+Enter to pop into fullscreen to enjoy.

If your´e like me, lazy, you could script the above steps with a Microsoft tool called DevCon. To get the tool look here: https://superuser.com/questions/1002950/quick-method-to-install-devcon-exe

Then you could issue theese commands to install the old and then the new driver by script and as an administrator. If you make two folders with the old (Vista) driver and the new windows 10 driver in sub folders under the devcon tool, just run the commands below:

devcon updateni LGJoyHid_8.81\LgJoyHid.inf "USB\VID_046D&PID_C24F&REV_8900&MI_00"
devcon updateni LGJoyHid_8.96\LgJoyHid.inf "USB\VID_046D&PID_C24F&REV_8900&MI_00"

I even setup a couple of Dirt 4 specific macros in my G810 to run theese commands even easier.

Hope this helps someone that wants to play the fun game with a Logitech Racing Wheel and without the annoying stutter.

Br Ice

Share this post


Link to post
Share on other sites
  • 0
Same issue for me. G27 makes my game stutter down to 15FPS on a GTX1050m on ultra low and 1366x860 resolution.
Dirt has the same problem, except this time around I got one word up my sleeve. And that's REFUND. 
Thank you Steam and shame on you Codemasters

Share this post


Link to post
Share on other sites
  • 0
Hi all , I know this is an old post , I have just come back to Dirt 4 after after many months away , the game has been running extremely well since the last updates using my xbox controller however I have just tried using my Logitech G29 wheel and I keep getting the graphics stuttering problem , I have tried to do various fixes mentioned on here and steam but I cant seem to fix the issue , Any help advice please !!!  , ps I can run Dirt rally and any other racing game I play with no problems

Share this post


Link to post
Share on other sites
  • 0
Hey guys, thought I would share  something of GREAT importance to all of you!
I´ve been plagued with stutters and failure to get propper FPS everytime I would plug my G27 in. I tried most of the things above to no avail. I thought I was suffering from the "USB bottleneck effect" in wich you can´t have ANY USB connected to your PC without causing lag, but, as it turns out, it had nothing to do with it.
Just this week I bought a 1ms. gaming  monitor so I could, you know, be faster, and now I can run Dirt  at ULTRA with no lag or stutter whatsoever.
Worth mentioning; I play a lot of games that DO NOT have any kind of issue on my previous TV (a regular 32'' LG), namely AMS, PCars 1 and 2, WRC, Asseto and so on... I have no idea why this game fails to perform on a regular TV using the same HDMI connection as on the monitor, Same Cable BTW too. But, for me, that was it. Thought I´d share this with you and maybe draw some attention to this issue hopefully helping you out.  
https://www.amazon.com/Acer-KG271-bmiix-FREESYNC-Technology/dp/B072HGR5HB
This is the monitor I got, it does have  AMD FREE SYNC, whatever that is.
Cheers

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×