Jump to content
Sign in to follow this  

Dirt Rally Very Low FPS

Recommended Posts

I recently got the humble bundle that included dirt rally, expecting it to run fine on my gtx 980 at 1080p, but i get 12.50 fps on the benchmark and everything is laggy. I turned off all graphics settings and turned down the resolution, but still I get 12.50 fps. I use an xbox controller to play. Thank you. 

Share this post


Link to post
Share on other sites
it should run fine on the gtx 980 at 1080p, you should manage to run it at ultra.  What CPU do you have? How much ram?
Try reinstalling dirt rally, and reinstalling nvidia graphics driver.   if its stuck at 12.50fps on high and low it seems like its something causing the locked fps.

Share this post


Link to post
Share on other sites
Thanks for replying, I have 32gb of ram, and an overclocked i7 4790k. I tried reinstalling and that did not work. I tried running the game with all usb ports unplugged and that also did not work. I originally had old drivers and ran the game with the same results, so I updated to the latest drivers from Nvidia and the same thing happens. I will try to reinstall the drivers, thank you for the help. 

Share this post


Link to post
Share on other sites
vish929 said:
I tried reinstalling the drivers and that did not work. 

more than enough ram and processor power. Do you get 12.5 fps on the main menu screen? or is it only while driving?
under Graphics - Video mode - what is the refresh rate set to?

Share this post


Link to post
Share on other sites
vish929 said:
I get low fps on startup, at menu, and when trying to do anything in the game

That is the weirdest... Could you try running the game in windowed mode / windowed borderless rather than fullscreen and see if that makes a difference?

Share this post


Link to post
Share on other sites
Yea i actually tried to alt tab  out of the game in windowed mode so that I could check my cpu and gpu usage, and it still ran slow, and the gpu and the cpu were working fine

Share this post


Link to post
Share on other sites
vish929 said:
Yea i actually tried to alt tab  out of the game in windowed mode so that I could check my cpu and gpu usage, and it still ran slow, and the gpu and the cpu were working fine

I dont know man, this is a strange issue..  does not seem hardware related at all.  Tried Nvidia Geforce experience and optimizing Dirt rally and launch it from there?  Just pitching idea's here, worth a shot.

Share this post


Link to post
Share on other sites
Thanks for the help I really appreciate it. Nvidia experience doesnt seem to fix the issue either. 

Share this post


Link to post
Share on other sites
vish929 said:
Thanks for the help I really appreciate it. Nvidia experience doesnt seem to fix the issue either. 

Pleasure. but I am out of ideas my friend. Lets hope someone else stumbles upon this thread with some better knowledge:).  To me it does sound like a program is interfering with the game or it could be some settings in the Nvidia control panel - Dirt Rally.  Tried running the game as Administrator?

Share this post


Link to post
Share on other sites
Do not use Geforce experience,...just chose,let's say low preset and see what the fps move to. Make sure to reset to the native resolution of your display too.

Share this post


Link to post
Share on other sites
I started the game without the controller plugged in and I have checked off run as administrator in the compatibility tab, but still the game is unplayable. Any other suggestions? 

Share this post


Link to post
Share on other sites
I tried deleting the exe then verifying the cache but that didn't work I have an old computer and dirt rally is managing to run on it, and that is on Windows 7. So, maybe it has something to do with the fact that my new computer is on Windows 10?

Share this post


Link to post
Share on other sites
Try updatting your Windows 10.                        

What performance mode are you running?

Share this post


Link to post
Share on other sites
I'll see if updating works, and if you mean the power setting for Windows, I set it to the highest performance in the settings and not on power saving or balanced. I really don't care about the apps in windows 10 so I might rollback to Windows 7 and see if that works. Thanks.

Share this post


Link to post
Share on other sites
Ah i tried everything and the compatibility for all the windows types and it still wont work properly. Considering all my other games work just fine, hopefully this will get better? Really sad that I cant play this game because I was looking forward to it very much. 

Share this post


Link to post
Share on other sites
In the game disable mouse menu. Disconnect all other usb devices and hubs. Do not use Nvidia experience to optimize the game, run low video graphics preset.

Share this post


Link to post
Share on other sites
Mouse ui disabled, disconnected everything, still lag in menu. Disconnected everything but keyboard the second time, benchmark 12.50 average, low, and max fps, on ultra low quality at 1080p. 

Share this post


Link to post
Share on other sites
Hey, i just checked gpu usage and cpu usage again using msi afterburner. Everything is at the base clock, but according to afterburner, the gpu usage is 1% and the Cpu usage is at 2%. Any way to force dirt rally to use these? 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×