Jump to content

Archived

This topic is now archived and is closed to further replies.

Correct operation of the soft lock option

Recommended Posts

Hi all,
Been playing with the FFB settings, as well as car tuning pretty heavily lately, trying to find a happy medium with handling. While doing this, I have come across something a little weird with the soft lock option. It appears (for me) that it isn't actually working as it did in Dirt Rally. I have the same problem with lack of feeling when steering in Automobilista, and in fact the steering option that sets the DOR per car wasn't working properly either. Setting the correct DOR in my CSW wheel made it WAY better. My question, since I can't see the wheels in a rally car, doesn't the soft lock option LOCK the wheel turning any greater than the actual DOR for any given car. So, if I set my wheel at 900, which is it's maximum, and select soft lock on in game, then each car should lock the steering wheel at the correct DOR for that car, true? Or does the steering wheel  just keep turning but the front wheels are at maximum lock at, say, 540 if it's a modern car. Every single car I test it with, old, new, displays the driver arms and steering wheel turning a full 900 degrees, no matter the setting that I use for soft lock. I have since turned soft lock OFF and set DOR in my wheel, and to me it feels MUCH better. 

Anyone else have something similar happen to them? I have tried searching for info on it and no one seems to be complaining about it. In an open wheel car, you can see where the front wheels lock, but in D4, it's hard to actually see what's happening with the front wheels. Also, from memory, and I will test it now, Dirt Rally actually locked the steering wheel to the DOR for each car with soft lock on. It doesn't seem to happen in D4. 

Share this post


Link to post
Share on other sites
Can anyone at least notify that it works for THEM? Trying to nail if it's a Fanatec thing or Dirt related.

Share this post


Link to post
Share on other sites
Thanks for doing that. Try the arms and wheel displayed in cockpit view. You don't even need to drive, just turn the wheel after the count down. If your wheel is locking at 540 with soft lock ON, and no other settings are set in your wheel (degree of rotation) then soft lock seems like it should be working as intended for you. Just curious, what operating system are you running, and if it's Windows 10, have you got the latest 'Creators Update'? I have been having trouble with a few sims (rFactor 2, Automobilista, both D4 and DR) and I have not noticed this being an issue until recently. Someone on another forum mentioned that there seemed to be a conflict with W10 CU, Fanatec drivers and certain sims. although there is no warning of this, it just doesn't work as it should. 

I have tried turning soft lock to 150, still was able to turn my wheel the full 900 degrees, and the in car wheel was in sync. Change to soft lock off, and set correct DOR for given car in my wheel, and the title feels miles better to drive. I think half my problem with the handling might have been down to me having 900 DOR for ALL CARS. In other words, barely any wheel response. 

Share this post


Link to post
Share on other sites
I will try another port. Not sure what will happen as it does work in other titles, and it did work previously. Thanks for the input though. Nice to know it still does work at all. 

Share this post


Link to post
Share on other sites

×