Jump to content
Sign in to follow this  

Thrustmaster F430 pedals have huge deadzone in F1 2013

Recommended Posts

I recently got my hands on a Thrustmaster Ferrari F430 racing wheel. The pedals respond quickly in the calibration program, and I tried a few races in Race 07, all fine no deadzone. In F1 2013, both the accelarator and brake have aprox 33% deadzone, although in the game options it is set at 0 and the override device set as a Racing Wheel.
Also when working with the accerator and brake deadzone and saturation in game options, there seems to be no effect when driving. Steering options do work fine thought. I'm running the game in Windows 8.1 Pro, and the wheel is officially supported by Codemasters in their racing wheel list.
Did anybody experience the same thing, and could it be solved somehow?

Share this post


Link to post
Share on other sites
I have the same problem with my thrustmaster ferrari red edition pc-ps3 wheel on the pc windows 7.
In the calibration program in windows it works good (using the official thrustmaster driver for this wheel).
In F1 2013 I have throttle deadzone set to 0.
However in game, I can put in the throttle like 20/30% before anything happens.
With my old thrustmaster enzo ferrari pc/ps2 with same thrustmaster drivers I don't have this problem.

Sorry I son't have a solution, but maybe good to know that you aren't the only one

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×