Jump to content
  • 0
Sign in to follow this  

F1 2017 - Graphic issues

Question

• CPU: Intel Core i5-6600K
• GPU: NVIDIA GeForce GTX 1060 6GB VRAM
• RAM: 16GB GSkill RipJaws V DDR4-2400

Hello Community,

I am 
experiencing some annoying issues with the graphics settings in this game. I maxed up everything to ultra, tried to fix something in the NVidia Control Panel, but nothing really works. The game just looks bad, there is almost no anti aliasing, and the allaround look is just not acceptable. I am wondering myself how the graphics can look this bad with my CPU ect.

I am hoping for your help. 

Share this post


Link to post
Share on other sites

13 answers to this question

Recommended Posts

  • 0
I've the same sort of problem. Seems like there's less anti aliasing. I noticed that there are only 3 setting just to TAA but i fon"t know why. I use a Nvidia GeForce GTX 970.

Share this post


Link to post
Share on other sites
  • 0
I have the same issue. I can almost see the pixels on my screen. it's really annoying and i am expecting more that this... this isn't worth the money.

Share this post


Link to post
Share on other sites
  • 0
Yep, same problem. Games looks marginally better if I disable in-game Aliasing, and use Nvidias own one (and some other settings I cant remember currently)

Share this post


Link to post
Share on other sites
  • 0
I had the problem but i just ramped up everything on nvidia control panel and ingame and it made a huge difference. I know u have tried it but try reinstall your graphic drivers with the new f1 2017 nvidia grapich driver!

Share this post


Link to post
Share on other sites
  • 0
i've downgraded the nvidia driver to 385.xx and the game fitted better! but the unfocused and no AA bug continue...
Show a ingame screenshot so we can see what u mean!

Share this post


Link to post
Share on other sites
  • 0
Degrus said:
i've downgraded the nvidia driver to 385.xx and the game fitted better! but the unfocused and no AA bug continue...
Show a ingame screenshot so we can see what u mean!
The thing is, when you take screenshot, BINGO, everithing shows PERFECT!!! But when you play the game, you'll see the blurry image.

There's a example:



And after a temporary fix


Look where is written f1 2017. Thats happen at all images! So, the deal is that the game and the nvidia driver EMULATE another resolution to run the game, and doesn't show the native monitor resolution. 

SO to run properly, i have to set MAX settings ate geforce experience, then i should reduce it at the game, restart, and that's get fit! I just have to reduce it because i have only 4gb of ram.


So there's a thing, that was unecesseraly at f1 2016, why the DAMN FUCKMASTERS complicated it at all??

I hope that them can fix it, like it was on f1 2016.

By the way, do you have whatsapp to talk about it?


Share this post


Link to post
Share on other sites
  • 0
Exactly, even though I maxed up everything, a tree looks like a tree from Minecraft, the reflections on the cars are so blrury and you can see pixels there aswell.

Such a shame, the game is really good, but the graphics are stealing all the racing atmosphere.

Share this post


Link to post
Share on other sites
  • 0
Seems to be an issue.

I have just built my new PC,
i7 7700
32gb DDR4
GTX 1070 8GB etc

It is blurry. Even the opening credits. I checked F1 2010, 2012, 2013, 2016 all sharp as a tack. In game it looks like I am wearing the wrong glasses.
I have tried everything, thinking it was my system, but all other driving games like rFactor 2 and even NASCAR Racing 2003 are tack sharp.
Codemasters have made an error here and I hope it is fixed up in a patch as other than that, is is great to drive.

Share this post


Link to post
Share on other sites
  • 0
Any solution here?
F1 2016 was nice and great to drive. F1 2017 has just an "unsharp" effect that it makes not really sense to drive... I tried to change a lot in the settings but it's more or less getting worse or stay the same.
Any ideas?
i-7 6500U with 16 GB Ram and Intel HD Graphics 520

Share this post


Link to post
Share on other sites
  • 0
Have you guys checked to see if your game is blocked in your anti-virus program?  I had an issue where the settings were not being saved, contacted Tech Support and they asked me to send a DX Diag lol.  Then told me it could be my monitor another ROFL moment!  

I checked my Anti-Virus and it showed 2017.exe was blocked alot.  I clicked allow and voila it is running in prime settings now!  4K with everything maxed.

Share this post


Link to post
Share on other sites
  • 0
Any kind of a solution?
On xbox game looks perfect but on my pc with gtx 970 it does not. I tried all the forementioned fixes it did not work
It shows a lot of fps in the test mode but overall picture not that good. Cars are blurry graphic not sharp.
Btw F1 2016 runs pretty nice.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×