Jump to content
  • 0
Sign in to follow this  

Grid autosport wont run/launch

Question

i purchased this game 2 days ago through steam, i have a amd 6core 3.2ghz, 8gb memory, gtx 570 video card windows 7 64bit, updated all my drivers/windows up dates, i every time i try to start/run the game, i get a steam box that pops up saying game preparing to launch, and then i get the grid autosport icon flash up, the 2 will go back and fort flashing between each other, but the game never starts/launch's , i have tried the directx false to true,uninstalled steam, the game several times, disabled anti virus software,disabled fire wall, still nothing, i want a refund at this point !!!!!!

Share this post


Link to post
Share on other sites

3 answers to this question

Recommended Posts

  • 0
well after some communication from the support team , the solution that helped me was rolling back the integrated intel's 4600 gpu driver. (i  play on laptop with 2 gpus) ran safe mode then istalled the latest driver and it runs

Share this post


Link to post
Share on other sites
  • 0
steam code d erreur 53 impossible de finalisé l instalation car les serveurs steam sont surchargés .

quoi faire?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×