Jump to content
Want to report an issue? Have a bug to report? Please look here first!!!! Read more... ×

Archived

This topic is now archived and is closed to further replies.

F1 2017 (PC) Microstuttering at High Refresh Rate Potential Workaround

Recommended Posts

I posted this morning in another thread and I think a few others did too, that this game again suffers from microstuttering at **high refresh rate** just like F1 2016 still does. My relevant system specs are 7700K, GTX 1080 Ti, 1440p G-sync monitor @ 144 Hz. Latest Nvidia driver installed. Also deleted game data and re-installed. I did a fresh Windows 10 install last week. Every other game except F1 2016 and 2017 works just fine with G-sync and high refresh rate. It is the game(s), not my PC. 

After messing around for hours tonight with settings I finally eliminated the microstutter. It may well be a G-sync issue, but I also experienced microstutter in ULMB mode at 120 Hz. I adjusted the game settings in the NV control panel to "fixed refresh" (my monitor is set at 144 Hz in display properties) and "use 3D application setting" for v-sync. In-game I've set the refresh rate to 99 and enabled v-sync. It works. Drove several laps around 3 different tracks, dry and wet, with FPS locked at 100 b/c of v-sync and no microstutter. Notably, setting the refresh rate in game to anything higher than 99 Hz causes microstutter to return for me. If I re-enable G-sync and use a 99 Hz refresh rate in game the microstutter comes back. Disabling G-sync isn't ideal obviously, but if you can stay at 100 FPS minimum w/ regular v-sync on, it doesn't really matter. 

TLDR, for some reason this game (like 2016 before it) has issues at over 100 Hz refresh rate, based on my experience. If others with Nvidia cards and 120+ Hz monitors (and who can sustain 100+ fps in this game) can test this out and comment it would be great, maybe Codemasters can fix this.

Share this post


Link to post
Share on other sites
I hope it can be fixed for those playing on sub 100fps and 60Hz displays too.
There is some substance to what you are saying. I didn't get the issues with 2016 at first but I upgraded my GPU from a 770 to a 970 thinking it would fix it but it got worse (obviously lifted my framerates over 100fps consistently).
You have to turn off V-Sync due to the input lag.
For some reason the 2017 beta was pretty smooth on my PC but it the released game was as nasty as hell online last night. I had set the Graphics Options to Medium because the framerate was dipping quite low at times on High. The driver I am using is the one I ran the beta on, I haven't updated to the F1 2017 game ready one yet.

Share this post


Link to post
Share on other sites
jlp0209 said:
I posted this morning in another thread and I think a few others did too, that this game again suffers from microstuttering at **high refresh rate** just like F1 2016 still does. My relevant system specs are 7700K, GTX 1080 Ti, 1440p G-sync monitor @ 144 Hz. Latest Nvidia driver installed. Also deleted game data and re-installed. I did a fresh Windows 10 install last week. Every other game except F1 2016 and 2017 works just fine with G-sync and high refresh rate. It is the game(s), not my PC. 

After messing around for hours tonight with settings I finally eliminated the microstutter. It may well be a G-sync issue, but I also experienced microstutter in ULMB mode at 120 Hz. I adjusted the game settings in the NV control panel to "fixed refresh" (my monitor is set at 144 Hz in display properties) and "use 3D application setting" for v-sync. In-game I've set the refresh rate to 99 and enabled v-sync. It works. Drove several laps around 3 different tracks, dry and wet, with FPS locked at 100 b/c of v-sync and no microstutter. Notably, setting the refresh rate in game to anything higher than 99 Hz causes microstutter to return for me. If I re-enable G-sync and use a 99 Hz refresh rate in game the microstutter comes back. Disabling G-sync isn't ideal obviously, but if you can stay at 100 FPS minimum w/ regular v-sync on, it doesn't really matter. 

TLDR, for some reason this game (like 2016 before it) has issues at over 100 Hz refresh rate, based on my experience. If others with Nvidia cards and 120+ Hz monitors (and who can sustain 100+ fps in this game) can test this out and comment it would be great, maybe Codemasters can fix this.
Hi,

I have exactly the same setup as you and the same issue with F1 2017, a few microstutters from time to time (like 3 or 4 per lap for instance).
I tweaked the Nvidia CP a bit and it seems that MFAA was the culprit for me. I disabled it and I'm fine for now.

Share this post


Link to post
Share on other sites
jlp0209 said:
I posted this morning in another thread and I think a few others did too, that this game again suffers from microstuttering at **high refresh rate** just like F1 2016 still does. My relevant system specs are 7700K, GTX 1080 Ti, 1440p G-sync monitor @ 144 Hz. Latest Nvidia driver installed. Also deleted game data and re-installed. I did a fresh Windows 10 install last week. Every other game except F1 2016 and 2017 works just fine with G-sync and high refresh rate. It is the game(s), not my PC. 

After messing around for hours tonight with settings I finally eliminated the microstutter. It may well be a G-sync issue, but I also experienced microstutter in ULMB mode at 120 Hz. I adjusted the game settings in the NV control panel to "fixed refresh" (my monitor is set at 144 Hz in display properties) and "use 3D application setting" for v-sync. In-game I've set the refresh rate to 99 and enabled v-sync. It works. Drove several laps around 3 different tracks, dry and wet, with FPS locked at 100 b/c of v-sync and no microstutter. Notably, setting the refresh rate in game to anything higher than 99 Hz causes microstutter to return for me. If I re-enable G-sync and use a 99 Hz refresh rate in game the microstutter comes back. Disabling G-sync isn't ideal obviously, but if you can stay at 100 FPS minimum w/ regular v-sync on, it doesn't really matter. 

TLDR, for some reason this game (like 2016 before it) has issues at over 100 Hz refresh rate, based on my experience. If others with Nvidia cards and 120+ Hz monitors (and who can sustain 100+ fps in this game) can test this out and comment it would be great, maybe Codemasters can fix this.
Hi,

I have exactly the same setup as you and the same issue with F1 2017, a few microstutters from time to time (like 3 or 4 per lap for instance).
I tweaked the Nvidia CP a bit and it seems that MFAA was the culprit for me. I disabled it and I'm fine for now.
I've had that disabled as well by default the whole time and still got the stuttering. Glad your setup is working!

Share this post


Link to post
Share on other sites
jlp0209 said:
jlp0209 said:
I posted this morning in another thread and I think a few others did too, that this game again suffers from microstuttering at **high refresh rate** just like F1 2016 still does. My relevant system specs are 7700K, GTX 1080 Ti, 1440p G-sync monitor @ 144 Hz. Latest Nvidia driver installed. Also deleted game data and re-installed. I did a fresh Windows 10 install last week. Every other game except F1 2016 and 2017 works just fine with G-sync and high refresh rate. It is the game(s), not my PC. 

After messing around for hours tonight with settings I finally eliminated the microstutter. It may well be a G-sync issue, but I also experienced microstutter in ULMB mode at 120 Hz. I adjusted the game settings in the NV control panel to "fixed refresh" (my monitor is set at 144 Hz in display properties) and "use 3D application setting" for v-sync. In-game I've set the refresh rate to 99 and enabled v-sync. It works. Drove several laps around 3 different tracks, dry and wet, with FPS locked at 100 b/c of v-sync and no microstutter. Notably, setting the refresh rate in game to anything higher than 99 Hz causes microstutter to return for me. If I re-enable G-sync and use a 99 Hz refresh rate in game the microstutter comes back. Disabling G-sync isn't ideal obviously, but if you can stay at 100 FPS minimum w/ regular v-sync on, it doesn't really matter. 

TLDR, for some reason this game (like 2016 before it) has issues at over 100 Hz refresh rate, based on my experience. If others with Nvidia cards and 120+ Hz monitors (and who can sustain 100+ fps in this game) can test this out and comment it would be great, maybe Codemasters can fix this.
Hi,

I have exactly the same setup as you and the same issue with F1 2017, a few microstutters from time to time (like 3 or 4 per lap for instance).
I tweaked the Nvidia CP a bit and it seems that MFAA was the culprit for me. I disabled it and I'm fine for now.
I've had that disabled as well by default the whole time and still got the stuttering. Glad your setup is working!
Still, it's weird that you got stuttering with G Sync only for F1 2016 and 2017... I used to have a bit of stuttering in some games with it, but forcing v sync on along with g sync in nvdidia's control panel (which nvidia recommends), disabling in-game v sync, and forcing max pre rendered frames to "1" in the nvidia CP eliminated stuttering.

Share this post


Link to post
Share on other sites
jlp0209 said:
jlp0209 said:
I posted this morning in another thread and I think a few others did too, that this game again suffers from microstuttering at **high refresh rate** just like F1 2016 still does. My relevant system specs are 7700K, GTX 1080 Ti, 1440p G-sync monitor @ 144 Hz. Latest Nvidia driver installed. Also deleted game data and re-installed. I did a fresh Windows 10 install last week. Every other game except F1 2016 and 2017 works just fine with G-sync and high refresh rate. It is the game(s), not my PC. 

After messing around for hours tonight with settings I finally eliminated the microstutter. It may well be a G-sync issue, but I also experienced microstutter in ULMB mode at 120 Hz. I adjusted the game settings in the NV control panel to "fixed refresh" (my monitor is set at 144 Hz in display properties) and "use 3D application setting" for v-sync. In-game I've set the refresh rate to 99 and enabled v-sync. It works. Drove several laps around 3 different tracks, dry and wet, with FPS locked at 100 b/c of v-sync and no microstutter. Notably, setting the refresh rate in game to anything higher than 99 Hz causes microstutter to return for me. If I re-enable G-sync and use a 99 Hz refresh rate in game the microstutter comes back. Disabling G-sync isn't ideal obviously, but if you can stay at 100 FPS minimum w/ regular v-sync on, it doesn't really matter. 

TLDR, for some reason this game (like 2016 before it) has issues at over 100 Hz refresh rate, based on my experience. If others with Nvidia cards and 120+ Hz monitors (and who can sustain 100+ fps in this game) can test this out and comment it would be great, maybe Codemasters can fix this.
Hi,

I have exactly the same setup as you and the same issue with F1 2017, a few microstutters from time to time (like 3 or 4 per lap for instance).
I tweaked the Nvidia CP a bit and it seems that MFAA was the culprit for me. I disabled it and I'm fine for now.
I've had that disabled as well by default the whole time and still got the stuttering. Glad your setup is working!
Still, it's weird that you got stuttering with G Sync only for F1 2016 and 2017... I used to have a bit of stuttering in some games with it, but forcing v sync on along with g sync in nvdidia's control panel (which nvidia recommends), disabling in-game v sync, and forcing max pre rendered frames to "1" in the nvidia CP eliminated stuttering.
These settings cause massive stuttering for me. Really strange, I agree.

Share this post


Link to post
Share on other sites
Hi,

I'm having these same micro stuttering issues as well. I have a geforce 1080ti and a 100hz 3440x1440 monitor.

I have disabled gsync and enabled vsync. I have tried vsync on auto and set it to 1 too. I've lowered overall settings from ultra high to medium. I've tried many things but nothing seems to help.

If anyone has any other ideas to try I would appreciate it.

Thanks

Share this post


Link to post
Share on other sites
As an update I've tried my wheel on another PC which has a geforce 980ti and a 144hz 2560x1440 monitor.  I left vsync off and gsync on and  I am not experiencing any stuttering.

This makes me think the stuttering is maybe linked to the 1080ti or ultra wide res of 3440x1440.

Share this post


Link to post
Share on other sites
I've got the same problem with a 1070. It started to happen in F1 2016 when I bought a 144 Hz Monitor.
Problem solved like OP with a Frame Limiter of 99,5 FPS...

Share this post


Link to post
Share on other sites
I have the same issue on 144Hz screen.

Specs:
Screen: ASUS VG278HE
CPU: Intel i5 7600K
RAM: 2X8GB 2666MHz GSkill RipJaws DDR4
GPU: Gigabyte Geforce 1070 G1

Share this post


Link to post
Share on other sites
jlp0209 said:
I posted this morning in another thread and I think a few others did too, that this game again suffers from microstuttering at **high refresh rate** just like F1 2016 still does. My relevant system specs are 7700K, GTX 1080 Ti, 1440p G-sync monitor @ 144 Hz. Latest Nvidia driver installed. Also deleted game data and re-installed. I did a fresh Windows 10 install last week. Every other game except F1 2016 and 2017 works just fine with G-sync and high refresh rate. It is the game(s), not my PC. 

After messing around for hours tonight with settings I finally eliminated the microstutter. It may well be a G-sync issue, but I also experienced microstutter in ULMB mode at 120 Hz. I adjusted the game settings in the NV control panel to "fixed refresh" (my monitor is set at 144 Hz in display properties) and "use 3D application setting" for v-sync. In-game I've set the refresh rate to 99 and enabled v-sync. It works. Drove several laps around 3 different tracks, dry and wet, with FPS locked at 100 b/c of v-sync and no microstutter. Notably, setting the refresh rate in game to anything higher than 99 Hz causes microstutter to return for me. If I re-enable G-sync and use a 99 Hz refresh rate in game the microstutter comes back. Disabling G-sync isn't ideal obviously, but if you can stay at 100 FPS minimum w/ regular v-sync on, it doesn't really matter. 

TLDR, for some reason this game (like 2016 before it) has issues at over 100 Hz refresh rate, based on my experience. If others with Nvidia cards and 120+ Hz monitors (and who can sustain 100+ fps in this game) can test this out and comment it would be great, maybe Codemasters can fix this.
Hi,

I have exactly the same setup as you and the same issue with F1 2017, a few microstutters from time to time (like 3 or 4 per lap for instance).
I tweaked the Nvidia CP a bit and it seems that MFAA was the culprit for me. I disabled it and I'm fine for now.
Yeah, unfortunately I run with all AA off already, and it happens for me.

Share this post


Link to post
Share on other sites
Thanks for commenting, guys (and/or girls). I also made sure to update my motherboard to the latest chipset drivers, etc., and still got stuttering at 144Hz. My board is Asus Z270 M9 Hero. My 16gb of RAM passed overnight testing with Memtest. 

My latest experiment is to play with DSR enabled and game set to 3840 x 2160, graphics settings on high, MFAA enabled in NV CP, G-sync enabled, in-game v-sync off. I leave my refresh rate at the normal 144 Hz and no FPS limiter. Seems to really help with (noticeable) microstutter and removes all jaggies to boot, looks stunning compared to DSR off. I took a look at frame times, and the most I've seen is 14ms. Rather high. I don't think it is just the 1080 Ti, I also had issues with F1 2016 and the 1080. Before that, a 980 Ti worked just fine I remember. 

I am close to just getting another motherboard to compare but think that in the end this must be GPU driver related. And based on history, not optimistic it'll ever get addressed. 

Share this post


Link to post
Share on other sites
I'm totally stumped by this stuttering. It's not 144hz related as I am experiencing it on my 100hz monitor. It's very frustrating as for me it's making the game unplayable as the stuttering is frequent enough and severe enough to cause me to crash.

Share this post


Link to post
Share on other sites
My solution (I have a 1080ti & 144hz monitor as well) was to run this in windowed mode because my G-sync is only turned on for full screen applications.  On windowed mode with refresh/fps set to 144hz in game with its in-game vsync turned on, game is butter smooth at 144fps with no stutter whatsoever.  Benchmark shows the frame time variance between min and max is only 0.2ms.  On fullscreen this was up at 3.8ms.

My global 3d settings in the nvidia CP was for Vsync to use the 3d application setting.

Share this post


Link to post
Share on other sites
nessfe5 said:
My solution (I have a 1080ti & 144hz monitor as well) was to run this in windowed mode because my G-sync is only turned on for full screen applications.  On windowed mode with refresh/fps set to 144hz in game with its in-game vsync turned on, game is butter smooth at 144fps with no stutter whatsoever.  Benchmark shows the frame time variance between min and max is only 0.2ms.  On fullscreen this was up at 3.8ms.

My global 3d settings in the nvidia CP was for Vsync to use the 3d application setting.
What are your frame times? So you are playing in Windowed full screen mode, G-sync off, and in-game v-sync on, 143 Hz refresh rate, correct? 

Share this post


Link to post
Share on other sites
I also have a 1440p 165hz g sync monitor with a gtx 1080ti. I never drop below 100fps and I too an seeing horrible stutters when cornering. It is unplayable for me. I am glad it wasn't just me seeing it. Codemaster have to fix this.

Share this post


Link to post
Share on other sites
I can also confirm that disabling g sync and lowering the refresh rate to anything below 100hz while using regular vsync eliminates stutter.

Share this post


Link to post
Share on other sites
jlp0209 said:
nessfe5 said:
My solution (I have a 1080ti & 144hz monitor as well) was to run this in windowed mode because my G-sync is only turned on for full screen applications.  On windowed mode with refresh/fps set to 144hz in game with its in-game vsync turned on, game is butter smooth at 144fps with no stutter whatsoever.  Benchmark shows the frame time variance between min and max is only 0.2ms.  On fullscreen this was up at 3.8ms.

My global 3d settings in the nvidia CP was for Vsync to use the 3d application setting.
What are your frame times? So you are playing in Windowed full screen mode, G-sync off, and in-game v-sync on, 143 Hz refresh rate, correct? 
My frame times are 6.92ms.  My "lowest" frame time is 7.08ms and the average is 6.93.  You are correct that this is windowed full screen mode, my gsync is off (only on for true full screen), in game v-sync is on, and refresh at the 143hz.

Share this post


Link to post
Share on other sites
Sayjimwoo said:
I also have a 1440p 165hz g sync monitor with a gtx 1080ti. I never drop below 100fps and I too an seeing horrible stutters when cornering. It is unplayable for me. I am glad it wasn't just me seeing it. Codemaster have to fix this.
I have the same problem and am waiting for the patch

Share this post


Link to post
Share on other sites
Sayjimwoo said:
I can also confirm that disabling g sync and lowering the refresh rate to anything below 100hz while using regular vsync eliminates stutter.

interesting for me, disabling gsync and enabling vsync and leaving my monitor (which is a 100hz monitor) at 99hz doesn't solve the issue for me at all.  

Share this post


Link to post
Share on other sites
nessfe5 said:
jlp0209 said:
nessfe5 said:
My solution (I have a 1080ti & 144hz monitor as well) was to run this in windowed mode because my G-sync is only turned on for full screen applications.  On windowed mode with refresh/fps set to 144hz in game with its in-game vsync turned on, game is butter smooth at 144fps with no stutter whatsoever.  Benchmark shows the frame time variance between min and max is only 0.2ms.  On fullscreen this was up at 3.8ms.

My global 3d settings in the nvidia CP was for Vsync to use the 3d application setting.
What are your frame times? So you are playing in Windowed full screen mode, G-sync off, and in-game v-sync on, 143 Hz refresh rate, correct? 
My frame times are 6.92ms.  My "lowest" frame time is 7.08ms and the average is 6.93.  You are correct that this is windowed full screen mode, my gsync is off (only on for true full screen), in game v-sync is on, and refresh at the 143hz.
Thanks. You know, this probably is also a W10 Creators Update issue. I tried many nVidia drivers, the oldest being 378.92 and still had problems. I am going to wipe Windows again and this time install 1607 and see what happens. I am also curious if I can create a Hackintosh and play the Mac version of F1 2017. I know nVidia released a Pascal driver for Mac. 

This whole thing really makes me mad. F1 is maybe 80% of why I built a gaming PC in the first place some years ago. If I can't even play it without stutters, and on top of that, have to run old versions of Windows to play it, what's the point in even having a gaming PC. And Forza I know requires you to keep Windows up to date, so I may not be able to play it if I downgrade to build 1607. So sick of this BS, I just want to play my racing games. 

Share this post


Link to post
Share on other sites
jlp0209 said:

Thanks. You know, this probably is also a W10 Creators Update issue. I tried many nVidia drivers, the oldest being 378.92 and still had problems. I am going to wipe Windows again and this time install 1607 and see what happens. I am also curious if I can create a Hackintosh and play the Mac version of F1 2017. I know nVidia released a Pascal driver for Mac. 

This whole thing really makes me mad. F1 is maybe 80% of why I built a gaming PC in the first place some years ago. If I can't even play it without stutters, and on top of that, have to run old versions of Windows to play it, what's the point in even having a gaming PC. And Forza I know requires you to keep Windows up to date, so I may not be able to play it if I downgrade to build 1607. So sick of this BS, I just want to play my racing games. 
I have pretty much the same opinion. I like league racing and that's best on PC.

I'll be interested to see if this is a fix but I somehow doubt it. W10 AU is an abortion as well.

Share this post


Link to post
Share on other sites

×