Jump to content
Want to report an issue? Have a bug to report? Please look here first!!!! Read more... ×

Archived

This topic is now archived and is closed to further replies.

F1 2017 (PC) Microstuttering at High Refresh Rate Potential Workaround

Recommended Posts

jlp0209 said:

Thanks. You know, this probably is also a W10 Creators Update issue. I tried many nVidia drivers, the oldest being 378.92 and still had problems. I am going to wipe Windows again and this time install 1607 and see what happens. I am also curious if I can create a Hackintosh and play the Mac version of F1 2017. I know nVidia released a Pascal driver for Mac. 

This whole thing really makes me mad. F1 is maybe 80% of why I built a gaming PC in the first place some years ago. If I can't even play it without stutters, and on top of that, have to run old versions of Windows to play it, what's the point in even having a gaming PC. And Forza I know requires you to keep Windows up to date, so I may not be able to play it if I downgrade to build 1607. So sick of this BS, I just want to play my racing games. 
I have pretty much the same opinion. I like league racing and that's best on PC.

I'll be interested to see if this is a fix but I somehow doubt it. W10 AU is an abortion as well.
Before I downgrade to build 1607 I am going to try 'updating' to the latest Insider Preview build. I have read comments on nVidia forums from people who say it has improved performance in some games. I haven't even tried online racing with this game yet, lol, too busy tinkering with stupid settings still to get single player to work. But I see that online is also a giant mess so far. If I can't get things running smoothly and the PS4 version ends up working properly I may just go that route. I didn't buy a 1080 Ti and 165Hz monitor only to cap my games at 100 Hz with v-sync on and disable G-sync. 

Share this post


Link to post
Share on other sites
No luck with W10 preview build 16278, same exact microstuttering behavior. Rolled back to regular non-Insider release. I guess for now the only workaround is to turn off g-sync and use v-sync, while limiting refresh rate to 100 Hz. Pathetic. I don't have the energy to wipe Windows and test out the older 1607 AU build. And now I'm also getting the engineer audio glitching since the 1.4 patch. Just pathetic. 

Here's a thought Codemasters. Instead of rushing to release a shoddy game ridden with bugs every year, why not just release a team, livery, season, etc., mega update to F1 2016 for example, and squish all the bugs, and charge $30 U.S. for it. I'd rather have the same game with updates and solid play compared to the turd that is 2017 at the moment. 

Share this post


Link to post
Share on other sites
jlp0209 said:
No luck with W10 preview build 16278, same exact microstuttering behavior. Rolled back to regular non-Insider release. I guess for now the only workaround is to turn off g-sync and use v-sync, while limiting refresh rate to 100 Hz. Pathetic. I don't have the energy to wipe Windows and test out the older 1607 AU build. And now I'm also getting the engineer audio glitching since the 1.4 patch. Just pathetic. 

Here's a thought Codemasters. Instead of rushing to release a shoddy game ridden with bugs every year, why not just release a team, livery, season, etc., mega update to F1 2016 for example, and squish all the bugs, and charge $30 U.S. for it. I'd rather have the same game with updates and solid play compared to the turd that is 2017 at the moment. 
I think this is a good idea also. Rewriting a game with new bugs every year that never gets fixed is getting so old.

Share this post


Link to post
Share on other sites
jlp0209 said:
Thanks for commenting, guys (and/or girls). I also made sure to update my motherboard to the latest chipset drivers, etc., and still got stuttering at 144Hz. My board is Asus Z270 M9 Hero. My 16gb of RAM passed overnight testing with Memtest. 

My latest experiment is to play with DSR enabled and game set to 3840 x 2160, graphics settings on high, MFAA enabled in NV CP, G-sync enabled, in-game v-sync off. I leave my refresh rate at the normal 144 Hz and no FPS limiter. Seems to really help with (noticeable) microstutter and removes all jaggies to boot, looks stunning compared to DSR off. I took a look at frame times, and the most I've seen is 14ms. Rather high. I don't think it is just the 1080 Ti, I also had issues with F1 2016 and the 1080. Before that, a 980 Ti worked just fine I remember. 

I am close to just getting another motherboard to compare but think that in the end this must be GPU driver related. And based on history, not optimistic it'll ever get addressed. 
Good on you for trying to fix this issue on your own, but it's definitely software-related - I still bet on the game, as I have Assetto Corsa and rFactor 2 and never have these issues with either, and I use them even more.

Share this post


Link to post
Share on other sites
yeah nothing is working for me either.  I did try disabling the nvidia game overlay and it seemed to help a bit but it could be wishful thinking on my part.

probably worth someone else trying to see if they think it makes a difference.

Share this post


Link to post
Share on other sites
Ho3n3r said:
jlp0209 said:
Thanks for commenting, guys (and/or girls). I also made sure to update my motherboard to the latest chipset drivers, etc., and still got stuttering at 144Hz. My board is Asus Z270 M9 Hero. My 16gb of RAM passed overnight testing with Memtest. 

My latest experiment is to play with DSR enabled and game set to 3840 x 2160, graphics settings on high, MFAA enabled in NV CP, G-sync enabled, in-game v-sync off. I leave my refresh rate at the normal 144 Hz and no FPS limiter. Seems to really help with (noticeable) microstutter and removes all jaggies to boot, looks stunning compared to DSR off. I took a look at frame times, and the most I've seen is 14ms. Rather high. I don't think it is just the 1080 Ti, I also had issues with F1 2016 and the 1080. Before that, a 980 Ti worked just fine I remember. 

I am close to just getting another motherboard to compare but think that in the end this must be GPU driver related. And based on history, not optimistic it'll ever get addressed. 
Good on you for trying to fix this issue on your own, but it's definitely software-related - I still bet on the game, as I have Assetto Corsa and rFactor 2 and never have these issues with either, and I use them even more.
I swapped my motherboard and PSU just to see if I had a ghost in the machine, but it was exactly the same. All other games run way nicer than F1 2016/17.

Share this post


Link to post
Share on other sites
Have Codemasters even acknowledged the high refresh rate/g sync stutter bug? I have yet to see any confirmation from them about this.
I hope this isn't just left broken. I am using regular vsync under 100Hz and it is fine, but I am doing this temporary, and I want to go back to g sync @ 165hz.

Share this post


Link to post
Share on other sites
Ho3n3r said:
jlp0209 said:
Thanks for commenting, guys (and/or girls). I also made sure to update my motherboard to the latest chipset drivers, etc., and still got stuttering at 144Hz. My board is Asus Z270 M9 Hero. My 16gb of RAM passed overnight testing with Memtest. 

My latest experiment is to play with DSR enabled and game set to 3840 x 2160, graphics settings on high, MFAA enabled in NV CP, G-sync enabled, in-game v-sync off. I leave my refresh rate at the normal 144 Hz and no FPS limiter. Seems to really help with (noticeable) microstutter and removes all jaggies to boot, looks stunning compared to DSR off. I took a look at frame times, and the most I've seen is 14ms. Rather high. I don't think it is just the 1080 Ti, I also had issues with F1 2016 and the 1080. Before that, a 980 Ti worked just fine I remember. 

I am close to just getting another motherboard to compare but think that in the end this must be GPU driver related. And based on history, not optimistic it'll ever get addressed. 
Good on you for trying to fix this issue on your own, but it's definitely software-related - I still bet on the game, as I have Assetto Corsa and rFactor 2 and never have these issues with either, and I use them even more.
I swapped my motherboard and PSU just to see if I had a ghost in the machine, but it was exactly the same. All other games run way nicer than F1 2016/17.
Thanks for trying this. Yep, this is definitely solely a Codemasters / game issue. No one from CM has acknowledged this issue, appears they are addressing game breaking bugs first although this one is right up there for me. Not optimistic they will ever address this. 

Share this post


Link to post
Share on other sites
What sorted this for me is running GeForce experience and going with the optimal settings.

Share this post


Link to post
Share on other sites
i just got 1.5 hours stutter and freeze frame free,
only thing i did was disable nvidia overlay,
maybe i just got lucky and they will be apparent next time i play but worth a shot for others to test as well

Share this post


Link to post
Share on other sites
I have AMD so i dunno what to do in this case...I'm having a better experience with shadows and texture low. But on high settings i run 60fps with stuttering...

Share this post


Link to post
Share on other sites
HabUK said:
What sorted this for me is running GeForce experience and going with the optimal settings.



Using two 165hz acer predator monitors I had all the symptoms described above. Just goofing around in desperation I did the same thing, and it helped! Was going to spread this potential workaround, but you beat me to it :) I really hope it works for the rest of you guys as this is the best F1 game in a long, long time!

Share this post


Link to post
Share on other sites
HabUK said:
What sorted this for me is running GeForce experience and going with the optimal settings.



Using two 165hz acer predator monitors I had all the symptoms described above. Just goofing around in desperation I did the same thing, and it helped! Was going to spread this potential workaround, but you beat me to it :) I really hope it works for the rest of you guys as this is the best F1 game in a long, long time!
Tried this, still get microstuttering same as before. I generally avoid GF Experience like the plague but tried it for this game. Didn't work for me. 

Share this post


Link to post
Share on other sites
Guys, i ran some benchmarks and when texture is very low the game runs smooth...try and tell if  works for you. Hope it "fix"..

 CODEMASTERS fix the texture :)  Game is very good when smooth

Share this post


Link to post
Share on other sites
Guys, i ran some benchmarks and when texture is very low the game runs smooth...try and tell if  works for you. Hope it "fix"..

 CODEMASTERS fix the texture :)  Game is very good when smooth
Unless I read your posts incorrectly, you are running at 60 fps with a 60 Hz monitor. Not relevant for this thread, respectfully. My laptop with a gtx 1060 runs the game silky smooth at 60 fps. This game is severely broken at high refresh rates. I've tried every setting under the sun, GF experience, others have swapped motherboards. Windowed mode doesn't help me. I'm very sensitive to micro stuttering and it even occurs when locking refresh rate at 100 Hz and using v-sync on / g-sync off.

So far the best workaround for me has been to use DSR and run the game full screen at 3840 x 2160. G-sync on, in-game v-sync off. I leave my refresh rate at 144 Hz- setting it lower creates other minor issues / response time increase, etc. My monitor runs best at native 144 Hz. I set a frame limiter in EVGA Precision to 100 fps and tested all the way to 144 fps. For some reason it always locks the game at 72-75 fps but maintains the 144 Hz refresh rate. The micro stutter is completely gone finally. Raced 38 laps at Bahrain just now. Running with a 75 fps lock sucks, but it's miles better than 100 fps + microstutter. 

Share this post


Link to post
Share on other sites
jlp0209 said:
Guys, i ran some benchmarks and when texture is very low the game runs smooth...try and tell if  works for you. Hope it "fix"..

 CODEMASTERS fix the texture :)  Game is very good when smooth
Unless I read your posts incorrectly, you are running at 60 fps with a 60 Hz monitor. Not relevant for this thread, respectfully. My laptop with a gtx 1060 runs the game silky smooth at 60 fps. This game is severely broken at high refresh rates. I've tried every setting under the sun, GF experience, others have swapped motherboards. Windowed mode doesn't help me. I'm very sensitive to micro stuttering and it even occurs when locking refresh rate at 100 Hz and using v-sync on / g-sync off.

So far the best workaround for me has been to use DSR and run the game full screen at 3840 x 2160. G-sync on, in-game v-sync off. I leave my refresh rate at 144 Hz- setting it lower creates other minor issues / response time increase, etc. My monitor runs best at native 144 Hz. I set a frame limiter in EVGA Precision to 100 fps and tested all the way to 144 fps. For some reason it always locks the game at 72-75 fps but maintains the 144 Hz refresh rate. The micro stutter is completely gone finally. Raced 38 laps at Bahrain just now. Running with a 75 fps lock sucks, but it's miles better than 100 fps + microstutter. 
Hope you can find a permanent fix. I had to lock hz as people said here. I've tried everything and what worked was changing texture. Let's hope CM fix it once for all ;)

Share this post


Link to post
Share on other sites
jlp0209 said:
Guys, i ran some benchmarks and when texture is very low the game runs smooth...try and tell if  works for you. Hope it "fix"..

 CODEMASTERS fix the texture :)  Game is very good when smooth
Unless I read your posts incorrectly, you are running at 60 fps with a 60 Hz monitor. Not relevant for this thread, respectfully. My laptop with a gtx 1060 runs the game silky smooth at 60 fps. This game is severely broken at high refresh rates. I've tried every setting under the sun, GF experience, others have swapped motherboards. Windowed mode doesn't help me. I'm very sensitive to micro stuttering and it even occurs when locking refresh rate at 100 Hz and using v-sync on / g-sync off.

So far the best workaround for me has been to use DSR and run the game full screen at 3840 x 2160. G-sync on, in-game v-sync off. I leave my refresh rate at 144 Hz- setting it lower creates other minor issues / response time increase, etc. My monitor runs best at native 144 Hz. I set a frame limiter in EVGA Precision to 100 fps and tested all the way to 144 fps. For some reason it always locks the game at 72-75 fps but maintains the 144 Hz refresh rate. The micro stutter is completely gone finally. Raced 38 laps at Bahrain just now. Running with a 75 fps lock sucks, but it's miles better than 100 fps + microstutter. 
Hope you can find a permanent fix. I had to lock hz as people said here. I've tried everything and what worked was changing texture. Let's hope CM fix it once for all ;)
On Texture Streaming 'Ultra Low' my game crashed out on starting MP. Moved it to 'Low' and I didn't crash out.

Share this post


Link to post
Share on other sites
I get these micro stutters, screen is 60Hz, game runs 60+ fps, but it's still not smooth. Very annoying as can't focus on the driving. (Multiplayer) Haven't tested offline.

Share this post


Link to post
Share on other sites
jlp0209 said:
Guys, i ran some benchmarks and when texture is very low the game runs smooth...try and tell if  works for you. Hope it "fix"..

 CODEMASTERS fix the texture :)  Game is very good when smooth
Unless I read your posts incorrectly, you are running at 60 fps with a 60 Hz monitor. Not relevant for this thread, respectfully. My laptop with a gtx 1060 runs the game silky smooth at 60 fps. This game is severely broken at high refresh rates. I've tried every setting under the sun, GF experience, others have swapped motherboards. Windowed mode doesn't help me. I'm very sensitive to micro stuttering and it even occurs when locking refresh rate at 100 Hz and using v-sync on / g-sync off.

So far the best workaround for me has been to use DSR and run the game full screen at 3840 x 2160. G-sync on, in-game v-sync off. I leave my refresh rate at 144 Hz- setting it lower creates other minor issues / response time increase, etc. My monitor runs best at native 144 Hz. I set a frame limiter in EVGA Precision to 100 fps and tested all the way to 144 fps. For some reason it always locks the game at 72-75 fps but maintains the 144 Hz refresh rate. The micro stutter is completely gone finally. Raced 38 laps at Bahrain just now. Running with a 75 fps lock sucks, but it's miles better than 100 fps + microstutter. 
Hope you can find a permanent fix. I had to lock hz as people said here. I've tried everything and what worked was changing texture. Let's hope CM fix it once for all ;)
On Texture Streaming 'Ultra Low' my game crashed out on starting MP. Moved it to 'Low' and I didn't crash out.
On MP session tonight game very good not stuttering, same settings, hopefully the crashing was unrelated. Was not hosting though, that might prove different.

Also have no recording software yet as GFE not installed by Windows. Session wet so framerate mostly hovering just under 100fps on High preset (obviously with Texture Streaming set at 'Ultra Low' again).

Share this post


Link to post
Share on other sites
jlp0209 said:
Guys, i ran some benchmarks and when texture is very low the game runs smooth...try and tell if  works for you. Hope it "fix"..

 CODEMASTERS fix the texture :)  Game is very good when smooth
Unless I read your posts incorrectly, you are running at 60 fps with a 60 Hz monitor. Not relevant for this thread, respectfully. My laptop with a gtx 1060 runs the game silky smooth at 60 fps. This game is severely broken at high refresh rates. I've tried every setting under the sun, GF experience, others have swapped motherboards. Windowed mode doesn't help me. I'm very sensitive to micro stuttering and it even occurs when locking refresh rate at 100 Hz and using v-sync on / g-sync off.

So far the best workaround for me has been to use DSR and run the game full screen at 3840 x 2160. G-sync on, in-game v-sync off. I leave my refresh rate at 144 Hz- setting it lower creates other minor issues / response time increase, etc. My monitor runs best at native 144 Hz. I set a frame limiter in EVGA Precision to 100 fps and tested all the way to 144 fps. For some reason it always locks the game at 72-75 fps but maintains the 144 Hz refresh rate. The micro stutter is completely gone finally. Raced 38 laps at Bahrain just now. Running with a 75 fps lock sucks, but it's miles better than 100 fps + microstutter. 
Hope you can find a permanent fix. I had to lock hz as people said here. I've tried everything and what worked was changing texture. Let's hope CM fix it once for all ;)
On Texture Streaming 'Ultra Low' my game crashed out on starting MP. Moved it to 'Low' and I didn't crash out.
On MP session tonight game very good not stuttering, same settings, hopefully the crashing was unrelated. Was not hosting though, that might prove different.

Also have no recording software yet as GFE not installed by Windows. Session wet so framerate mostly hovering just under 100fps on High preset (obviously with Texture Streaming set at 'Ultra Low' again).
I dont have any issues with ultra low until now...let's hope CM fix it as soon as possible

Share this post


Link to post
Share on other sites

×