Jump to content
Want to report an issue? Have a bug to report? Please look here first!!!! Read more... ×

Archived

This topic is now archived and is closed to further replies.

F1 2017 (PC) Microstuttering at High Refresh Rate Potential Workaround

Recommended Posts

jlp0209 said:
Guys, i ran some benchmarks and when texture is very low the game runs smooth...try and tell if  works for you. Hope it "fix"..

 CODEMASTERS fix the texture :)  Game is very good when smooth
Unless I read your posts incorrectly, you are running at 60 fps with a 60 Hz monitor. Not relevant for this thread, respectfully. My laptop with a gtx 1060 runs the game silky smooth at 60 fps. This game is severely broken at high refresh rates. I've tried every setting under the sun, GF experience, others have swapped motherboards. Windowed mode doesn't help me. I'm very sensitive to micro stuttering and it even occurs when locking refresh rate at 100 Hz and using v-sync on / g-sync off.

So far the best workaround for me has been to use DSR and run the game full screen at 3840 x 2160. G-sync on, in-game v-sync off. I leave my refresh rate at 144 Hz- setting it lower creates other minor issues / response time increase, etc. My monitor runs best at native 144 Hz. I set a frame limiter in EVGA Precision to 100 fps and tested all the way to 144 fps. For some reason it always locks the game at 72-75 fps but maintains the 144 Hz refresh rate. The micro stutter is completely gone finally. Raced 38 laps at Bahrain just now. Running with a 75 fps lock sucks, but it's miles better than 100 fps + microstutter. 
Hope you can find a permanent fix. I had to lock hz as people said here. I've tried everything and what worked was changing texture. Let's hope CM fix it once for all ;)
On Texture Streaming 'Ultra Low' my game crashed out on starting MP. Moved it to 'Low' and I didn't crash out.
On MP session tonight game very good not stuttering, same settings, hopefully the crashing was unrelated. Was not hosting though, that might prove different.

Also have no recording software yet as GFE not installed by Windows. Session wet so framerate mostly hovering just under 100fps on High preset (obviously with Texture Streaming set at 'Ultra Low' again).
Hosting tonight so we will see what happens in a 100% race.

Have to say the odd glitch was present at Singapore as the FPS was around 100-125 because it is night and street track. Monaco is a street track and my FPS is high there too.

We may be doing Monza again but I will fight to make sure we don't take a street track but one that should put the draw distance to the test and hit the FPS rate.

GFE 3.x wormed it's way on, because I let Microsoft install the driver (384.94) I could not control the install and there were no files to delete and modify to stop GFE 2.x from updating. So I have the latest GFE for now, but that should hopefully not update.

Share this post


Link to post
Share on other sites
I won't call it "micro" stutter-- more like 1 sec or so of freezing.
EDIT: All people who got this: Are you by somehow using Logitech wheels, especially G27?
What about USB headsets?
GTX 970.
Asus ROG 27" monitor, no vSync, SSD hd, all at "low".
Full screen, xxxx x 1440 resolution.
TT and events so far.
Normally comes after 3-5 minutes use, and often that's the most but not always.

Share this post


Link to post
Share on other sites
ChokDK said:
I won't call it "micro" stutter-- more like 1 sec or so of freezing.
EDIT: All people who got this: Are you by somehow using Logitech wheels, especially G27?
What about USB headsets?
GTX 970.
Asus ROG 27" monitor, no vSync, SSD hd, all at "low".
Full screen, xxxx x 1440 resolution.
TT and events so far.
Normally comes after 3-5 minutes use, and often that's the most but not always.

I ditched the USB section of my headset and now plug it straight into the front audio because I was trying to isolate the poor feeling of the wheel in F1 2016.

But as you see;
GTX970
Samsung 40" LED TV (HDMI, Game Mode), no vSync, SSHD "high" with texture streaming at 'Ultra Low'
Fullscreen (windowed), 1920x1080 resolution
I get a black screen occasionally when FPS>100 for a few minutes.
But yes, my sig has my wheel and headset.

Share this post


Link to post
Share on other sites
As for the stutter, no problems but I only lasted 5 laps.

It's noticeable on spectator cam that the cars don't update quickly in the corners but not bad on the straights unless internet connection is quite bad.

Most cars were running from Europe (France, Finland, Holland, Germany and UK) to my UK connection. I think we had 1 US driver in the lobby of 18 cars.

We deliberately migrated the host and the game survived.

Still getting illegal overtake on lapped (disconnected AI) cars.

Patch level: 1.6
Mode: Custom MP (Invite Only)
Track: Monza (100%, Formation Lap, No Qualifying)

@F1Support


Share this post


Link to post
Share on other sites
Still having this issue.. No fix yet?

I have that AOR eSport thing tomorrow so won't be ideal :/ Really bad on Bahrain for some reason and only occurs on mp @F1Support

Share this post


Link to post
Share on other sites
Just to note, i did try v-sync on, with v-sync on there's no micro stutter.. but with it on there is awful input lag so it doesn't rectify the problem as have the input lag is just as bad. It doesnt make sense why it only occurs on multiplayer, even with just a lobby of 2

Share this post


Link to post
Share on other sites
StarkzHD said:
Just to note, i did try v-sync on, with v-sync on there's no micro stutter.. but with it on there is awful input lag so it doesn't rectify the problem as have the input lag is just as bad. It doesnt make sense why it only occurs on multiplayer, even with just a lobby of 2
I always used to run with V-SYNC ON on the older games but I used a controller.

Since having a wheel I have exactly the same issue, the input lag is obscene with V-SYNC ON

Share this post


Link to post
Share on other sites
Micro stuttering for me online at times! unacceptable codemasters!! your name is wrong! you are not masters of coding at all! 8 years ffs sort it out! plus all the other bugs as well... you will lose your licence to f1 and hopefully someone else can do a better job instead!!!!!!!!!!!   

Share this post


Link to post
Share on other sites
It's been 1 month since the game was released and the codemaster did not say anything about this problem. Many players run their games over 100fps and everyone is having microstuttering. I hope this problem is resolved as soon as possible.

Someone quotes the moderator to bring this question to technical staff.

Share this post


Link to post
Share on other sites
jlp0209 said:
Ho3n3r said:
jlp0209 said:
Thanks for commenting, guys (and/or girls). I also made sure to update my motherboard to the latest chipset drivers, etc., and still got stuttering at 144Hz. My board is Asus Z270 M9 Hero. My 16gb of RAM passed overnight testing with Memtest. 

My latest experiment is to play with DSR enabled and game set to 3840 x 2160, graphics settings on high, MFAA enabled in NV CP, G-sync enabled, in-game v-sync off. I leave my refresh rate at the normal 144 Hz and no FPS limiter. Seems to really help with (noticeable) microstutter and removes all jaggies to boot, looks stunning compared to DSR off. I took a look at frame times, and the most I've seen is 14ms. Rather high. I don't think it is just the 1080 Ti, I also had issues with F1 2016 and the 1080. Before that, a 980 Ti worked just fine I remember. 

I am close to just getting another motherboard to compare but think that in the end this must be GPU driver related. And based on history, not optimistic it'll ever get addressed. 
Good on you for trying to fix this issue on your own, but it's definitely software-related - I still bet on the game, as I have Assetto Corsa and rFactor 2 and never have these issues with either, and I use them even more.
I swapped my motherboard and PSU just to see if I had a ghost in the machine, but it was exactly the same. All other games run way nicer than F1 2016/17.
Thanks for trying this. Yep, this is definitely solely a Codemasters / game issue. No one from CM has acknowledged this issue, appears they are addressing game breaking bugs first although this one is right up there for me. Not optimistic they will ever address this. 
Someone has posted about high latency issues with Realtek Network and Audio Drivers.

I have ordered another network card and have my eye on a soundcard to test this theory. I doubt it will bear much fruit but I'm already about £500 into changing kit to play a £25 game.

Share this post


Link to post
Share on other sites
jlp0209 said:
Ho3n3r said:
jlp0209 said:
Thanks for commenting, guys (and/or girls). I also made sure to update my motherboard to the latest chipset drivers, etc., and still got stuttering at 144Hz. My board is Asus Z270 M9 Hero. My 16gb of RAM passed overnight testing with Memtest. 

My latest experiment is to play with DSR enabled and game set to 3840 x 2160, graphics settings on high, MFAA enabled in NV CP, G-sync enabled, in-game v-sync off. I leave my refresh rate at the normal 144 Hz and no FPS limiter. Seems to really help with (noticeable) microstutter and removes all jaggies to boot, looks stunning compared to DSR off. I took a look at frame times, and the most I've seen is 14ms. Rather high. I don't think it is just the 1080 Ti, I also had issues with F1 2016 and the 1080. Before that, a 980 Ti worked just fine I remember. 

I am close to just getting another motherboard to compare but think that in the end this must be GPU driver related. And based on history, not optimistic it'll ever get addressed. 
Good on you for trying to fix this issue on your own, but it's definitely software-related - I still bet on the game, as I have Assetto Corsa and rFactor 2 and never have these issues with either, and I use them even more.
I swapped my motherboard and PSU just to see if I had a ghost in the machine, but it was exactly the same. All other games run way nicer than F1 2016/17.
Thanks for trying this. Yep, this is definitely solely a Codemasters / game issue. No one from CM has acknowledged this issue, appears they are addressing game breaking bugs first although this one is right up there for me. Not optimistic they will ever address this. 
Someone has posted about high latency issues with Realtek Network and Audio Drivers.

I have ordered another network card and have my eye on a soundcard to test this theory. I doubt it will bear much fruit but I'm already about £500 into changing kit to play a £25 game.
Lol, I feel your pain. That's interesting, maybe I'll try disabling Realtek networking (I have a PCI-E wifi card anyway) and audio (will use the Nvidia high def audio driver). Honestly after my Sochi qualifying issue (damp track, everyone on slicks, AI lap times are same as they would be on totally dry track, but my lap times are 10-15 seconds slower...because track is wet...), I have not played this game. It is a joke as are CM. I flagged F1 support here and nothing happened. Currently enjoying Project Cars 2 rather than this F1 abomination. 

Share this post


Link to post
Share on other sites
Hi all -
I can confirm I have the exact same issue as described in this post. Not sure if it's been mentioned, but this exact same issue was present in F1 2016, acknowladged but never fixed by Codemasters. They said they couldn't reproduce it (see: http://forums.codemasters.com/discussion/44517/f1-2016-pc-sudden-stuttering-framerate-drop).

Note that this issue was introduced in F1 2016 (2015 was fine). Seems to affect NVIDIA more than ATI users, although both do report problems. Me personally I'm running an Nvidia GTX 1080, with triple monitors @ 144hz. Have tried all the suggestions in this forum to work around the issue but to no avail. I'm using a Logitech G27 with custom Mercedes and Ferrari 2016 F1 rims (https://www.youtube.com/watch?v=rpACfdHPTUg if interested). I've have tried using the stock G27 rim which makes no difference.

It's really frustrating and a massive game-breaker for me.

I'm not into Codemasters bashing as if it wasn't for this issue, I'd be loving this game. But Codies, please have another look into this one. So many people with this issue it must be reproducible.

Share this post


Link to post
Share on other sites
Problem with uploading these to YT is you can't see the stutter as YT reencodes to 60fps.

My trained eye notices T3 on L3 is quite ropey but the rest you'd be hard pushed to see where the stutter is. I can't believe that CM can't reproduce it.

I had mixed results with the new LAN adapter, it severely mitigates the stutter but does not eliminate it. I hope to secure a PCI-E Soundblaster to ditch the Realtek audio as well.

Share this post


Link to post
Share on other sites
Locking to 100fps with MSI Afterburner/Rivatuner @ 144hz Vsync off fixes all stuttering for me, rock solid 10.0ms frame times, never skips a beat.

As soon as you uncap it above 100 though the microstutter frametiming spikes are constant.

100fps is fine though, at least it's fixed.

@trenamax   Why are you sitting on the drivers head? Lower that seat damnit lol

Share this post


Link to post
Share on other sites
kraM1t said:
Locking to 100fps with MSI Afterburner/Rivatuner @ 144hz Vsync off fixes all stuttering for me, rock solid 10.0ms frame times, never skips a beat.

As soon as you uncap it above 100 though the microstutter frametiming spikes are constant.

100fps is fine though, at least it's fixed.

@trenamax   Why are you sitting on the drivers head? Lower that seat damnit lol
Because I don't like to see the on screen wheel when I have a replica in my hands ;) shame there is no option to turn off the on screen wheel

Share this post


Link to post
Share on other sites
Could someone reading this test the following to see if it makes a difference

Setup a 50% Race in Grand Prix Mode in Spain
Make a custom weather so it changes from Heavy Rain to Clear to Heavy Rain
Set to Official Time
Set the Ai so you can "play" with them (drop back out of the slip stream/dirty air and catch back up)
Run the start of the race but do not finish it
Quit the game
shut down the PC
Reboot
Load the game
Go straight to Grand Prix and race

If this improves your stutter please let us know,

If not do the following:
Quit the game
Delete the codemasters folder in the user Temp folder
Reboot
Load the game
Go straight to the Grand Prix and race

If this improves your stutter please let us know.

My logic:
I tested Spain with the above settings and I had stutter whilst recording so I undid everything from previous comments above including moving the Temp folder and moving the game back to the SSD.
I then retested Spain and it worked smooth (30 laps then quit, I did not finish the GP so I could use the setting again).
I closed the game without rebooting and loaded the game again, I got stutter on the first 3 laps (about once per lap, It seems to happen when something happens - for example, Jeff speaks, I hit someone, A Car goes off the track but most noticeable when catching another car or they catch you - maybe when close enough to be affected by the dirty air/slipstream).
I deleted the codemasters temp folder (got the idea due to me moving the Temp folder location) and rebooted.
Re-Ran the GP and it was smooth (23 laps then quit).
Closed the game, reloaded and ran GP and it Stuttered within the first 3 laps.
Shut the PC down and rebooted (without deleting the Temp folder).
Re-Ran the GP and it was smooth until lap 16 then I had "minor" stutter (looked like only a couple of frames were dropped) 5 times till lap 30.

Share this post


Link to post
Share on other sites
Could someone reading this test the following to see if it makes a difference

Setup a 50% Race in Grand Prix Mode in Spain
Make a custom weather so it changes from Heavy Rain to Clear to Heavy Rain
Set to Official Time
Set the Ai so you can "play" with them (drop back out of the slip stream/dirty air and catch back up)
Run the start of the race but do not finish it
Quit the game
shut down the PC
Reboot
Load the game
Go straight to Grand Prix and race

If this improves your stutter please let us know,

If not do the following:
Quit the game
Delete the codemasters folder in the user Temp folder
Reboot
Load the game
Go straight to the Grand Prix and race

If this improves your stutter please let us know.

My logic:
I tested Spain with the above settings and I had stutter whilst recording so I undid everything from previous comments above including moving the Temp folder and moving the game back to the SSD.
I then retested Spain and it worked smooth (30 laps then quit, I did not finish the GP so I could use the setting again).
I closed the game without rebooting and loaded the game again, I got stutter on the first 3 laps (about once per lap, It seems to happen when something happens - for example, Jeff speaks, I hit someone, A Car goes off the track but most noticeable when catching another car or they catch you - maybe when close enough to be affected by the dirty air/slipstream).
I deleted the codemasters temp folder (got the idea due to me moving the Temp folder location) and rebooted.
Re-Ran the GP and it was smooth (23 laps then quit).
Closed the game, reloaded and ran GP and it Stuttered within the first 3 laps.
Shut the PC down and rebooted (without deleting the Temp folder).
Re-Ran the GP and it was smooth until lap 16 then I had "minor" stutter (looked like only a couple of frames were dropped) 5 times till lap 30.
I followed this but don't follow the logic. Are you saying deleting/not deleting the Temp folder cures the stutter because it doesn't.

Share this post


Link to post
Share on other sites
Sorry it didn't work for you, thanks for trying.

I have only tested it on one machine but from my logic it appeared that rebooting the machine (not deleting the temp folder) reduced the stutter.

Deleting the temp folder and rebooting removed the stutter.

Both only worked on the first session loaded.  If I closed the game and reloaded or went back to the main menu without deleting and rebooting the next session would stutter.

I have however only did this once as described in my post so it could be a "false positive".

Since the post I have completed a 50% career race (inc. all practices and short quali), deleted temp folder+rebooted then did a 2h multiplayer (which included Australia in the rain, Bahrain, Monaco in the rain and at night, Spain in the rain, Canada in the rain, China in the rain and Baku.  All of which have stuttered in the past but yesterday not even a micro stutter.

I was hoping someone else could get similar results to try and pinpoint the issue.

Kindest regards.

Share this post


Link to post
Share on other sites
The stuttering seems related to career mode IMO. I did a test race the other night at Singapore to prepare myself for the actual career race, and I had no stutters. Then I went into career, started doing the last few practice programs and stuttering was back. It wasn't gone during the actual race either.

Perhaps it might even be the career score variables that probably record most things you do - something that clearly doesn't happen during once-off races.

Share this post


Link to post
Share on other sites
Ho3n3r said:
The stuttering seems related to career mode IMO. I did a test race the other night at Singapore to prepare myself for the actual career race, and I had no stutters. Then I went into career, started doing the last few practice programs and stuttering was back. It wasn't gone during the actual race either.

Perhaps it might even be the career score variables that probably record most things you do - something that clearly doesn't happen during once-off races.
Did you reboot between the test race and career session?

Share this post


Link to post
Share on other sites
Ho3n3r said:
The stuttering seems related to career mode IMO. I did a test race the other night at Singapore to prepare myself for the actual career race, and I had no stutters. Then I went into career, started doing the last few practice programs and stuttering was back. It wasn't gone during the actual race either.

Perhaps it might even be the career score variables that probably record most things you do - something that clearly doesn't happen during once-off races.

Nope. I never do career, only to pick my driver name and number. I race MP and Quick Race as well as use TT and TT is the only one it isn't there in as often (the start/finish new PB causes a stutter).

Better with a non-Realtek LAN card, still waiting on a sound card.

Share this post


Link to post
Share on other sites
Sorry it didn't work for you, thanks for trying.

I have only tested it on one machine but from my logic it appeared that rebooting the machine (not deleting the temp folder) reduced the stutter.

Deleting the temp folder and rebooting removed the stutter.

Both only worked on the first session loaded.  If I closed the game and reloaded or went back to the main menu without deleting and rebooting the next session would stutter.

I have however only did this once as described in my post so it could be a "false positive".

Since the post I have completed a 50% career race (inc. all practices and short quali), deleted temp folder+rebooted then did a 2h multiplayer (which included Australia in the rain, Bahrain, Monaco in the rain and at night, Spain in the rain, Canada in the rain, China in the rain and Baku.  All of which have stuttered in the past but yesterday not even a micro stutter.

I was hoping someone else could get similar results to try and pinpoint the issue.

Kindest regards.
I will test this anecdotally. I'll make a point of rebooting or not and let you know.

Share this post


Link to post
Share on other sites
Ho3n3r said:
The stuttering seems related to career mode IMO. I did a test race the other night at Singapore to prepare myself for the actual career race, and I had no stutters. Then I went into career, started doing the last few practice programs and stuttering was back. It wasn't gone during the actual race either.

Perhaps it might even be the career score variables that probably record most things you do - something that clearly doesn't happen during once-off races.
Did you reboot between the test race and career session?
I did not.

Share this post


Link to post
Share on other sites

×